summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-21 07:30:41 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-21 07:30:41 +0000
commit46be8f300cd666bf3aea597b22b37e6ea8733d7a (patch)
tree0a368e0c65ce11b1ebee48ef5210ed9018681826 /games-arcade/methane/methane-1.4.8.ebuild
parentx86 stable per bug 364191 (diff)
downloadgentoo-2-46be8f300cd666bf3aea597b22b37e6ea8733d7a.tar.gz
gentoo-2-46be8f300cd666bf3aea597b22b37e6ea8733d7a.tar.bz2
gentoo-2-46be8f300cd666bf3aea597b22b37e6ea8733d7a.zip
Build with gcc-4.6 Bug #362381
Enabling parallell compilation (Portage version: 2.1.9.46/cvs/Linux i686)
Diffstat (limited to 'games-arcade/methane/methane-1.4.8.ebuild')
-rw-r--r--games-arcade/methane/methane-1.4.8.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/games-arcade/methane/methane-1.4.8.ebuild b/games-arcade/methane/methane-1.4.8.ebuild
index 6034ba066b48..be32c13a3aa8 100644
--- a/games-arcade/methane/methane-1.4.8.ebuild
+++ b/games-arcade/methane/methane-1.4.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/methane/methane-1.4.8.ebuild,v 1.7 2010/10/01 05:00:17 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/methane/methane-1.4.8.ebuild,v 1.8 2011/04/21 07:30:41 tupone Exp $
EAPI=2
inherit eutils games
@@ -28,13 +28,14 @@ src_prepare() {
fi
sed -i \
-e "s:/var/games:${GAMES_STATEDIR}:" \
- source/linux/doc.cpp history \
+ source/linux/doc.cpp \
|| die "sed failed"
- epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
}
src_compile() {
- emake -C source/linux -j1 || die "emake failed"
+ emake -C source/linux || die "emake failed"
}
src_install() {