summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-13 23:57:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-13 23:57:05 +0000
commit15d5c8e9331b7266cc044b6c97040c379a1409a3 (patch)
tree0b43aa52a52a2a640cb62442755580298731ecdc /games-arcade/monkey-bubble
parentimport for science overlay (diff)
downloadgentoo-2-15d5c8e9331b7266cc044b6c97040c379a1409a3.tar.gz
gentoo-2-15d5c8e9331b7266cc044b6c97040c379a1409a3.tar.bz2
gentoo-2-15d5c8e9331b7266cc044b6c97040c379a1409a3.zip
use app-text/rarian instead of app-text/scrollkeeper
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade/monkey-bubble')
-rw-r--r--games-arcade/monkey-bubble/ChangeLog6
-rw-r--r--games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch4
-rw-r--r--games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild8
3 files changed, 13 insertions, 5 deletions
diff --git a/games-arcade/monkey-bubble/ChangeLog b/games-arcade/monkey-bubble/ChangeLog
index 76b20f14d1ec..c832f15df908 100644
--- a/games-arcade/monkey-bubble/ChangeLog
+++ b/games-arcade/monkey-bubble/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/monkey-bubble
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/ChangeLog,v 1.32 2015/02/06 22:44:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/ChangeLog,v 1.33 2015/02/13 23:57:05 mr_bones_ Exp $
+
+ 13 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ files/monkey-bubble-0.4.0-asneeded.patch, monkey-bubble-0.4.0.ebuild:
+ use app-text/rarian instead of app-text/scrollkeeper
06 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
monkey-bubble-0.4.0.ebuild:
diff --git a/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch
index 7083cbeab23c..1e8822d0f871 100644
--- a/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch
+++ b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch
@@ -9,7 +9,7 @@
../monkey/libmonkey.a \
- ../util/libmonkeyutil.a
+ ../util/libmonkeyutil.a \
-+ $(MONKEY_SRV_LIBS)
++ $(MONKEY_SRV_LIBS) -lm
$(libmonkeynet_a_OBJECTS): $(marshal_sources)
@@ -27,4 +27,4 @@
../audio/libmonkeyaudio.a \
- ../input/libmbinput.a
+ ../input/libmbinput.a \
-+ $(UI_LIBS)
++ $(UI_LIBS) -lm
diff --git a/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild b/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild
index 89724a9a9386..06f9acd3c363 100644
--- a/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild
+++ b/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild,v 1.13 2015/02/06 22:44:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild,v 1.14 2015/02/13 23:57:05 mr_bones_ Exp $
EAPI=5
inherit autotools eutils gnome2
@@ -23,7 +23,7 @@ RDEPEND="x11-libs/gtk+:2
media-libs/gstreamer:0.10
>=dev-libs/libxml2-2.6.7"
DEPEND="${RDEPEND}
- app-text/scrollkeeper
+ app-text/rarian
app-text/gnome-doc-utils
dev-util/intltool"
@@ -35,6 +35,10 @@ src_prepare() {
"${FILESDIR}"/${P}-glib-single-include.patch
# bug 260895
sed -i -e 's/ -Werror//' $(find . -name Makefile.am) || die
+ sed -i \
+ -e '/^Icon/s/.png//' \
+ -e '/^Categories/s/Application;//' \
+ monkey-bubble.desktop.in || die
AT_NOELIBTOOLIZE=yes eautoreconf
gnome2_src_prepare
}