summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-04-22 21:11:21 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-04-22 21:11:21 +0000
commitb12afecd769b021c81807b3e6d136c3441274046 (patch)
treea340a28a35622c223b682210fefd95e2270735bd /games-arcade/monster-masher
parentRemove kdepim-4.4.11.1 package mask (diff)
downloadgentoo-2-b12afecd769b021c81807b3e6d136c3441274046.tar.gz
gentoo-2-b12afecd769b021c81807b3e6d136c3441274046.tar.bz2
gentoo-2-b12afecd769b021c81807b3e6d136c3441274046.zip
Version bump. Port to libcanberra, bug #348605.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/monster-masher')
-rw-r--r--games-arcade/monster-masher/ChangeLog9
-rw-r--r--games-arcade/monster-masher/files/monster-masher-1.8.1-libcanberra.patch85
-rw-r--r--games-arcade/monster-masher/monster-masher-1.8.1-r1.ebuild43
3 files changed, 136 insertions, 1 deletions
diff --git a/games-arcade/monster-masher/ChangeLog b/games-arcade/monster-masher/ChangeLog
index 323d8f3664c0..5f8883fec541 100644
--- a/games-arcade/monster-masher/ChangeLog
+++ b/games-arcade/monster-masher/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-arcade/monster-masher
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/monster-masher/ChangeLog,v 1.23 2011/03/29 07:49:10 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monster-masher/ChangeLog,v 1.24 2011/04/22 21:11:21 eva Exp $
+
+*monster-masher-1.8.1-r1 (22 Apr 2011)
+
+ 22 Apr 2011; Gilles Dartiguelongue <eva@gentoo.org>
+ +monster-masher-1.8.1-r1.ebuild,
+ +files/monster-masher-1.8.1-libcanberra.patch:
+ Version bump. Port to libcanberra, bug #348605.
29 Mar 2011; Christoph Mende <angelos@gentoo.org>
monster-masher-1.8.1.ebuild:
diff --git a/games-arcade/monster-masher/files/monster-masher-1.8.1-libcanberra.patch b/games-arcade/monster-masher/files/monster-masher-1.8.1-libcanberra.patch
new file mode 100644
index 000000000000..4ee47fab39fb
--- /dev/null
+++ b/games-arcade/monster-masher/files/monster-masher-1.8.1-libcanberra.patch
@@ -0,0 +1,85 @@
+Drop dependency on esound support in libgnome and replace it by libcanberra.
+
+Gentoo bug: #348605
+
+--- a/configure.ac 2008-11-09 20:52:01.000000000 +0000
++++ b/configure.ac 2011-03-06 13:08:42.000000000 +0000
+@@ -18,7 +18,8 @@
+ gconfmm-2.6 >= 2.6.0 \
+ gtkmm-2.4 >= 2.6.0 \
+ libgnomecanvasmm-2.6 >= 2.6.0 \
+- libglademm-2.4 >= 2.4.0)
++ libglademm-2.4 >= 2.4.0 \
++ libcanberra)
+ AC_SUBST(DEPS_CFLAGS)
+ AC_SUBST(DEPS_LIBS)
+
+--- a/src/sound.hpp 2007-01-06 16:16:30.000000000 +0000
++++ b/src/sound.hpp 2011-03-06 13:12:47.000000000 +0000
+@@ -22,6 +22,7 @@
+ #define SOUND_HPP
+
+ #include <string>
++#include <canberra.h>
+
+ #include "helpers.hpp"
+
+@@ -39,8 +40,7 @@
+ private:
+ Sound();
+
+- typedef std::map<std::string, int> cache_map;
+- cache_map cache;
++ ca_context *ctx;
+ };
+
+ #endif
+--- a/src/sound.cpp 2007-01-06 16:16:30.000000000 +0000
++++ b/src/sound.cpp 2011-03-07 21:55:47.000000000 +0000
+@@ -18,9 +18,6 @@
+ * USA.
+ */
+
+-#include <libgnome/gnome-sound.h>
+-#include <esd.h>
+-
+ #include "sound.hpp"
+
+
+@@ -30,26 +27,23 @@
+ return s;
+ }
+
+-Sound::Sound()
++Sound::Sound() :
++ ctx(0)
+ {
++ ca_context_create(&ctx);
+ }
+
+ Sound::~Sound()
+ {
++ if (ctx)
++ ca_context_destroy(ctx);
+ }
+
+ void Sound::play(const std::string &name)
+ {
+- int id;
+-
+- cache_map::iterator i = cache.find(name);
+- if (i != cache.end())
+- id = i->second;
+- else {
+- id = gnome_sound_sample_load(name.c_str(),
+- (MONSTER_MASHER_SOUND_DIR + name).c_str());
+- cache.insert(make_pair(name, id));
+- }
+-
+- esd_sample_play(gnome_sound_connection_get(), id);
++ if (ctx)
++ ca_context_play(ctx, 0,
++ CA_PROP_MEDIA_FILENAME, (MONSTER_MASHER_SOUND_DIR + name).c_str(),
++ CA_PROP_CANBERRA_CACHE_CONTROL, "permanent",
++ NULL);
+ }
diff --git a/games-arcade/monster-masher/monster-masher-1.8.1-r1.ebuild b/games-arcade/monster-masher/monster-masher-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..7558d208c414
--- /dev/null
+++ b/games-arcade/monster-masher/monster-masher-1.8.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monster-masher/monster-masher-1.8.1-r1.ebuild,v 1.1 2011/04/22 21:11:21 eva Exp $
+
+EAPI=3
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Squash the monsters with your levitation worker gnome"
+HOMEPAGE="http://people.iola.dk/olau/monster-masher/"
+SRC_URI="http://people.iola.dk/olau/monster-masher/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libSM
+ >=dev-cpp/gtkmm-2.6:2.4
+ >=dev-cpp/gconfmm-2.6
+ >=dev-cpp/libglademm-2.4:2.4
+ >=dev-cpp/libgnomecanvasmm-2.6:2.6
+ gnome-base/libgnome
+ media-libs/libcanberra"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ # Port to libcanberra, bug #348605
+ epatch "${FILESDIR}"/${P}-libcanberra.patch
+
+ intltoolize --force --copy --automake || die
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README" gnome2_src_install
+}