summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-16 12:02:51 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-16 12:02:51 +0000
commit3ec5ae82cf0d79f98a29f5ba846d772c727290af (patch)
tree414bb82184beed075fb99be5f58fbf442e377b1d /games-arcade/performous
parentApply correction to REQUIRED_USE, bug #416245. (diff)
downloadgentoo-2-3ec5ae82cf0d79f98a29f5ba846d772c727290af.tar.gz
gentoo-2-3ec5ae82cf0d79f98a29f5ba846d772c727290af.tar.bz2
gentoo-2-3ec5ae82cf0d79f98a29f5ba846d772c727290af.zip
Build with libav and thus depend on virtual/ffmpeg.
(Portage version: 2.2.0_alpha105/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/performous')
-rw-r--r--games-arcade/performous/ChangeLog6
-rw-r--r--games-arcade/performous/files/performous-0.6.1-libav.patch41
-rw-r--r--games-arcade/performous/performous-0.6.1.ebuild5
3 files changed, 49 insertions, 3 deletions
diff --git a/games-arcade/performous/ChangeLog b/games-arcade/performous/ChangeLog
index 4adf1fad39e4..396ed7169966 100644
--- a/games-arcade/performous/ChangeLog
+++ b/games-arcade/performous/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/performous
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.7 2012/03/15 03:54:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.8 2012/05/16 12:02:51 scarabeus Exp $
+
+ 16 May 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/performous-0.6.1-libav.patch, performous-0.6.1.ebuild:
+ Build with libav and thus depend on virtual/ffmpeg.
15 Mar 2012; Michael Sterrett <mr_bones_@gentoo.org> performous-0.6.1.ebuild:
games-arcade/ultrastar-ng is gone
diff --git a/games-arcade/performous/files/performous-0.6.1-libav.patch b/games-arcade/performous/files/performous-0.6.1-libav.patch
new file mode 100644
index 000000000000..b598dc0a488a
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.6.1-libav.patch
@@ -0,0 +1,41 @@
+diff -urN Performous-0.6.1-Source.old/cmake/Modules/FindAVUtil.cmake Performous-0.6.1-Source/cmake/Modules/FindAVUtil.cmake
+--- Performous-0.6.1-Source.old/cmake/Modules/FindAVUtil.cmake 2012-05-16 13:44:26.112930173 +0200
++++ Performous-0.6.1-Source/cmake/Modules/FindAVUtil.cmake 2012-05-16 13:56:10.229914635 +0200
+@@ -25,9 +25,15 @@
+ if(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}avutil.h")
+ set(AVUtil_INCLUDE "${suffix}avutil.h")
+ endif(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}avutil.h")
++ if(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}mathematics.h")
++ set(AVUtilMath_INCLUDE "${suffix}mathematics.h")
++ endif(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}mathematics.h")
+ endif(NOT AVUtil_INCLUDE)
+ endforeach(suffix)
+
++ if(NOT AVUtilMath_INCLUDE)
++ message(FATAL_ERROR "Found mathematics.h include dir, but not the header file. Perhaps you need to clear CMake cache?")
++ endif(NOT AVUtilMath_INCLUDE)
+ if(NOT AVUtil_INCLUDE)
+ message(FATAL_ERROR "Found avutil.h include dir, but not the header file. Perhaps you need to clear CMake cache?")
+ endif(NOT AVUtil_INCLUDE)
+diff -urN Performous-0.6.1-Source.old/game/config.cmake.hh Performous-0.6.1-Source/game/config.cmake.hh
+--- Performous-0.6.1-Source.old/game/config.cmake.hh 2012-05-16 13:44:26.103930173 +0200
++++ Performous-0.6.1-Source/game/config.cmake.hh 2012-05-16 13:59:24.552910345 +0200
+@@ -15,6 +15,7 @@
+ #define AVCODEC_INCLUDE <@AVCodec_INCLUDE@>
+ #define AVFORMAT_INCLUDE <@AVFormat_INCLUDE@>
+ #define SWSCALE_INCLUDE <@SWScale_INCLUDE@>
++#define AVUTILMATH_INCLUDE <@AVUtilMath_INCLUDE@>
+
+ #endif
+
+diff -urN Performous-0.6.1-Source.old/game/ffmpeg.cc Performous-0.6.1-Source/game/ffmpeg.cc
+--- Performous-0.6.1-Source.old/game/ffmpeg.cc 2012-05-16 13:44:26.101930173 +0200
++++ Performous-0.6.1-Source/game/ffmpeg.cc 2012-05-16 14:00:38.278908717 +0200
+@@ -10,6 +10,7 @@
+ #include AVCODEC_INCLUDE
+ #include AVFORMAT_INCLUDE
+ #include SWSCALE_INCLUDE
++#include AVUTILMATH_INCLUDE
+ }
+
+ // #define USE_FFMPEG_CRASH_RECOVERY
diff --git a/games-arcade/performous/performous-0.6.1.ebuild b/games-arcade/performous/performous-0.6.1.ebuild
index cb6251219458..c4c24225677f 100644
--- a/games-arcade/performous/performous-0.6.1.ebuild
+++ b/games-arcade/performous/performous-0.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/performous-0.6.1.ebuild,v 1.7 2012/03/15 03:54:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/performous-0.6.1.ebuild,v 1.8 2012/05/16 12:02:51 scarabeus Exp $
EAPI="3"
@@ -40,9 +40,9 @@ RDEPEND="dev-cpp/glibmm
virtual/jpeg
media-libs/libpng
media-libs/libsdl
+ virtual/ffmpeg
virtual/opengl
virtual/glu
- media-video/ffmpeg
sys-libs/zlib
x11-libs/cairo
x11-libs/gdk-pixbuf
@@ -55,6 +55,7 @@ S=${WORKDIR}/${MY_P}-Source
PATCHES=(
"${FILESDIR}"/${P}-ffmpeg.patch
+ "${FILESDIR}"/${P}-libav.patch
"${FILESDIR}"/${P}-libpng.patch
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-linguas.patch