summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-06-03 20:40:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-06-03 20:40:14 +0000
commit3f7563e4fae01b0a8c080c1702b289de22e3cbdc (patch)
tree3c7ebb4965b9247db0ae0b2e93451236361198a4 /games-arcade/sdl-sopwith
parentsys-libs/cracklib doesn't need dev-python/setuptools at run-time. (diff)
downloadgentoo-2-3f7563e4fae01b0a8c080c1702b289de22e3cbdc.tar.gz
gentoo-2-3f7563e4fae01b0a8c080c1702b289de22e3cbdc.tar.bz2
gentoo-2-3f7563e4fae01b0a8c080c1702b289de22e3cbdc.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-arcade/sdl-sopwith')
-rw-r--r--games-arcade/sdl-sopwith/ChangeLog10
-rw-r--r--games-arcade/sdl-sopwith/sdl-sopwith-1.7.2.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/games-arcade/sdl-sopwith/ChangeLog b/games-arcade/sdl-sopwith/ChangeLog
index 616461ce82ee..df2b9c16d944 100644
--- a/games-arcade/sdl-sopwith/ChangeLog
+++ b/games-arcade/sdl-sopwith/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/sdl-sopwith
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdl-sopwith/ChangeLog,v 1.8 2007/04/24 15:11:26 drizzt Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdl-sopwith/ChangeLog,v 1.9 2010/06/03 20:40:14 mr_bones_ Exp $
+
+*sdl-sopwith-1.7.2 (03 Jun 2010)
+
+ 03 Jun 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +sdl-sopwith-1.7.2.ebuild:
+ version bump
24 Apr 2007; Timothy Redaelli <drizzt@gentoo.org>
sdl-sopwith-1.7.1.ebuild:
diff --git a/games-arcade/sdl-sopwith/sdl-sopwith-1.7.2.ebuild b/games-arcade/sdl-sopwith/sdl-sopwith-1.7.2.ebuild
new file mode 100644
index 000000000000..adb10e8475de
--- /dev/null
+++ b/games-arcade/sdl-sopwith/sdl-sopwith-1.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdl-sopwith/sdl-sopwith-1.7.2.ebuild,v 1.1 2010/06/03 20:40:14 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+MY_P=${P/sdl-/}
+DESCRIPTION="Port of the classic Sopwith game using LibSDL"
+HOMEPAGE="http://sdl-sopwith.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND=">=media-libs/freetype-2
+ >=media-libs/libsdl-1.1.3
+ dev-libs/atk
+ x11-libs/pango
+ >=x11-libs/gtk+-2
+ >=dev-libs/glib-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog FAQ NEWS README TODO doc/*txt
+ rm -rf "${D}/usr/games/share/"
+ prepgamesdirs
+}