summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-02-17 09:29:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-02-17 09:29:16 +0000
commitb509c3e751e43625572763000e6b11ed6403329e (patch)
tree2eb8837b8cd8c05b89afb425bdd7632458f5c2a5 /games-arcade/solarwolf
parentmasked due to API changes which break apps. (Manifest recommit) (diff)
downloadgentoo-2-b509c3e751e43625572763000e6b11ed6403329e.tar.gz
gentoo-2-b509c3e751e43625572763000e6b11ed6403329e.tar.bz2
gentoo-2-b509c3e751e43625572763000e6b11ed6403329e.zip
version bump
Diffstat (limited to 'games-arcade/solarwolf')
-rw-r--r--games-arcade/solarwolf/ChangeLog7
-rw-r--r--games-arcade/solarwolf/Manifest2
-rw-r--r--games-arcade/solarwolf/files/digest-solarwolf-1.51
-rw-r--r--games-arcade/solarwolf/solarwolf-1.5.ebuild35
4 files changed, 44 insertions, 1 deletions
diff --git a/games-arcade/solarwolf/ChangeLog b/games-arcade/solarwolf/ChangeLog
index fbc2263d6e3f..b6ba4f49167d 100644
--- a/games-arcade/solarwolf/ChangeLog
+++ b/games-arcade/solarwolf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/solarwolf
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/ChangeLog,v 1.6 2004/01/29 07:07:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/ChangeLog,v 1.7 2004/02/17 09:29:16 mr_bones_ Exp $
+
+*solarwolf-1.5 (17 Feb 2004)
+
+ 17 Feb 2004; Michael Sterrett <mr_bones_@gentoo.org> solarwolf-1.5.ebuild:
+ version bump
28 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org> solarwolf-1.3.ebuild,
solarwolf-1.4.ebuild:
diff --git a/games-arcade/solarwolf/Manifest b/games-arcade/solarwolf/Manifest
index c09e4873e881..906d25fd819f 100644
--- a/games-arcade/solarwolf/Manifest
+++ b/games-arcade/solarwolf/Manifest
@@ -2,7 +2,9 @@ MD5 bba475a41251de3d0804ee9d8efeda22 ChangeLog 1040
MD5 debab15fd91889f9c2878677d41db550 solarwolf-1.3.ebuild 772
MD5 b244cf1c41a78cacb62296d573935c07 metadata.xml 245
MD5 8dde7dab78e538b46020d63ad1f13217 solarwolf-1.4.ebuild 953
+MD5 8dde7dab78e538b46020d63ad1f13217 solarwolf-1.5.ebuild 953
MD5 61ffe85eee861987219a25b6ac70649c files/digest-solarwolf-1.3 66
MD5 9f30c7cc7d9b6ec57451e1c365384e2d files/solarwolf 58
MD5 fff7bbad80960e659612a131e965283e files/digest-solarwolf-1.4 66
MD5 52a86f532680a28435dbf476e7d2482c files/solarwolf.png 3441
+MD5 4774b024dd42384d07d8597a56a5a64e files/digest-solarwolf-1.5 66
diff --git a/games-arcade/solarwolf/files/digest-solarwolf-1.5 b/games-arcade/solarwolf/files/digest-solarwolf-1.5
new file mode 100644
index 000000000000..926c9e950c14
--- /dev/null
+++ b/games-arcade/solarwolf/files/digest-solarwolf-1.5
@@ -0,0 +1 @@
+MD5 52fbed0a33c3c4c08d9dc0e533f90f8c solarwolf-1.5.tar.gz 2045888
diff --git a/games-arcade/solarwolf/solarwolf-1.5.ebuild b/games-arcade/solarwolf/solarwolf-1.5.ebuild
new file mode 100644
index 000000000000..c2ec90823a1a
--- /dev/null
+++ b/games-arcade/solarwolf/solarwolf-1.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.5.ebuild,v 1.1 2004/02/17 09:29:16 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="action/arcade recreation of SolarFox"
+HOMEPAGE="http://www.pygame.org/shredwheat/solarwolf/"
+SRC_URI="http://www.pygame.org/shredwheat/solarwolf/${P}.tar.gz"
+
+KEYWORDS="x86 ~sparc hppa"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/pygame-1.5.6
+ >=dev-lang/python-2.3
+ media-libs/libsdl"
+
+src_unpack() {
+ unpack ${A}
+ find ${S} -name .xvpics | xargs rm -rf
+}
+
+src_install() {
+ dodoc readme.txt
+ doman dist/solarwolf.6.gz
+ dodir ${GAMES_LIBDIR}/${PN}
+ cp -r code/ data/ *py ${D}/${GAMES_LIBDIR}/${PN}/ || die "cp failed"
+ games_make_wrapper solarwolf "python ./solarwolf.py" ${GAMES_LIBDIR}/${PN}
+ insinto /usr/share/icons
+ doins dist/solarwolf.png
+ make_desktop_entry solarwolf
+ prepgamesdirs
+}