summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-16 07:27:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-16 07:27:31 +0000
commit34a661fd8c911073afbdd15e2f160286e30e436a (patch)
treef536c752d51f42d160bc5f678e4e905eb0cc0e72 /games-arcade
parentMove to virtual/pmw (diff)
downloadgentoo-2-34a661fd8c911073afbdd15e2f160286e30e436a.tar.gz
gentoo-2-34a661fd8c911073afbdd15e2f160286e30e436a.tar.bz2
gentoo-2-34a661fd8c911073afbdd15e2f160286e30e436a.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/supertransball2/ChangeLog9
-rw-r--r--games-arcade/supertransball2/supertransball2-1.5.ebuild20
2 files changed, 18 insertions, 11 deletions
diff --git a/games-arcade/supertransball2/ChangeLog b/games-arcade/supertransball2/ChangeLog
index 3d090e6b80dc..91aad30bc4fd 100644
--- a/games-arcade/supertransball2/ChangeLog
+++ b/games-arcade/supertransball2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/supertransball2
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertransball2/ChangeLog,v 1.5 2010/10/16 19:41:49 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertransball2/ChangeLog,v 1.6 2015/03/16 07:27:31 mr_bones_ Exp $
+
+ 16 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ supertransball2-1.5.ebuild:
+ EAPI=5
16 Oct 2010; Tupone Alfredo <tupone@gentoo.org>
supertransball2-1.5.ebuild, +files/supertransball2-1.5-ldflags.patch:
@@ -23,4 +27,3 @@
11 Feb 2007; <tupone@gentoo.org> +metadata.xml,
+supertransball2-1.5.ebuild:
New ebuild by brebs. Bug #109199 by desowin.
-
diff --git a/games-arcade/supertransball2/supertransball2-1.5.ebuild b/games-arcade/supertransball2/supertransball2-1.5.ebuild
index 064accf35799..95badeaf0fc7 100644
--- a/games-arcade/supertransball2/supertransball2-1.5.ebuild
+++ b/games-arcade/supertransball2/supertransball2-1.5.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertransball2/supertransball2-1.5.ebuild,v 1.5 2010/10/16 19:41:49 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertransball2/supertransball2-1.5.ebuild,v 1.6 2015/03/16 07:27:31 mr_bones_ Exp $
+EAPI=5
inherit eutils versionator games
MY_PV=$(delete_all_version_separators)
@@ -18,7 +19,7 @@ SLOT="0"
KEYWORDS="x86 ~x86-fbsd"
IUSE=""
-RDEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl[sound,video]
media-libs/sdl-image
media-libs/sdl-mixer
media-libs/sdl-sound
@@ -31,10 +32,13 @@ S=${WORKDIR}/${P}/sources
src_unpack() {
unpack ${A}
mv -f "${FILE}" ${P}
+}
+src_prepare() {
+ cd "${WORKDIR}"
sed -i \
-e "s:/usr/share/games:${GAMES_DATADIR}:" \
- "${DEBIAN_PATCH}" || die "sed patch failed"
+ "${DEBIAN_PATCH}" || die
epatch "${DEBIAN_PATCH}"
@@ -53,13 +57,13 @@ src_unpack() {
src_install() {
cd ..
- dogamesbin ${PN} || die "dogamesbin failed"
+ dogamesbin ${PN}
make_desktop_entry ${PN} "Super Transball 2"
- dodoc readme.txt || die "Installing doc failed"
- doman debian/supertransball2.6 || die "Installing man page failed"
+ dodoc readme.txt
+ doman debian/supertransball2.6
insinto "${GAMES_DATADIR}/${PN}"
- doins -r demos graphics maps sound || die "doins -r failed"
+ doins -r demos graphics maps sound
prepgamesdirs
}