summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-10-12 03:49:33 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-10-12 03:49:33 +0000
commit659ee775316dff8c4540d9665137e24f0f7118ad (patch)
tree1fc8aecec065b9a07fba4e4e30860459bea10fef /games-arcade
parenttidy (diff)
downloadgentoo-2-659ee775316dff8c4540d9665137e24f0f7118ad.tar.gz
gentoo-2-659ee775316dff8c4540d9665137e24f0f7118ad.tar.bz2
gentoo-2-659ee775316dff8c4540d9665137e24f0f7118ad.zip
honor CXX and CXXFLAGS; add use-deps; tidy
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/sdlsasteroids/ChangeLog6
-rw-r--r--games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild20
2 files changed, 18 insertions, 8 deletions
diff --git a/games-arcade/sdlsasteroids/ChangeLog b/games-arcade/sdlsasteroids/ChangeLog
index 5968ff4b25b0..6a28b073c07b 100644
--- a/games-arcade/sdlsasteroids/ChangeLog
+++ b/games-arcade/sdlsasteroids/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/sdlsasteroids
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/ChangeLog,v 1.9 2010/09/22 06:49:33 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/ChangeLog,v 1.10 2010/10/12 03:49:33 mr_bones_ Exp $
+
+ 12 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ sdlsasteroids-3.0.1.ebuild:
+ honor CXX and CXXFLAGS; add use-deps; tidy
22 Sep 2010; Tupone Alfredo <tupone@gentoo.org>
sdlsasteroids-3.0.1.ebuild, +files/sdlsasteroids-3.0.1-ldflags.patch:
diff --git a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
index 69800280d2d6..66eb5f5aea13 100644
--- a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
+++ b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild,v 1.5 2010/09/22 06:49:33 tupone Exp $
-EAPI="2"
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild,v 1.6 2010/10/12 03:49:33 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="Rework of Sasteroids using SDL"
@@ -16,20 +16,26 @@ IUSE=""
DEPEND="virtual/opengl
media-libs/sdl-mixer
- media-libs/libsdl
- media-libs/sdl-image
+ media-libs/libsdl[audio,joystick,video]
+ media-libs/sdl-image[png]
media-libs/sdl-ttf"
S=${WORKDIR}/SDLSasteroids-${PV}
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch \
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-ldflags.patch
- #-e '34 d' \
sed -i \
-e 's/make /$(MAKE) /' \
-e 's/--strip//' \
- Makefile || die "sed Makefile failed"
+ Makefile || die
+ sed -i \
+ -e '/^CC/d' \
+ -e 's/g++/$(CXX)/' \
+ -e 's/CC/CXX/' \
+ -e 's/CFLAGS/CXXFLAGS/' \
+ src/Makefile || die
}
src_compile() {