summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-07-01 22:30:23 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-07-01 22:30:23 +0000
commit662d571647b6cb25c7d000686d51505877ce3017 (patch)
treeda01cfb66da51440c28fc0698dd5300876f8750f /games-arcade
parentNew package, python api for docker (diff)
downloadgentoo-2-662d571647b6cb25c7d000686d51505877ce3017.tar.gz
gentoo-2-662d571647b6cb25c7d000686d51505877ce3017.tar.bz2
gentoo-2-662d571647b6cb25c7d000686d51505877ce3017.zip
fix build wrt #515188
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/commandergenius/ChangeLog6
-rw-r--r--games-arcade/commandergenius/commandergenius-1.7.4.0.ebuild4
-rw-r--r--games-arcade/commandergenius/files/commandergenius-1.7.4.0-build.patch22
3 files changed, 29 insertions, 3 deletions
diff --git a/games-arcade/commandergenius/ChangeLog b/games-arcade/commandergenius/ChangeLog
index 51d4be3dc9d4..813db5d7f7a7 100644
--- a/games-arcade/commandergenius/ChangeLog
+++ b/games-arcade/commandergenius/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/commandergenius
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/commandergenius/ChangeLog,v 1.10 2014/06/01 18:10:51 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/commandergenius/ChangeLog,v 1.11 2014/07/01 22:30:23 hasufell Exp $
+
+ 01 Jul 2014; Julian Ospald <hasufell@gentoo.org>
+ commandergenius-1.7.4.0.ebuild, +files/commandergenius-1.7.4.0-build.patch:
+ fix build wrt #515188
*commandergenius-1.7.4.0 (01 Jun 2014)
diff --git a/games-arcade/commandergenius/commandergenius-1.7.4.0.ebuild b/games-arcade/commandergenius/commandergenius-1.7.4.0.ebuild
index f506cfc5015b..6b85ead3dad6 100644
--- a/games-arcade/commandergenius/commandergenius-1.7.4.0.ebuild
+++ b/games-arcade/commandergenius/commandergenius-1.7.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/commandergenius/commandergenius-1.7.4.0.ebuild,v 1.1 2014/06/01 18:10:51 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/commandergenius/commandergenius-1.7.4.0.ebuild,v 1.2 2014/07/01 22:30:23 hasufell Exp $
EAPI=5
@@ -29,7 +29,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}
src_prepare() {
- epatch "${FILESDIR}"/${P}-install.patch
+ epatch "${FILESDIR}"/${P}-{install,build}.patch
rm -rf vfsroot || die
diff --git a/games-arcade/commandergenius/files/commandergenius-1.7.4.0-build.patch b/games-arcade/commandergenius/files/commandergenius-1.7.4.0-build.patch
new file mode 100644
index 000000000000..52bf4557d9fc
--- /dev/null
+++ b/games-arcade/commandergenius/files/commandergenius-1.7.4.0-build.patch
@@ -0,0 +1,22 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Jul 1 22:23:59 UTC 2014
+Subject: fix build
+
+--- lib/GsKit/CMakeLists.txt
++++ lib/GsKit/CMakeLists.txt
+@@ -48,7 +48,6 @@
+ # pkg_check_modules(SDL sdl)
+ #ENDIF(BUILD_TARGET STREQUAL WIN32)
+
+-Find_Package ( SDL_image REQUIRED )
+
+
+
+@@ -92,6 +91,7 @@
+ set(SDL_IMAGE_LIBRARIES "SDL2_image")
+ target_link_libraries(GsKit ${SDL_IMAGE_LIBRARIES})
+ else(SDL2_FOUND)
++ Find_Package ( SDL_image REQUIRED )
+ target_link_libraries(GsKit ${SDL_LIBRARY})
+ target_link_libraries(GsKit ${SDLIMAGE_LIBRARY})
+ endif(SDL2_FOUND)