summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-04-01 05:09:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-04-01 05:09:52 +0000
commit88056093bda68878101484900a1001d8274e7f30 (patch)
treed1f87f8bc6516ea225e6c69491383c95b41b2876 /games-arcade
parentStable for HPPA (bug #513988). (diff)
downloadgentoo-2-88056093bda68878101484900a1001d8274e7f30.tar.gz
gentoo-2-88056093bda68878101484900a1001d8274e7f30.tar.bz2
gentoo-2-88056093bda68878101484900a1001d8274e7f30.zip
first attempt at patch to fix bug #539658
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/spacerider/ChangeLog7
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-font.patch14
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gcc49.patch22
-rw-r--r--games-arcade/spacerider/spacerider-0.13.ebuild6
4 files changed, 46 insertions, 3 deletions
diff --git a/games-arcade/spacerider/ChangeLog b/games-arcade/spacerider/ChangeLog
index 335a373a2d1d..15b8e82327af 100644
--- a/games-arcade/spacerider/ChangeLog
+++ b/games-arcade/spacerider/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/spacerider
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/ChangeLog,v 1.9 2015/02/15 23:19:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/ChangeLog,v 1.10 2015/04/01 05:09:52 mr_bones_ Exp $
+
+ 01 Apr 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/spacerider-0.13-font.patch, +files/spacerider-0.13-gcc49.patch,
+ spacerider-0.13.ebuild:
+ first attempt at patch to fix bug #539658
15 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> spacerider-0.13.ebuild:
use deps for libsdl
diff --git a/games-arcade/spacerider/files/spacerider-0.13-font.patch b/games-arcade/spacerider/files/spacerider-0.13-font.patch
new file mode 100644
index 000000000000..914a0466c7fe
--- /dev/null
+++ b/games-arcade/spacerider/files/spacerider-0.13-font.patch
@@ -0,0 +1,14 @@
+Ugly brute-force method for avoiding a double-free segfault on exit.
+Better patch welcome.
+
+--- spacerider.cpp.orig 2015-03-31 23:24:17.770966147 -0400
++++ spacerider.cpp 2015-03-31 23:24:41.592174463 -0400
+@@ -306,8 +306,6 @@
+ /* free screen */
+ SDL_FreeSurface(screen);
+ }
+- /* call the TTF-Library cleanup function */
+- TTF_Quit();
+
+ /* call the NET-Library cleanup function */
+ SDLNet_Quit();
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch b/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch
new file mode 100644
index 000000000000..d057e7bab730
--- /dev/null
+++ b/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch
@@ -0,0 +1,22 @@
+--- effect.cpp.orig 2015-03-31 22:36:53.336131373 -0400
++++ effect.cpp 2015-03-31 22:37:04.359755281 -0400
+@@ -18,7 +18,7 @@
+ void Effect::add(const int x, const int y)
+ {
+ object_struct *effect;
+- if((effect = add_object(x, y)) == NULL)
++ if((effect = add_object(x, y, 0, 0)) == NULL)
+ {
+ return;
+ }
+--- object.h.orig 2015-03-31 22:35:22.939214561 -0400
++++ object.h 2015-03-31 22:37:19.654233441 -0400
+@@ -172,7 +172,7 @@
+ return object->next;
+ }
+
+-template <class T>struct Object<T>::object_struct *Object<T>::add_object(const int x, const int y, const int speedx = 0, const int speedy = 0)
++template <class T>struct Object<T>::object_struct *Object<T>::add_object(const int x, const int y, const int speedx, const int speedy)
+ {
+ object_struct *object;
+
diff --git a/games-arcade/spacerider/spacerider-0.13.ebuild b/games-arcade/spacerider/spacerider-0.13.ebuild
index 0a5363e9e134..5c85a1d2bc5c 100644
--- a/games-arcade/spacerider/spacerider-0.13.ebuild
+++ b/games-arcade/spacerider/spacerider-0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/spacerider-0.13.ebuild,v 1.11 2015/02/15 23:19:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/spacerider-0.13.ebuild,v 1.12 2015/04/01 05:09:52 mr_bones_ Exp $
EAPI=5
inherit eutils games
@@ -25,7 +25,9 @@ RDEPEND=${DEPEND}
src_prepare() {
epatch "${FILESDIR}/${P}"-gentoo.patch \
"${FILESDIR}/${P}"-gcc41.patch \
- "${FILESDIR}"/${P}-ovflfix.patch
+ "${FILESDIR}"/${P}-ovflfix.patch \
+ "${FILESDIR}"/${P}-gcc49.patch \
+ "${FILESDIR}"/${P}-font.patch
sed -i \
-e "s:/usr/share/games/spacerider:${GAMES_DATADIR}/${PN}:" \
globals.cpp || die