summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-06-28 05:36:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-06-28 05:36:39 +0000
commitf5e25a0eef5ecbf778080916c33552b95de40382 (patch)
treea679b4acc3812b428eb75ca5e0ef5a06002d1c34 /games-board/domination
parentarm stable, bug #419473 (diff)
downloadgentoo-2-f5e25a0eef5ecbf778080916c33552b95de40382.tar.gz
gentoo-2-f5e25a0eef5ecbf778080916c33552b95de40382.tar.bz2
gentoo-2-f5e25a0eef5ecbf778080916c33552b95de40382.zip
initial commit; package renamed from jrisk
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-board/domination')
-rw-r--r--games-board/domination/ChangeLog10
-rw-r--r--games-board/domination/domination-1.1.0.9.ebuild53
-rw-r--r--games-board/domination/metadata.xml5
3 files changed, 68 insertions, 0 deletions
diff --git a/games-board/domination/ChangeLog b/games-board/domination/ChangeLog
new file mode 100644
index 000000000000..eb55332bbdd9
--- /dev/null
+++ b/games-board/domination/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-board/domination
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/domination/ChangeLog,v 1.1 2012/06/28 05:36:39 mr_bones_ Exp $
+
+*domination-1.1.0.9 (28 Jun 2012)
+
+ 28 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +domination-1.1.0.9.ebuild, +metadata.xml:
+ initial commit; package renamed from jrisk
+
diff --git a/games-board/domination/domination-1.1.0.9.ebuild b/games-board/domination/domination-1.1.0.9.ebuild
new file mode 100644
index 000000000000..ecf294e40165
--- /dev/null
+++ b/games-board/domination/domination-1.1.0.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/domination/domination-1.1.0.9.ebuild,v 1.1 2012/06/28 05:36:39 mr_bones_ Exp $
+
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="The well-known board game, written in java"
+HOMEPAGE="http://domination.sourceforge.net"
+SRC_URI="mirror://sourceforge/domination/Domination_${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+
+S=${WORKDIR}/Domination
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+EANT_BUILD_TARGET="game"
+
+src_compile() {
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ mkdir -p ${D}${GAMES_PREFIX}/bin
+ cp ${S}/FlashGUI.sh ${D}${GAMES_PREFIX}/bin/${PN} \
+ || die "copy failed"
+ sed -i \
+ -e "s|cd.*|cd ${GAMES_DATADIR}/${PN}|" \
+ ${D}${GAMES_PREFIX}/bin/${PN} \
+ || die "sed failed"
+ chmod +x ${D}${GAMES_PREFIX}/bin/${PN} \
+ || die "chmod failed"
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r ${S}/* || die "doins failed"
+ rm -f "${D}${GAMES_DATADIR}"/${PN}/*.cmd || die
+ java-pkg_regjar "${D}/${GAMES_DATADIR}/${PN}"/*.jar
+
+ newicon resources/icon.png ${PN}.png
+ make_desktop_entry ${PN} "Domination"
+
+ prepgamesdirs
+}
diff --git a/games-board/domination/metadata.xml b/games-board/domination/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-board/domination/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>