summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-06 22:39:45 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-06 22:39:45 +0000
commit1102110bba89a790a84264c4d920787f793c7055 (patch)
tree7f2a11b6a3ce7509c682e1ff1a94c6321a5e8d93 /games-board/ggz-txt-client
parentReassigning to crypto herd, approved by dsd. (diff)
downloadgentoo-2-1102110bba89a790a84264c4d920787f793c7055.tar.gz
gentoo-2-1102110bba89a790a84264c4d920787f793c7055.tar.bz2
gentoo-2-1102110bba89a790a84264c4d920787f793c7055.zip
Fix nls support
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'games-board/ggz-txt-client')
-rw-r--r--games-board/ggz-txt-client/ChangeLog6
-rw-r--r--games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild26
2 files changed, 22 insertions, 10 deletions
diff --git a/games-board/ggz-txt-client/ChangeLog b/games-board/ggz-txt-client/ChangeLog
index 927c92ca37c8..2e1e35866d82 100644
--- a/games-board/ggz-txt-client/ChangeLog
+++ b/games-board/ggz-txt-client/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/ggz-txt-client
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-txt-client/ChangeLog,v 1.11 2006/07/18 21:47:57 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-txt-client/ChangeLog,v 1.12 2006/10/06 22:39:45 nyhm Exp $
+
+ 06 Oct 2006; Tristan Heaven <nyhm@gentoo.org>
+ ggz-txt-client-0.0.13.ebuild:
+ Fix nls support
18 Jul 2006; Michael Hanselmann <hansmi@gentoo.org>
ggz-txt-client-0.0.13.ebuild:
diff --git a/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild b/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild
index d1e0930868ca..fac1c68c8f72 100644
--- a/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild
+++ b/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild,v 1.5 2006/09/28 20:58:18 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild,v 1.6 2006/10/06 22:39:45 nyhm Exp $
-inherit eutils games
+inherit games
DESCRIPTION="The textbased client for GGZ Gaming Zone"
HOMEPAGE="http://www.ggzgamingzone.org/"
@@ -14,19 +14,27 @@ SLOT="0"
KEYWORDS="-amd64 ppc x86"
IUSE=""
-DEPEND="~dev-games/ggz-client-libs-${PV}
+RDEPEND="~dev-games/ggz-client-libs-${PV}
sys-libs/ncurses
- sys-libs/readline"
+ sys-libs/readline
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:$(prefix)/share:/usr/share:' \
+ po/Makefile.in || die "sed failed"
+}
src_compile() {
- egamesconf || die
- emake || die
+ egamesconf --datadir=/usr/share || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS QuickStart.GGZ README* TODO
- domenu ${D}/usr/share/games/applications/ggz-txt.desktop
- rm -rf ${D}/usr/share/games
prepgamesdirs
}