summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-13 15:12:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-13 15:12:08 +0000
commit2e21436623fabde2ab286798765aa161bbc2fd1c (patch)
treefde1da99917546fa03fa0b53452b89a51424a5ec /games-board/hexxagon
parentAdd missing cards, bug 269167 (diff)
downloadgentoo-2-2e21436623fabde2ab286798765aa161bbc2fd1c.tar.gz
gentoo-2-2e21436623fabde2ab286798765aa161bbc2fd1c.tar.bz2
gentoo-2-2e21436623fabde2ab286798765aa161bbc2fd1c.zip
Fix patch so hexxagon builds with older compilers.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'games-board/hexxagon')
-rw-r--r--games-board/hexxagon/ChangeLog4
-rw-r--r--games-board/hexxagon/files/hexxagon-1.0-toolchain.patch (renamed from games-board/hexxagon/files/hexxagon-1.0-build.patch)76
-rw-r--r--games-board/hexxagon/hexxagon-1.0.ebuild4
3 files changed, 43 insertions, 41 deletions
diff --git a/games-board/hexxagon/ChangeLog b/games-board/hexxagon/ChangeLog
index 14d19dc5a09f..999bd56dbf2f 100644
--- a/games-board/hexxagon/ChangeLog
+++ b/games-board/hexxagon/ChangeLog
@@ -1,9 +1,9 @@
# ChangeLog for games-board/hexxagon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/ChangeLog,v 1.22 2009/08/13 04:05:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/ChangeLog,v 1.23 2009/08/13 15:12:08 ssuominen Exp $
12 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> hexxagon-1.0.ebuild,
- +files/hexxagon-1.0-build.patch:
+ +files/hexxagon-1.0-toolchain.patch:
Fix building with GCC 4.4+ wrt #273526, thanks to vasuvi from #gentoo-kde
for patch.
diff --git a/games-board/hexxagon/files/hexxagon-1.0-build.patch b/games-board/hexxagon/files/hexxagon-1.0-toolchain.patch
index 8aece9b47576..fed6013d09a8 100644
--- a/games-board/hexxagon/files/hexxagon-1.0-build.patch
+++ b/games-board/hexxagon/files/hexxagon-1.0-toolchain.patch
@@ -1,6 +1,6 @@
-diff -ur hexxagon-1.0.original/src/libhexx/bitboard64.h hexxagon-1.0/src/libhexx/bitboard64.h
---- hexxagon-1.0.original/src/libhexx/bitboard64.h 2005-01-13 23:19:07.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/bitboard64.h 2009-08-13 06:51:10.000000000 +0300
+diff -ur hexxagon-1.0.orig/src/libhexx/bitboard64.h hexxagon-1.0/src/libhexx/bitboard64.h
+--- hexxagon-1.0.orig/src/libhexx/bitboard64.h 2005-01-13 23:19:07.000000000 +0200
++++ hexxagon-1.0/src/libhexx/bitboard64.h 2009-08-13 18:07:53.000000000 +0300
@@ -19,12 +19,12 @@
*
*/
@@ -34,23 +34,17 @@ diff -ur hexxagon-1.0.original/src/libhexx/bitboard64.h hexxagon-1.0/src/libhexx
}
#endif
-diff -ur hexxagon-1.0.original/src/libhexx/board.h hexxagon-1.0/src/libhexx/board.h
---- hexxagon-1.0.original/src/libhexx/board.h 2005-01-16 13:12:23.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/board.h 2009-08-13 07:03:48.000000000 +0300
-@@ -25,7 +25,6 @@
-
- #include "bitboard64.h"
- #include "lookup.h"
--#include "move.h"
- #include "layout.h"
-
- #include <iostream>
-@@ -33,8 +32,21 @@
+diff -ur hexxagon-1.0.orig/src/libhexx/board.h hexxagon-1.0/src/libhexx/board.h
+--- hexxagon-1.0.orig/src/libhexx/board.h 2005-01-16 13:12:23.000000000 +0200
++++ hexxagon-1.0/src/libhexx/board.h 2009-08-13 18:07:53.000000000 +0300
+@@ -33,8 +33,24 @@
namespace libhexx
{
- class Move;
- class MoveList;
++#ifndef _MOVE_DEFINED
++#define _MOVE_DEFINED
+ class Move
+ {
+ public:
@@ -66,30 +60,29 @@ diff -ur hexxagon-1.0.original/src/libhexx/board.h hexxagon-1.0/src/libhexx/boar
+
+ bool scoreMoves(std::vector<Move> &moves, class Board board,
+ const LookUp& lookUp, int depth, bool (*callback)(), int maxtime);
++#endif
enum
{
-diff -ur hexxagon-1.0.original/src/libhexx/libhexx.h hexxagon-1.0/src/libhexx/libhexx.h
---- hexxagon-1.0.original/src/libhexx/libhexx.h 2005-01-13 23:19:07.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/libhexx.h 2009-08-13 06:53:35.000000000 +0300
-@@ -19,6 +19,8 @@
+diff -ur hexxagon-1.0.orig/src/libhexx/libhexx.h hexxagon-1.0/src/libhexx/libhexx.h
+--- hexxagon-1.0.orig/src/libhexx/libhexx.h 2005-01-13 23:19:07.000000000 +0200
++++ hexxagon-1.0/src/libhexx/libhexx.h 2009-08-13 18:07:53.000000000 +0300
+@@ -19,11 +19,10 @@
*
*/
-+#ifndef _LIBHEXX_H
-+#define _LIBHEXX_H
-
+-
#include "bitboard64.h"
++#include "lookup.h"
#include "move.h"
-@@ -27,3 +29,5 @@
- #include "lookup.h"
+ #include "board.h"
+ #include "game.h"
+-#include "lookup.h"
#include "view.h"
#include "layout.h"
-+
-+#endif
-diff -ur hexxagon-1.0.original/src/libhexx/lookup.h hexxagon-1.0/src/libhexx/lookup.h
---- hexxagon-1.0.original/src/libhexx/lookup.h 2005-01-13 23:19:07.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/lookup.h 2009-08-13 06:51:10.000000000 +0300
+diff -ur hexxagon-1.0.orig/src/libhexx/lookup.h hexxagon-1.0/src/libhexx/lookup.h
+--- hexxagon-1.0.orig/src/libhexx/lookup.h 2005-01-13 23:19:07.000000000 +0200
++++ hexxagon-1.0/src/libhexx/lookup.h 2009-08-13 18:07:53.000000000 +0300
@@ -27,6 +27,8 @@
namespace libhexx
@@ -99,9 +92,9 @@ diff -ur hexxagon-1.0.original/src/libhexx/lookup.h hexxagon-1.0/src/libhexx/loo
int getHexxagonIndex(int x, int y);
class LookUp
-diff -ur hexxagon-1.0.original/src/libhexx/move.cpp hexxagon-1.0/src/libhexx/move.cpp
---- hexxagon-1.0.original/src/libhexx/move.cpp 2005-01-16 13:12:23.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/move.cpp 2009-08-13 06:51:10.000000000 +0300
+diff -ur hexxagon-1.0.orig/src/libhexx/move.cpp hexxagon-1.0/src/libhexx/move.cpp
+--- hexxagon-1.0.orig/src/libhexx/move.cpp 2005-01-16 13:12:23.000000000 +0200
++++ hexxagon-1.0/src/libhexx/move.cpp 2009-08-13 18:07:53.000000000 +0300
@@ -114,4 +114,11 @@
return true;
}
@@ -115,10 +108,10 @@ diff -ur hexxagon-1.0.original/src/libhexx/move.cpp hexxagon-1.0/src/libhexx/mov
+{
+ return from != 99 && to != 99;
+}
-diff -ur hexxagon-1.0.original/src/libhexx/move.h hexxagon-1.0/src/libhexx/move.h
---- hexxagon-1.0.original/src/libhexx/move.h 2005-01-13 23:19:07.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/move.h 2009-08-13 06:51:10.000000000 +0300
-@@ -23,19 +23,19 @@
+diff -ur hexxagon-1.0.orig/src/libhexx/move.h hexxagon-1.0/src/libhexx/move.h
+--- hexxagon-1.0.orig/src/libhexx/move.h 2005-01-13 23:19:07.000000000 +0200
++++ hexxagon-1.0/src/libhexx/move.h 2009-08-13 18:07:53.000000000 +0300
+@@ -23,19 +23,21 @@
#ifndef _MOVE_H
#define _MOVE_H
@@ -131,6 +124,8 @@ diff -ur hexxagon-1.0.original/src/libhexx/move.h hexxagon-1.0/src/libhexx/move.
{
+ class Board;
+
++#ifndef _MOVE_DEFINED
++#define _MOVE_DEFINED
class Move
{
public:
@@ -143,7 +138,7 @@ diff -ur hexxagon-1.0.original/src/libhexx/move.h hexxagon-1.0/src/libhexx/move.
inline bool operator<(const Move &r) const
{
-@@ -47,7 +47,7 @@
+@@ -47,13 +49,14 @@
return (score != r.score);
};
@@ -152,3 +147,10 @@ diff -ur hexxagon-1.0.original/src/libhexx/move.h hexxagon-1.0/src/libhexx/move.
char from, to;
int score;
+ };
+
+ bool scoreMoves(std::vector<Move> &moves, class Board board, const LookUp& lookUp, int depth, bool (*callback)(), int maxtime);
++#endif
+ } //namespace libhexx
+
+ #endif // _HEXXAGONMOVE_H
diff --git a/games-board/hexxagon/hexxagon-1.0.ebuild b/games-board/hexxagon/hexxagon-1.0.ebuild
index ef1a01e26606..5d867f895572 100644
--- a/games-board/hexxagon/hexxagon-1.0.ebuild
+++ b/games-board/hexxagon/hexxagon-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/hexxagon-1.0.ebuild,v 1.11 2009/08/13 04:05:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/hexxagon-1.0.ebuild,v 1.12 2009/08/13 15:12:08 ssuominen Exp $
EAPI=2
inherit eutils games
@@ -21,7 +21,7 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-toolchain.patch
}
src_install() {