summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-15 17:33:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-15 17:33:38 +0000
commitfe6e1505b67812960537a47bd2b53703c9fce1fd (patch)
tree0d58ec58b53dfb1a8fc6c02065e1ad45cceb5819 /games-board/hexxagon
parentRemove old since it doesn't pass econf with stable python anyway. (diff)
downloadgentoo-2-fe6e1505b67812960537a47bd2b53703c9fce1fd.tar.gz
gentoo-2-fe6e1505b67812960537a47bd2b53703c9fce1fd.tar.bz2
gentoo-2-fe6e1505b67812960537a47bd2b53703c9fce1fd.zip
Replace working workaround with correct solution. Won't change anything from users POV.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'games-board/hexxagon')
-rw-r--r--games-board/hexxagon/ChangeLog7
-rw-r--r--games-board/hexxagon/files/hexxagon-1.0-gcc44.patch65
-rw-r--r--games-board/hexxagon/files/hexxagon-1.0-toolchain.patch156
-rw-r--r--games-board/hexxagon/hexxagon-1.0.ebuild4
4 files changed, 70 insertions, 162 deletions
diff --git a/games-board/hexxagon/ChangeLog b/games-board/hexxagon/ChangeLog
index 999bd56dbf2f..6ffaa85e7759 100644
--- a/games-board/hexxagon/ChangeLog
+++ b/games-board/hexxagon/ChangeLog
@@ -1,11 +1,10 @@
# ChangeLog for games-board/hexxagon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/ChangeLog,v 1.23 2009/08/13 15:12:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/ChangeLog,v 1.24 2009/08/15 17:33:38 ssuominen Exp $
12 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> hexxagon-1.0.ebuild,
- +files/hexxagon-1.0-toolchain.patch:
- Fix building with GCC 4.4+ wrt #273526, thanks to vasuvi from #gentoo-kde
- for patch.
+ +files/hexxagon-1.0-gcc44.patch:
+ Fix building with GCC 4.4+ wrt #273526.
08 Apr 2008; Michael Sterrett <mr_bones_@gentoo.org> hexxagon-1.0.ebuild:
fix deps (bug #216560)
diff --git a/games-board/hexxagon/files/hexxagon-1.0-gcc44.patch b/games-board/hexxagon/files/hexxagon-1.0-gcc44.patch
new file mode 100644
index 000000000000..3a6f3c8d2a2d
--- /dev/null
+++ b/games-board/hexxagon/files/hexxagon-1.0-gcc44.patch
@@ -0,0 +1,65 @@
+Only in hexxagon-1.0.orig: hexxagon-1.0
+diff -ur hexxagon-1.0.orig/src/libhexx/bitboard64.h hexxagon-1.0/src/libhexx/bitboard64.h
+--- hexxagon-1.0.orig/src/libhexx/bitboard64.h 2005-01-13 23:19:07.000000000 +0200
++++ hexxagon-1.0/src/libhexx/bitboard64.h 2009-08-15 20:34:23.000000000 +0300
+@@ -25,6 +25,7 @@
+
+ #include <netinet/in.h>
+ #include <iostream>
++#include <cstdio>
+
+ namespace libhexx
+ {
+@@ -54,14 +55,11 @@
+ {
+ printf("0x%X, 0x%X\n", lowbits, highbits);
+ };
+-
+- friend std::ostream& operator<<(std::ostream &output, const class BitBoard64 &b);
+- friend std::istream& operator>>(std::istream &input, class BitBoard64 &b);
+-
+- private:
+
+ uint32_t lowbits, highbits;
+ };
++ std::ostream& operator<<(std::ostream &output, const class BitBoard64 &b);
++ std::istream& operator>>(std::istream &input, class BitBoard64 &b);
+ }
+
+ #endif
+diff -ur hexxagon-1.0.orig/src/libhexx/board.h hexxagon-1.0/src/libhexx/board.h
+--- hexxagon-1.0.orig/src/libhexx/board.h 2005-01-16 13:12:23.000000000 +0200
++++ hexxagon-1.0/src/libhexx/board.h 2009-08-15 20:34:23.000000000 +0300
+@@ -93,6 +93,7 @@
+ BitBoard64 board;
+ BitBoard64 color;
+ };
++ bool scoreMoves(std::vector<Move> &moves, class Board board, const LookUp& lookUp, int depth, bool (*callback)(), int maxtime);
+ } // namespace libhexx
+
+ #endif // _BOARD_H
+diff -ur hexxagon-1.0.orig/src/libhexx/move.h hexxagon-1.0/src/libhexx/move.h
+--- hexxagon-1.0.orig/src/libhexx/move.h 2005-01-13 23:19:07.000000000 +0200
++++ hexxagon-1.0/src/libhexx/move.h 2009-08-15 20:34:23.000000000 +0300
+@@ -20,10 +20,9 @@
+ */
+
+
+-#ifndef _MOVE_H
+-#define _MOVE_H
++#ifndef _LIBHEXX_MOVE_H
++#define _LIBHEXX_MOVE_H
+
+-#include "board.h"
+
+ #include <list>
+ #include <vector>
+@@ -53,7 +52,7 @@
+ int score;
+ };
+
+- bool scoreMoves(std::vector<Move> &moves, class Board board, const LookUp& lookUp, int depth, bool (*callback)(), int maxtime);
++
+ } //namespace libhexx
+
+ #endif // _HEXXAGONMOVE_H
diff --git a/games-board/hexxagon/files/hexxagon-1.0-toolchain.patch b/games-board/hexxagon/files/hexxagon-1.0-toolchain.patch
deleted file mode 100644
index fed6013d09a8..000000000000
--- a/games-board/hexxagon/files/hexxagon-1.0-toolchain.patch
+++ /dev/null
@@ -1,156 +0,0 @@
-diff -ur hexxagon-1.0.orig/src/libhexx/bitboard64.h hexxagon-1.0/src/libhexx/bitboard64.h
---- hexxagon-1.0.orig/src/libhexx/bitboard64.h 2005-01-13 23:19:07.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/bitboard64.h 2009-08-13 18:07:53.000000000 +0300
-@@ -19,12 +19,12 @@
- *
- */
-
--
- #ifndef _BITBOARD64_H
- #define _BITBOARD64_H
-
- #include <netinet/in.h>
- #include <iostream>
-+#include <cstdio>
-
- namespace libhexx
- {
-@@ -54,14 +54,12 @@
- {
- printf("0x%X, 0x%X\n", lowbits, highbits);
- };
--
-- friend std::ostream& operator<<(std::ostream &output, const class BitBoard64 &b);
-- friend std::istream& operator>>(std::istream &input, class BitBoard64 &b);
--
-- private:
--
-+
- uint32_t lowbits, highbits;
- };
-+
-+ std::ostream& operator<<(std::ostream &output, const class BitBoard64 &b);
-+ std::istream& operator>>(std::istream &input, class BitBoard64 &b);
- }
-
- #endif
-diff -ur hexxagon-1.0.orig/src/libhexx/board.h hexxagon-1.0/src/libhexx/board.h
---- hexxagon-1.0.orig/src/libhexx/board.h 2005-01-16 13:12:23.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/board.h 2009-08-13 18:07:53.000000000 +0300
-@@ -33,8 +33,24 @@
-
- namespace libhexx
- {
-- class Move;
-- class MoveList;
-+#ifndef _MOVE_DEFINED
-+#define _MOVE_DEFINED
-+ class Move
-+ {
-+ public:
-+ Move();
-+ Move(int t);
-+ Move(int f, int t);
-+
-+ operator bool() const;
-+
-+ char from, to;
-+ int score;
-+ };
-+
-+ bool scoreMoves(std::vector<Move> &moves, class Board board,
-+ const LookUp& lookUp, int depth, bool (*callback)(), int maxtime);
-+#endif
-
- enum
- {
-diff -ur hexxagon-1.0.orig/src/libhexx/libhexx.h hexxagon-1.0/src/libhexx/libhexx.h
---- hexxagon-1.0.orig/src/libhexx/libhexx.h 2005-01-13 23:19:07.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/libhexx.h 2009-08-13 18:07:53.000000000 +0300
-@@ -19,11 +19,10 @@
- *
- */
-
--
- #include "bitboard64.h"
-+#include "lookup.h"
- #include "move.h"
- #include "board.h"
- #include "game.h"
--#include "lookup.h"
- #include "view.h"
- #include "layout.h"
-diff -ur hexxagon-1.0.orig/src/libhexx/lookup.h hexxagon-1.0/src/libhexx/lookup.h
---- hexxagon-1.0.orig/src/libhexx/lookup.h 2005-01-13 23:19:07.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/lookup.h 2009-08-13 18:07:53.000000000 +0300
-@@ -27,6 +27,8 @@
-
- namespace libhexx
- {
-+ class BitBoard64;
-+
- int getHexxagonIndex(int x, int y);
-
- class LookUp
-diff -ur hexxagon-1.0.orig/src/libhexx/move.cpp hexxagon-1.0/src/libhexx/move.cpp
---- hexxagon-1.0.orig/src/libhexx/move.cpp 2005-01-16 13:12:23.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/move.cpp 2009-08-13 18:07:53.000000000 +0300
-@@ -114,4 +114,11 @@
- return true;
- }
-
--
-+Move::Move() { from = 99; to = 99;};
-+Move::Move(int t) { from = t; to = t; };
-+Move::Move(int f, int t) { from = f; to = t; };
-+
-+Move::operator bool() const
-+{
-+ return from != 99 && to != 99;
-+}
-diff -ur hexxagon-1.0.orig/src/libhexx/move.h hexxagon-1.0/src/libhexx/move.h
---- hexxagon-1.0.orig/src/libhexx/move.h 2005-01-13 23:19:07.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/move.h 2009-08-13 18:07:53.000000000 +0300
-@@ -23,19 +23,21 @@
- #ifndef _MOVE_H
- #define _MOVE_H
-
--#include "board.h"
--
- #include <list>
- #include <vector>
-
- namespace libhexx
- {
-+ class Board;
-+
-+#ifndef _MOVE_DEFINED
-+#define _MOVE_DEFINED
- class Move
- {
- public:
-- Move() { from = 99; to = 99;};
-- Move(int t) { from = t; to = t; };
-- Move(int f, int t) { from = f; to = t; };
-+ Move();
-+ Move(int t);
-+ Move(int f, int t);
-
- inline bool operator<(const Move &r) const
- {
-@@ -47,13 +49,14 @@
- return (score != r.score);
- };
-
-- operator bool() const { return from != 99 && to != 99; };
-+ operator bool() const;
-
- char from, to;
- int score;
- };
-
- bool scoreMoves(std::vector<Move> &moves, class Board board, const LookUp& lookUp, int depth, bool (*callback)(), int maxtime);
-+#endif
- } //namespace libhexx
-
- #endif // _HEXXAGONMOVE_H
diff --git a/games-board/hexxagon/hexxagon-1.0.ebuild b/games-board/hexxagon/hexxagon-1.0.ebuild
index 5d867f895572..f7d19279814c 100644
--- a/games-board/hexxagon/hexxagon-1.0.ebuild
+++ b/games-board/hexxagon/hexxagon-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/hexxagon-1.0.ebuild,v 1.12 2009/08/13 15:12:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/hexxagon-1.0.ebuild,v 1.13 2009/08/15 17:33:38 ssuominen Exp $
EAPI=2
inherit eutils games
@@ -21,7 +21,7 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-toolchain.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
}
src_install() {