summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-28 18:56:47 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-28 18:56:47 +0000
commit24d6d77d63755a32c16e2e474986acd5eab1bd99 (patch)
treea719ea62ebd084431bbd89078aa9f7f4a0b6a1fa /games-board
parentMarking clamav-0.97.5-r1 ppc64 for bug 428584 (diff)
downloadgentoo-2-24d6d77d63755a32c16e2e474986acd5eab1bd99.tar.gz
gentoo-2-24d6d77d63755a32c16e2e474986acd5eab1bd99.tar.bz2
gentoo-2-24d6d77d63755a32c16e2e474986acd5eab1bd99.zip
Fix g_thread_init/glib-2.32 build failure (bug #432938, thanks to Oschtan).
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/aisleriot/ChangeLog6
-rw-r--r--games-board/aisleriot/aisleriot-3.2.3.2-r1.ebuild7
-rw-r--r--games-board/aisleriot/files/aisleriot-3.2.3.2-g_thread_init.patch38
3 files changed, 49 insertions, 2 deletions
diff --git a/games-board/aisleriot/ChangeLog b/games-board/aisleriot/ChangeLog
index 2419db5a0ad0..61ef2781f48f 100644
--- a/games-board/aisleriot/ChangeLog
+++ b/games-board/aisleriot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/aisleriot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/aisleriot/ChangeLog,v 1.7 2012/08/26 15:43:23 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/aisleriot/ChangeLog,v 1.8 2012/08/28 18:56:47 tetromino Exp $
+
+ 28 Aug 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ aisleriot-3.2.3.2-r1.ebuild, +files/aisleriot-3.2.3.2-g_thread_init.patch:
+ Fix g_thread_init/glib-2.32 build failure (bug #432938, thanks to Oschtan).
*aisleriot-3.4.1-r1 (26 Aug 2012)
*aisleriot-3.2.3.2-r1 (26 Aug 2012)
diff --git a/games-board/aisleriot/aisleriot-3.2.3.2-r1.ebuild b/games-board/aisleriot/aisleriot-3.2.3.2-r1.ebuild
index 12b1abc4ba64..e23fc6ebedc5 100644
--- a/games-board/aisleriot/aisleriot-3.2.3.2-r1.ebuild
+++ b/games-board/aisleriot/aisleriot-3.2.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/aisleriot/aisleriot-3.2.3.2-r1.ebuild,v 1.1 2012/08/26 15:43:23 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/aisleriot/aisleriot-3.2.3.2-r1.ebuild,v 1.2 2012/08/28 18:56:47 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
@@ -69,6 +69,11 @@ pkg_setup() {
games_pkg_setup
}
+src_prepare() {
+ epatch "${FILESDIR}/${P}-g_thread_init.patch" #432938
+ gnome2_src_prepare
+}
+
src_install() {
gnome2_src_install
prepgamesdirs
diff --git a/games-board/aisleriot/files/aisleriot-3.2.3.2-g_thread_init.patch b/games-board/aisleriot/files/aisleriot-3.2.3.2-g_thread_init.patch
new file mode 100644
index 000000000000..2b050887b33c
--- /dev/null
+++ b/games-board/aisleriot/files/aisleriot-3.2.3.2-g_thread_init.patch
@@ -0,0 +1,38 @@
+From ee73ae586a307aad04f00908122f3950303153db Mon Sep 17 00:00:00 2001
+From: Christian Persch <chpe@gnome.org>
+Date: Wed, 5 Oct 2011 20:07:09 +0200
+Subject: [PATCH] Just call g_type_init
+
+This will init gthreads, so no need to do it manually.
+---
+ src/lib/ar-runtime.c | 14 +++-----------
+ 1 file changed, 3 insertions(+), 11 deletions(-)
+
+diff --git a/src/lib/ar-runtime.c b/src/lib/ar-runtime.c
+index eeff9f9..f51766f 100644
+--- a/src/lib/ar-runtime.c
++++ b/src/lib/ar-runtime.c
+@@ -286,17 +286,9 @@ ar_runtime_init (const char *name)
+ }
+ #endif /* G_OS_WIN32 */
+
+-#if defined(HAVE_GNOME) || defined(HAVE_RSVG_GNOMEVFS) || defined(ENABLE_SOUND)
+- /* If we're going to use gconf, gnome-vfs, or canberra, we need to
+- * init threads; and this has to be done before calling any other glib functions.
+- */
+-#if defined(LIBGAMES_SUPPORT_GI)
+- /* Seed has already called g_thread_init() */
+- g_assert (g_thread_get_initialized());
+-#else
+- g_thread_init (NULL);
+-#endif
+-#endif
++ /* This also initialises gthread */
++ g_type_init ();
++
+ /* May call any glib function after this point */
+
+ ar_profilestart ("ar_runtime_init");
+--
+1.7.12
+