summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-02-24 09:45:20 +0000
committerPacho Ramos <pacho@gentoo.org>2015-02-24 09:45:20 +0000
commit518400e3b3cb3a7455165ff1ba9ff5a7f917c969 (patch)
tree986db0a9c47ec9a7445b2a6bd44ee14f6ed3c568 /games-board
parentStable for amd64, wrt bug #539468 (diff)
downloadgentoo-2-518400e3b3cb3a7455165ff1ba9ff5a7f917c969.tar.gz
gentoo-2-518400e3b3cb3a7455165ff1ba9ff5a7f917c969.tar.bz2
gentoo-2-518400e3b3cb3a7455165ff1ba9ff5a7f917c969.zip
Version bump, add a note about how to play against the computer (#536612 by bitlord)
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnome-chess/ChangeLog10
-rw-r--r--games-board/gnome-chess/gnome-chess-3.14.3.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/games-board/gnome-chess/ChangeLog b/games-board/gnome-chess/ChangeLog
index fd3a154f07ed..870a03c6d6d6 100644
--- a/games-board/gnome-chess/ChangeLog
+++ b/games-board/gnome-chess/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/gnome-chess
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnome-chess/ChangeLog,v 1.20 2014/12/22 18:51:20 eva Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnome-chess/ChangeLog,v 1.21 2015/02/24 09:45:20 pacho Exp $
+
+*gnome-chess-3.14.3 (24 Feb 2015)
+
+ 24 Feb 2015; Pacho Ramos <pacho@gentoo.org> +gnome-chess-3.14.3.ebuild:
+ Version bump, add a note about how to play against the computer (#536612 by
+ bitlord)
*gnome-chess-3.14.2 (22 Dec 2014)
diff --git a/games-board/gnome-chess/gnome-chess-3.14.3.ebuild b/games-board/gnome-chess/gnome-chess-3.14.3.ebuild
new file mode 100644
index 000000000000..f9006abe64e6
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-3.14.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnome-chess/gnome-chess-3.14.3.ebuild,v 1.1 2015/02/24 09:45:20 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.24"
+
+inherit gnome-games vala readme.gentoo
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=gnome-base/librsvg-2.32
+ >=x11-libs/gtk+-3.13.2:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-util/appdata-tools
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="For being able to play against computer you will
+ need to install a chess engine like, for example, games-board/gnuchess"
+
+src_prepare() {
+ vala_src_prepare
+ gnome-games_src_prepare
+}
+
+src_configure() {
+ gnome-games_src_configure APPDATA_VALIDATE=$(type -P true)
+}
+
+src_install() {
+ gnome-games_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome-games_pkg_postinst
+ readme.gentoo_print_elog
+}