summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2013-04-07 21:21:53 +0000
committerAlfredo Tupone <tupone@gentoo.org>2013-04-07 21:21:53 +0000
commit66d832ebf038e47e88ebc8ec40b1160f4ce30dd5 (patch)
treea90745b1c013c48bc632075987c66ac972b1ed82 /games-board
parentRemove wrong sed on QT_INSTALL_{LIBS,PLUGINS}. See bug 304971 comments 16-18. (diff)
downloadgentoo-2-66d832ebf038e47e88ebc8ec40b1160f4ce30dd5.tar.gz
gentoo-2-66d832ebf038e47e88ebc8ec40b1160f4ce30dd5.tar.bz2
gentoo-2-66d832ebf038e47e88ebc8ec40b1160f4ce30dd5.zip
Fix bad behaviour on x86. Bug #463164
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/crafty/ChangeLog6
-rw-r--r--games-board/crafty/crafty-23.4.ebuild5
-rw-r--r--games-board/crafty/files/crafty-23.4-64bits.patch16
3 files changed, 24 insertions, 3 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index 536e70f3cdda..1acb4fff91fa 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/crafty
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.54 2013/01/25 06:29:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.55 2013/04/07 21:21:53 tupone Exp $
+
+ 07 Apr 2013; Alfredo Tupone <tupone@gentoo.org> crafty-23.4.ebuild,
+ +files/crafty-23.4-64bits.patch:
+ Fix bad behaviour on x86. Bug #463164 by Kobboi
25 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> crafty-23.4.ebuild:
point HOMEPAGE at an actual web page
diff --git a/games-board/crafty/crafty-23.4.ebuild b/games-board/crafty/crafty-23.4.ebuild
index 106ba0579425..a4462950909c 100644
--- a/games-board/crafty/crafty-23.4.ebuild
+++ b/games-board/crafty/crafty-23.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-23.4.ebuild,v 1.5 2013/01/25 06:29:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-23.4.ebuild,v 1.6 2013/04/07 21:21:53 tupone Exp $
EAPI=2
-inherit flag-o-matic toolchain-funcs games
+inherit flag-o-matic toolchain-funcs eutils games
DESCRIPTION="Bob Hyatt's strong chess engine"
HOMEPAGE="http://www.craftychess.com/"
@@ -30,6 +30,7 @@ src_prepare() {
sed -i \
-e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
|| die "sed failed"
+ epatch "${FILESDIR}"/${P}-64bits.patch
}
src_compile() {
diff --git a/games-board/crafty/files/crafty-23.4-64bits.patch b/games-board/crafty/files/crafty-23.4-64bits.patch
new file mode 100644
index 000000000000..9dc06a048819
--- /dev/null
+++ b/games-board/crafty/files/crafty-23.4-64bits.patch
@@ -0,0 +1,16 @@
+--- chess.h.old 2013-04-07 23:04:54.708245856 +0200
++++ chess.h 2013-04-07 23:05:20.052002160 +0200
+@@ -140,13 +140,7 @@
+ # define QUEEN_VALUE 1050
+ # define KING_VALUE 40000
+ # define MAX_DRAFT 256
+-# if defined(HAS_64BITS)
+-typedef unsigned long BITBOARD;
+-# elif defined(NT_i386)
+-typedef unsigned __int64 BITBOARD;
+-# else
+ typedef unsigned long long BITBOARD;
+-# endif
+ # if defined(NT_i386)
+ # define BMF "%I64u"
+ # define BMF6 "%6I64u"