summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-10 21:40:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-10 21:40:01 +0000
commit6909e63f58a520a903ce1dcad7b28f9cf13db51d (patch)
tree3a7f10c371e4ee144acf9fb242f85861f6d58c32 /games-emulation/darcnes
parentMark 6.2-r8 stable on all arches. Prune older ebuilds (Manifest recommit) (diff)
downloadgentoo-2-6909e63f58a520a903ce1dcad7b28f9cf13db51d.tar.gz
gentoo-2-6909e63f58a520a903ce1dcad7b28f9cf13db51d.tar.bz2
gentoo-2-6909e63f58a520a903ce1dcad7b28f9cf13db51d.zip
make X optional for the svgalib lovers.
Diffstat (limited to 'games-emulation/darcnes')
-rw-r--r--games-emulation/darcnes/ChangeLog5
-rw-r--r--games-emulation/darcnes/darcnes-0401-r2.ebuild20
2 files changed, 17 insertions, 8 deletions
diff --git a/games-emulation/darcnes/ChangeLog b/games-emulation/darcnes/ChangeLog
index 9f5e4ec66b81..e88ebbd8858a 100644
--- a/games-emulation/darcnes/ChangeLog
+++ b/games-emulation/darcnes/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/darcnes
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/ChangeLog,v 1.3 2004/05/10 19:02:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/ChangeLog,v 1.4 2004/05/10 21:40:01 mr_bones_ Exp $
+
+ 10 May 2004; Michael Sterrett <mr_bones_@gentoo.org> darcnes-0401-r2.ebuild:
+ make X optional for the svgalib lovers.
*darcnes-0401-r2 (10 May 2004)
diff --git a/games-emulation/darcnes/darcnes-0401-r2.ebuild b/games-emulation/darcnes/darcnes-0401-r2.ebuild
index 0f8538830e3e..bb08aca6fb1a 100644
--- a/games-emulation/darcnes/darcnes-0401-r2.ebuild
+++ b/games-emulation/darcnes/darcnes-0401-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.1 2004/05/10 19:02:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.2 2004/05/10 21:40:01 mr_bones_ Exp $
inherit games
@@ -11,11 +11,13 @@ SRC_URI="http://www.dridus.com/~nyef/darcnes/download/dn9b${PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 -ppc"
-IUSE="gtk svga"
+IUSE="gtk svga X"
DEPEND="svga? ( >=media-libs/svgalib-1.4.2 )
- virtual/x11
- gtk? ( =x11-libs/gtk+-1.2* )"
+ X? ( virtual/x11 )
+ gtk? (
+ virtual/x11
+ =x11-libs/gtk+-1.2* )"
S="${WORKDIR}/${PN}"
@@ -28,12 +30,16 @@ src_compile() {
emake BINFILE=gdarcnes TARGET=Linux_GTK OPTFLAGS="${CFLAGS}" || \
die "compile target Linux_GTK failed"
fi
- emake TARGET=Linux_X OPTFLAGS="${CFLAGS}" || \
- die "compile target Linux_X failed"
+ if use X ; then
+ emake TARGET=Linux_X OPTFLAGS="${CFLAGS}" || \
+ die "compile target Linux_X failed"
+ fi
}
src_install() {
- dogamesbin darcnes || die "dogamesbin failed"
+ if use X ; then
+ dogamesbin darcnes || die "dogamesbin failed"
+ fi
if use gtk ; then
dogamesbin gdarcnes || die "dogamesbin failed (gtk)"
fi