summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-28 07:22:45 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-28 07:22:45 +0000
commit575a38a730cc0a1a00d2e0a87fd584fe52c57ac9 (patch)
tree2248a90dc609a1e37365db2d18821ae59ffad479 /games-emulation/dosbox
parentVersion Bump. (diff)
downloadgentoo-2-575a38a730cc0a1a00d2e0a87fd584fe52c57ac9.tar.gz
gentoo-2-575a38a730cc0a1a00d2e0a87fd584fe52c57ac9.tar.bz2
gentoo-2-575a38a730cc0a1a00d2e0a87fd584fe52c57ac9.zip
Build with gcc-4.6 Bug #364231
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/dosbox')
-rw-r--r--games-emulation/dosbox/ChangeLog8
-rw-r--r--games-emulation/dosbox/dosbox-0.74.ebuild7
-rw-r--r--games-emulation/dosbox/files/dosbox-0.74-gcc46.patch10
3 files changed, 21 insertions, 4 deletions
diff --git a/games-emulation/dosbox/ChangeLog b/games-emulation/dosbox/ChangeLog
index 4c8035c1c1c8..9324bbb570ce 100644
--- a/games-emulation/dosbox/ChangeLog
+++ b/games-emulation/dosbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/dosbox
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.55 2010/11/23 09:24:23 tupone Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.56 2011/04/28 07:22:45 tupone Exp $
+
+ 28 Apr 2011; Tupone Alfredo <tupone@gentoo.org> dosbox-0.74.ebuild,
+ +files/dosbox-0.74-gcc46.patch:
+ Build with gcc-4.6 Bug #364231 by Philipp
23 Nov 2010; Tupone Alfredo <tupone@gentoo.org> dosbox-0.74.ebuild:
media-libs/libsdl need to be built with X. Fix bug #346241 by Tom Noonan
diff --git a/games-emulation/dosbox/dosbox-0.74.ebuild b/games-emulation/dosbox/dosbox-0.74.ebuild
index 28fc60a73158..a6902f4a4c0a 100644
--- a/games-emulation/dosbox/dosbox-0.74.ebuild
+++ b/games-emulation/dosbox/dosbox-0.74.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.74.ebuild,v 1.7 2010/11/28 00:57:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.74.ebuild,v 1.8 2011/04/28 07:22:45 tupone Exp $
EAPI=2
inherit eutils games
@@ -21,6 +21,9 @@ DEPEND="alsa? ( media-libs/alsa-lib )
media-libs/libsdl[joystick,video,X]
media-libs/sdl-net
media-libs/sdl-sound"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc46.patch )
src_configure() {
egamesconf \
diff --git a/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch b/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch
new file mode 100644
index 000000000000..16811d47d640
--- /dev/null
+++ b/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch
@@ -0,0 +1,10 @@
+--- include/dos_inc.h.old 2011-04-28 08:46:04.505011354 +0200
++++ include/dos_inc.h 2011-04-28 08:46:27.104408178 +0200
+@@ -21,6 +21,7 @@
+ #ifndef DOSBOX_DOS_INC_H
+ #define DOSBOX_DOS_INC_H
+
++#include <cstddef>
+ #ifndef DOSBOX_DOS_SYSTEM_H
+ #include "dos_system.h"
+ #endif