summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2011-12-13 01:40:02 +0000
committerChristian Birchinger <joker@gentoo.org>2011-12-13 01:40:02 +0000
commitc172b0c56b4b840e64aceff27720b6ffcbd4eeca (patch)
treea01be8d0629d334fd6915fe516a3c61ed16d06b6 /games-emulation/mupen64plus
parentVersion bump. (diff)
downloadgentoo-2-c172b0c56b4b840e64aceff27720b6ffcbd4eeca.tar.gz
gentoo-2-c172b0c56b4b840e64aceff27720b6ffcbd4eeca.tar.bz2
gentoo-2-c172b0c56b4b840e64aceff27720b6ffcbd4eeca.zip
Make it use the user configured CC (also needed as linker because the args are not LD compatible) and CXX. However, this will not cause it to build cleanly with non-gcc compilers like clang.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/mupen64plus')
-rw-r--r--games-emulation/mupen64plus/ChangeLog8
-rw-r--r--games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild7
2 files changed, 11 insertions, 4 deletions
diff --git a/games-emulation/mupen64plus/ChangeLog b/games-emulation/mupen64plus/ChangeLog
index 1aaf29aa14e7..3493350735d2 100644
--- a/games-emulation/mupen64plus/ChangeLog
+++ b/games-emulation/mupen64plus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/mupen64plus
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/ChangeLog,v 1.15 2011/09/24 05:48:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/ChangeLog,v 1.16 2011/12/13 01:40:02 joker Exp $
+
+ 13 Dec 2011; Christian Birchinger <joker@gentoo.org>
+ mupen64plus-1.5-r2.ebuild:
+ Make it use the user configured CC (also needed as linker because the args
+ are not LD compatible) and CXX. However, this will not cause it to build
+ cleanly with non-gcc compilers like clang
24 Sep 2011; Mike Frysinger <vapier@gentoo.org> mupen64plus-1.5-r2.ebuild,
+files/mupen64plus-1.5-minizip.patch:
diff --git a/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild b/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild
index 81c08ac5f16a..e22ef4b3d5fd 100644
--- a/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild
+++ b/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild,v 1.3 2011/09/24 05:48:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild,v 1.4 2011/12/13 01:40:02 joker Exp $
EAPI="2"
-inherit eutils flag-o-matic games
+inherit eutils flag-o-matic games toolchain-funcs
MY_P="Mupen64Plus-${PV/./-}-src"
@@ -89,8 +89,9 @@ get_opts() {
}
src_compile() {
+ tc-export CC CXX
use x86 && use sse && append-flags -fomit-frame-pointer
- emake $(get_opts) DBGSYM=1 all || die "make failed"
+ emake $(get_opts) DBGSYM=1 CC="${CC}" CXX="${CXX}" LD="${CC}" all || die "make failed"
}
src_install() {