summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-10-08 21:28:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-10-08 21:28:24 +0000
commit7140c8a6612c811a949ca5b2d280a6724d7f9f22 (patch)
tree275095d38d8a25439595fc7779b476080321e621 /games-emulation/raine
parentremove old (diff)
downloadgentoo-2-7140c8a6612c811a949ca5b2d280a6724d7f9f22.tar.gz
gentoo-2-7140c8a6612c811a949ca5b2d280a6724d7f9f22.tar.bz2
gentoo-2-7140c8a6612c811a949ca5b2d280a6724d7f9f22.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation/raine')
-rw-r--r--games-emulation/raine/ChangeLog8
-rw-r--r--games-emulation/raine/files/raine-0.51.9-ldflags.patch11
-rw-r--r--games-emulation/raine/raine-0.51.9.ebuild58
3 files changed, 76 insertions, 1 deletions
diff --git a/games-emulation/raine/ChangeLog b/games-emulation/raine/ChangeLog
index 834e6d0d36cf..6dafd76a4377 100644
--- a/games-emulation/raine/ChangeLog
+++ b/games-emulation/raine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/raine
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.26 2010/10/08 08:25:02 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.27 2010/10/08 21:28:23 mr_bones_ Exp $
+
+*raine-0.51.9 (08 Oct 2010)
+
+ 08 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org> +raine-0.51.9.ebuild,
+ +files/raine-0.51.9-ldflags.patch:
+ version bump
08 Oct 2010; Tupone Alfredo <tupone@gentoo.org> raine-0.51.8.ebuild,
+files/raine-0.51.8-ldflags.patch:
diff --git a/games-emulation/raine/files/raine-0.51.9-ldflags.patch b/games-emulation/raine/files/raine-0.51.9-ldflags.patch
new file mode 100644
index 000000000000..f011cd6a1e5c
--- /dev/null
+++ b/games-emulation/raine/files/raine-0.51.9-ldflags.patch
@@ -0,0 +1,11 @@
+--- makefile.old 2010-10-08 10:04:46.000000000 +0200
++++ makefile 2010-10-08 10:05:25.000000000 +0200
+@@ -995,7 +995,7 @@
+ else
+ @echo Linking Raine...
+ endif
+- $(LDV) $(LFLAGS) -g -Wall -Wno-write-strings -o $(RAINE_EXE) $(OBJS) $(LIBS) -lstdc++
++ $(LDV) $(LDFLAGS) $(LFLAGS) -g -Wall -Wno-write-strings -o $(RAINE_EXE) $(OBJS) $(LIBS) -lstdc++
+
+ converter: source/bonus/converter.c
+ $(CCV) $(CFLAGS) -c $< -o $(OBJDIR)/converter.o
diff --git a/games-emulation/raine/raine-0.51.9.ebuild b/games-emulation/raine/raine-0.51.9.ebuild
new file mode 100644
index 000000000000..18f7c872150a
--- /dev/null
+++ b/games-emulation/raine/raine-0.51.9.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/raine-0.51.9.ebuild,v 1.1 2010/10/08 21:28:23 mr_bones_ Exp $
+
+EAPI=2
+inherit flag-o-matic eutils games
+
+DESCRIPTION="R A I N E M680x0 Arcade Emulation"
+HOMEPAGE="http://rainemu.swishparty.co.uk/"
+SRC_URI="http://rainemu.swishparty.co.uk/html/archive/raines-${PV}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+
+RDEPEND="dev-cpp/muParser
+ media-libs/libsdl[audio,joystick,video]
+ sys-libs/zlib
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ app-arch/unzip"
+
+src_prepare() {
+ echo > detect-cpu
+ echo > cpuinfo
+ sed -i \
+ -e "/^NEO/s:^:#:" \
+ -e "s:nasmw:nasm:" \
+ -e "/bindir/s:=.*:=\$(DESTDIR)${GAMES_BINDIR}:" \
+ -e "/sharedir =/s:=.*:=\$(DESTDIR)${GAMES_DATADIR}:" \
+ -e "/mandir/s:=.*:=\$(DESTDIR)/usr/share/man/man6:" \
+ makefile \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ append-ldflags -Wl,-z,noexecstack
+}
+
+src_compile() {
+ local myopts
+
+ use static \
+ && myopts="${myopts} STATIC=1" \
+ || myopts="${myopts} STATIC="
+ emake \
+ _MARCH="${CFLAGS}" \
+ VERBOSE=1 \
+ ${myopts} || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ keepdir "${GAMES_DATADIR}"/${PN}/{roms,artwork,emudx,scripts/raine}
+ dodoc docs/readme.txt
+ prepgamesdirs
+}