summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-03-23 20:42:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-03-23 20:42:41 +0000
commit773a90e55aad36f992e1dbe7d28fb8c5b8e8d17a (patch)
tree486b13e02ac428599bb9717aca750df661f07716 /games-emulation/tuxnes
parentGet rid of ebuild unported to modular X, it's breaking category-level commits. (diff)
downloadgentoo-2-773a90e55aad36f992e1dbe7d28fb8c5b8e8d17a.tar.gz
gentoo-2-773a90e55aad36f992e1dbe7d28fb8c5b8e8d17a.tar.bz2
gentoo-2-773a90e55aad36f992e1dbe7d28fb8c5b8e8d17a.zip
more dep fixing (bug #122168); use games eclass
(Portage version: 2.1_pre6-r6)
Diffstat (limited to 'games-emulation/tuxnes')
-rw-r--r--games-emulation/tuxnes/ChangeLog5
-rw-r--r--games-emulation/tuxnes/tuxnes-0.75.ebuild36
2 files changed, 27 insertions, 14 deletions
diff --git a/games-emulation/tuxnes/ChangeLog b/games-emulation/tuxnes/ChangeLog
index e0ec74fde4cd..fd8c544ad9d7 100644
--- a/games-emulation/tuxnes/ChangeLog
+++ b/games-emulation/tuxnes/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/tuxnes
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/ChangeLog,v 1.6 2006/02/11 04:21:22 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/ChangeLog,v 1.7 2006/03/23 20:42:41 mr_bones_ Exp $
+
+ 23 Mar 2006; Michael Sterrett <mr_bones_@gentoo.org> tuxnes-0.75.ebuild:
+ more dep fixing (bug #122168); use games eclass
11 Feb 2006; Joshua Baergen <joshuabaergen@gentoo.org> tuxnes-0.75.ebuild:
Add modular X dependencies (bug #122168, Tupone Alfredo).
diff --git a/games-emulation/tuxnes/tuxnes-0.75.ebuild b/games-emulation/tuxnes/tuxnes-0.75.ebuild
index 2182b1c16eaf..b75f6ffc8ce7 100644
--- a/games-emulation/tuxnes/tuxnes-0.75.ebuild
+++ b/games-emulation/tuxnes/tuxnes-0.75.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/tuxnes-0.75.ebuild,v 1.7 2006/02/11 04:21:22 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/tuxnes-0.75.ebuild,v 1.8 2006/03/23 20:42:41 mr_bones_ Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils games
DESCRIPTION="emulator for the 8-bit Nintendo Entertainment System"
HOMEPAGE="http://tuxnes.sourceforge.net/"
@@ -13,36 +13,46 @@ SLOT="0"
KEYWORDS="x86"
IUSE="X ggi"
-RDEPEND=">=media-libs/netpbm-9.12
- X? ( || ( ( x11-libs/libSM
- x11-libs/libXpm )
+RDEPEND="sys-libs/zlib
+ X? ( || (
+ (
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libSM )
virtual/x11 ) )
ggi? ( >=media-libs/libggi-2.0.1 )"
DEPEND="${RDEPEND}
- X? ( || ( x11-proto/xextproto virtual/x11 ) )"
+ X? ( || (
+ (
+ x11-proto/xextproto
+ x11-proto/xproto )
+ virtual/x11 ) )"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-configure.in.patch
- epatch "${FILESDIR}"/${P}-gcc34.patch
+ epatch \
+ "${FILESDIR}"/${P}-configure.in.patch \
+ "${FILESDIR}"/${P}-gcc34.patch
export WANT_AUTOCONF=2.5
aclocal && automake && autoconf || die "autoconf failed"
}
src_compile() {
replace-flags "-O?" "-O"
- econf \
+ egamesconf \
--without-w \
$(use_with ggi) \
$(use_with X x) \
|| die
- emake || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die
- insinto /usr/share/pixmaps
- doins tuxnes.xpm tuxnes2.xpm
+ make DESTDIR="${D}" install || die "make install failed"
+ doicon tuxnes.xpm tuxnes2.xpm
dodoc AUTHORS BUGS ChangeLog CHANGES NEWS README THANKS
+ prepgamesdirs
}