summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-18 03:44:48 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-18 03:44:48 +0000
commit1b8ff13b40b02b9ba693a2b089a9d3f0eb0c6598 (patch)
tree2078bdab238ae618a0f4c37c7484cadcf41a0719 /games-emulation
parentFix compile issue with zlib-1.2.6 (bug #403485). (diff)
downloadgentoo-2-1b8ff13b40b02b9ba693a2b089a9d3f0eb0c6598.tar.gz
gentoo-2-1b8ff13b40b02b9ba693a2b089a9d3f0eb0c6598.tar.bz2
gentoo-2-1b8ff13b40b02b9ba693a2b089a9d3f0eb0c6598.zip
Version bump to new snapshot.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/vbam/ChangeLog8
-rw-r--r--games-emulation/vbam/files/vbam-1.8.0.1090-ffmpeg.patch10
-rw-r--r--games-emulation/vbam/vbam-1.8.0.1090.ebuild77
3 files changed, 94 insertions, 1 deletions
diff --git a/games-emulation/vbam/ChangeLog b/games-emulation/vbam/ChangeLog
index e7def38663f0..27666bdd1a9d 100644
--- a/games-emulation/vbam/ChangeLog
+++ b/games-emulation/vbam/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/vbam
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/ChangeLog,v 1.9 2012/02/18 03:37:58 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/ChangeLog,v 1.10 2012/02/18 03:44:48 radhermit Exp $
+
+*vbam-1.8.0.1090 (18 Feb 2012)
+
+ 18 Feb 2012; Tim Harder <radhermit@gentoo.org> +vbam-1.8.0.1090.ebuild,
+ +files/vbam-1.8.0.1090-ffmpeg.patch:
+ Version bump to new snapshot.
18 Feb 2012; Tim Harder <radhermit@gentoo.org> vbam-1.8.0.1009-r1.ebuild,
+files/vbam-1.8.0.1009-zlib-1.2.6.patch:
diff --git a/games-emulation/vbam/files/vbam-1.8.0.1090-ffmpeg.patch b/games-emulation/vbam/files/vbam-1.8.0.1090-ffmpeg.patch
new file mode 100644
index 000000000000..deb212e97113
--- /dev/null
+++ b/games-emulation/vbam/files/vbam-1.8.0.1090-ffmpeg.patch
@@ -0,0 +1,10 @@
+--- vbam-1.8.0.1090.orig/src/common/ffmpeg.cpp
++++ vbam-1.8.0.1090/src/common/ffmpeg.cpp
+@@ -12,6 +12,7 @@
+ #include <libavformat/avformat.h>
+ #include <libswscale/swscale.h>
+ #include <libavcodec/opt.h>
++#include <libavutil/mathematics.h>
+ #ifndef AV_PKT_FLAG_KEY
+ #define AV_PKT_FLAG_KEY PKT_FLAG_KEY
+ #endif
diff --git a/games-emulation/vbam/vbam-1.8.0.1090.ebuild b/games-emulation/vbam/vbam-1.8.0.1090.ebuild
new file mode 100644
index 000000000000..239b5dad2bae
--- /dev/null
+++ b/games-emulation/vbam/vbam-1.8.0.1090.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/vbam-1.8.0.1090.ebuild,v 1.1 2012/02/18 03:44:48 radhermit Exp $
+
+EAPI=3
+
+inherit confutils cmake-utils games eutils
+
+DESCRIPTION="Game Boy, GBC, and GBA emulator forked from VisualBoyAdvance"
+HOMEPAGE="http://vba-m.ngemu.com"
+SRC_URI="http://dev.gentoo.org/~radhermit/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ffmpeg gtk link lirc nls +sdl"
+
+RDEPEND=">=media-libs/libpng-1.4
+ media-libs/libsdl[joystick]
+ link? ( media-libs/libsfml )
+ sys-libs/zlib
+ virtual/opengl
+ ffmpeg? ( virtual/ffmpeg )
+ gtk? ( >=dev-cpp/glibmm-2.4.0:2
+ >=dev-cpp/gtkmm-2.4.0:2.4
+ >=dev-cpp/gtkglextmm-1.2.0 )
+ lirc? ( app-misc/lirc )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ x86? ( || ( dev-lang/nasm dev-lang/yasm ) )
+ nls? ( sys-devel/gettext )
+ app-arch/xz-utils
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ confutils_require_any sdl gtk
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.0.1009-zlib-1.2.6.patch
+ epatch "${FILESDIR}"/${P}-ffmpeg.patch
+
+ # Fix issue with zlib-1.2.5.1 macros (bug #383179)
+ sed -i '1i#define OF(x) x' src/common/memgzio.c || die
+
+ sed -i -e "s:\(DESTINATION\) bin:\1 ${GAMES_BINDIR}:" CMakeLists.txt || die
+}
+
+src_configure() {
+ local myconf
+ use x86 && myconf="-DENABLE_ASM_SCALERS=ON -DENABLE_ASM_CORE=ON"
+
+ mycmakeargs=(
+ $(cmake-utils_use_enable ffmpeg FFMPEG)
+ $(cmake-utils_use_enable gtk GTK)
+ $(cmake-utils_use_enable link LINK)
+ $(cmake-utils_use_enable lirc LIRC)
+ $(cmake-utils_use_enable nls NLS)
+ $(cmake-utils_use_enable sdl SDL)
+ ${myconf}
+ "-DDATA_INSTALL_DIR=share/games/${PN}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use sdl ; then
+ dodoc doc/ReadMe.SDL.txt || die
+ doman debian/vbam.1 || die
+ fi
+
+ prepgamesdirs
+}