summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-10 01:00:18 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-10 01:00:18 +0000
commit524b557b628cd52b0d2e0685bc4180fe1dffee9a (patch)
tree1964b9d008a8e295a3aa308d39c50d135b4a6519 /games-emulation
parentSet myself as maintainer. (diff)
downloadgentoo-2-524b557b628cd52b0d2e0685bc4180fe1dffee9a.tar.gz
gentoo-2-524b557b628cd52b0d2e0685bc4180fe1dffee9a.tar.bz2
gentoo-2-524b557b628cd52b0d2e0685bc4180fe1dffee9a.zip
Fix LDFLAGS support.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/nestra/ChangeLog7
-rw-r--r--games-emulation/nestra/nestra-0.66-r1.ebuild17
2 files changed, 11 insertions, 13 deletions
diff --git a/games-emulation/nestra/ChangeLog b/games-emulation/nestra/ChangeLog
index 8dec2d657ff8..f4445ca8cf57 100644
--- a/games-emulation/nestra/ChangeLog
+++ b/games-emulation/nestra/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/nestra
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/ChangeLog,v 1.7 2005/07/13 21:57:09 mr_bones_ Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/ChangeLog,v 1.8 2006/01/10 01:00:18 vapier Exp $
+
+ 10 Jan 2006; Mike Frysinger <vapier@gentoo.org> nestra-0.66-r1.ebuild:
+ Fix LDFLAGS support.
13 Jul 2005; Michael Sterrett <mr_bones_@gentoo.org>
nestra-0.66-r1.ebuild:
diff --git a/games-emulation/nestra/nestra-0.66-r1.ebuild b/games-emulation/nestra/nestra-0.66-r1.ebuild
index 411b62e0abaa..d589be975546 100644
--- a/games-emulation/nestra/nestra-0.66-r1.ebuild
+++ b/games-emulation/nestra/nestra-0.66-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.9 2005/07/13 21:57:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.10 2006/01/10 01:00:18 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic games
@@ -42,17 +42,12 @@ src_unpack() {
cd "${S}"
epatch "${WORKDIR}/${PATCH}"
sed -i \
+ -e "s:-L/usr/X11R6/lib::" \
-e 's:-O2 ::' \
- -e "s:ld:$(tc-getLD) ${LDFLAGS}:" \
- -e "s:gcc:$(tc-getCC) ${CFLAGS}:" Makefile \
+ -e "s:gcc:$(tc-getCC) ${CFLAGS}:" \
+ -e "s:ld:$(tc-getLD) $(raw-ldflags):" \
+ Makefile \
|| die "sed failed"
-
- #94871
- if use amd64 ; then
- sed -i \
- -e "s:-L/usr/X11R6/lib:-L/emul/linux/x86/usr/lib32:" Makefile \
- || die "sed failed"
- fi
}
src_install() {