summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-01-20 07:00:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-01-20 07:00:38 +0000
commit542b4ae36bb6b6f72964fce8cef7c017abb3d3c2 (patch)
tree87983019759cd97314992023a9b908095ba6f77f /games-emulation
parentremoved media-video/gspcav1 from package.mask (diff)
downloadgentoo-2-542b4ae36bb6b6f72964fce8cef7c017abb3d3c2.tar.gz
gentoo-2-542b4ae36bb6b6f72964fce8cef7c017abb3d3c2.tar.bz2
gentoo-2-542b4ae36bb6b6f72964fce8cef7c017abb3d3c2.zip
version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/files/digest-stella-2.3.53
-rw-r--r--games-emulation/stella/stella-2.3.5.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index ec2aae426a0a..ede59f550f5a 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.22 2007/01/03 10:51:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.23 2007/01/20 07:00:38 mr_bones_ Exp $
+
+*stella-2.3.5 (20 Jan 2007)
+
+ 20 Jan 2007; Michael Sterrett <mr_bones_@gentoo.org> +stella-2.3.5.ebuild:
+ version bump
*stella-2.3 (03 Jan 2007)
diff --git a/games-emulation/stella/files/digest-stella-2.3.5 b/games-emulation/stella/files/digest-stella-2.3.5
new file mode 100644
index 000000000000..032f2825e5b3
--- /dev/null
+++ b/games-emulation/stella/files/digest-stella-2.3.5
@@ -0,0 +1,3 @@
+MD5 b3458475518b53c459a76399da5dcc3f stella-2.3.5-src.tar.gz 1331004
+RMD160 0a3b33ec08b08b8a975d56b33e4bfdc527a37cba stella-2.3.5-src.tar.gz 1331004
+SHA256 b42847f471a29273f28a149af3bb58843fa29ddd5045cced79c68103645d4ecb stella-2.3.5-src.tar.gz 1331004
diff --git a/games-emulation/stella/stella-2.3.5.ebuild b/games-emulation/stella/stella-2.3.5.ebuild
new file mode 100644
index 000000000000..5dc661b29cee
--- /dev/null
+++ b/games-emulation/stella/stella-2.3.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-2.3.5.ebuild,v 1.1 2007/01/20 07:00:38 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ media-libs/libpng
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/strip/d' \
+ -e "/icons/d" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.xpm
+ make_desktop_entry stella Stella stella.xpm
+ prepgamesdirs
+}