summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-25 11:56:44 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-25 11:56:44 +0000
commit74a8f4e7c0ec7d0a2d5d95ac4c3077a48a8e97f7 (patch)
tree2c23c52a2213e59efa4f6346bfb2ef0be614d09a /games-emulation
parentver bump (diff)
downloadgentoo-2-74a8f4e7c0ec7d0a2d5d95ac4c3077a48a8e97f7.tar.gz
gentoo-2-74a8f4e7c0ec7d0a2d5d95ac4c3077a48a8e97f7.tar.bz2
gentoo-2-74a8f4e7c0ec7d0a2d5d95ac4c3077a48a8e97f7.zip
old
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/advancemame-0.62.0.ebuild115
-rw-r--r--games-emulation/advancemame/advancemame-0.62.2.ebuild115
-rw-r--r--games-emulation/advancemame/advancemame-0.63.0.ebuild111
-rw-r--r--games-emulation/advancemame/files/advancemame-0.62.0-sdl-configure.patch24
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.62.03
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.62.23
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.63.03
7 files changed, 0 insertions, 374 deletions
diff --git a/games-emulation/advancemame/advancemame-0.62.0.ebuild b/games-emulation/advancemame/advancemame-0.62.0.ebuild
deleted file mode 100644
index eb557e1ee1f0..000000000000
--- a/games-emulation/advancemame/advancemame-0.62.0.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.62.0.ebuild,v 1.1 2003/09/09 16:26:49 vapier Exp $
-
-inherit eutils
-
-# This build we configure to explicitly use SDL, as it is very
-# difficult to get it working with fb or svgalib support. Anyway,
-# it do not look as good ;-)
-
-ADVMNU_VER="2.2.0"
-
-MY_PV="$(echo ${PV} | cut -d. -f1,2)"
-S="${WORKDIR}/advmame"
-DESCRIPTION="GNU/Linux port of the MAME emulator, with GUI menu."
-SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz
- mirror://sourceforge/advancemame/advancemenu-${ADVMNU_VER}.tar.gz
- http://mbnet.fi/~gridle/mame${MY_PV/\.}s.zip
- http://www.mame.net/zips/mame${MY_PV/\.}s.zip
- http://roms.mame.dk/emu/mame${MY_PV/\.}s.zip"
-HOMEPAGE="http://advancemame.sourceforge.net/"
-
-LICENSE="GPL-2 xmame"
-SLOT="0"
-KEYWORDS="~x86 -ppc"
-
-RDEPEND="virtual/glibc
- app-arch/unzip
- >=dev-lang/nasm-0.98
- >=media-libs/libsdl-1.2.3
- slang? ( sys-libs/slang )
- svga? ( >=media-libs/svgalib-1.9 )"
-DEPEND="${RDEPEND}
- sys-kernel/linux-headers"
-
-src_unpack() {
- unpack ${A}
-
- mkdir -p ${S}
-
- cd ${S}
- # Unpack mame and advacemame
- unzip -aa ${WORKDIR}/MAME.ZIP || die
- cp -adf ${WORKDIR}/${P}/* .
- cp -adf ${WORKDIR}/advancemenu-${ADVMNU_VER}/* .
-
- # This one is from MAME.ZIP, and breaks things if present
- rm -f makefile
-
- # Fix type-o in configue script
- # <azarah@gentoo.org> (20 Nov 2002)
- epatch ${FILESDIR}/${P}-sdl-configure.patch
-
- cd ${S}/src
- # Apply the advancemame patch to the mame sources
- epatch ../advance/advmame.dif
-
- for x in os.c vslang.c
- do
- cp -f ${S}/advance/linux/${x} ${S}/advance/linux/${x}.orig
- sed -e 's:slang/slang.h:slang.h:' \
- ${S}/advance/linux/${x}.orig > ${S}/advance/linux/${x}
- rm -f ${S}/advance/linux/${x}.orig
- done
-
- # Fix manpage/doc install location
- cp -f ${S}/advance/advance.mak ${S}/advance/advance.mak.orig
- sed -e 's:$(PREFIX)/doc/advance:$(PREFIX)/share/doc/$(PF):g' \
- -e 's:$(PREFIX)/man/man1:$(PREFIX)/share/man/man1:g' \
- ${S}/advance/advance.mak.orig > ${S}/advance/advance.mak
- rm -f ${S}/advance/advance.mak.orig
-}
-
-src_compile() {
- local myconf=""
-
- use fbcon || myconf="${myconf} --disable-fb"
-
- use oss || myconf="${myconf} --disable-oss"
-
- use slang || myconf="${myconf} --disable-slang"
-
- use svga || myconf="${myconf} --disable-svgalib"
-
- # Configure with explicit SDL support
- # NOTE: do not use econf, as we should not
- # pass --host ...
- ./configure \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-system=sdl \
- --enable-pthread \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- # The install script do not create this one
- dodir /usr/bin
- make PREFIX=${D}/usr install || die
-
- dodir /usr/share/advance/{artwork,diff,image,rom,sample,snap}
-
- dodoc COPYING HISTORY README RELEASE whatsnew.txt
- dodoc docs/{ctrlr.txt,listinfo.txt,mame.txt}
- # Zip the docs that was installed by 'make install'
- gzip ${D}/usr/share/doc/${PF}/*.txt
-
- # Move the html pages the the correct location
- dodir /usr/share/doc/${PF}/html
- mv -f ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/html
-}
-
diff --git a/games-emulation/advancemame/advancemame-0.62.2.ebuild b/games-emulation/advancemame/advancemame-0.62.2.ebuild
deleted file mode 100644
index 3fd9edd02929..000000000000
--- a/games-emulation/advancemame/advancemame-0.62.2.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.62.2.ebuild,v 1.1 2003/09/09 16:26:49 vapier Exp $
-
-inherit eutils
-
-# This build we configure to explicitly use SDL, as it is very
-# difficult to get it working with fb or svgalib support. Anyway,
-# it do not look as good ;-)
-
-ADVMNU_VER="2.2.2"
-
-MY_PV="$(echo ${PV} | cut -d. -f1,2)"
-S="${WORKDIR}/advmame"
-DESCRIPTION="GNU/Linux port of the MAME emulator, with GUI menu."
-SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz
- mirror://sourceforge/advancemame/advancemenu-${ADVMNU_VER}.tar.gz
- http://mbnet.fi/~gridle/mame${MY_PV/\.}s.zip
- http://www.mame.net/zips/mame${MY_PV/\.}s.zip
- http://roms.mame.dk/emu/mame${MY_PV/\.}s.zip"
-HOMEPAGE="http://advancemame.sourceforge.net/"
-
-LICENSE="GPL-2 xmame"
-SLOT="0"
-KEYWORDS="~x86 -ppc"
-
-RDEPEND="virtual/glibc
- app-arch/unzip
- >=dev-lang/nasm-0.98
- >=media-libs/libsdl-1.2.3
- slang? ( sys-libs/slang )
- svga? ( >=media-libs/svgalib-1.9 )"
-DEPEND="${RDEPEND}
- sys-kernel/linux-headers"
-
-src_unpack() {
- unpack ${A}
-
- mkdir -p ${S}
-
- cd ${S}
- # Unpack mame and advacemame
- unzip -aa ${WORKDIR}/MAME.ZIP || die
- cp -adf ${WORKDIR}/${P}/* .
- cp -adf ${WORKDIR}/advancemenu-${ADVMNU_VER}/* .
-
- # This one is from MAME.ZIP, and breaks things if present
- rm -f makefile
-
- # Fix type-o in configue script
- # <azarah@gentoo.org> (20 Nov 2002)
- epatch ${FILESDIR}/${PN}-0.62.0-sdl-configure.patch
-
- cd ${S}/src
- # Apply the advancemame patch to the mame sources
- epatch ../advance/advmame.dif
-
- for x in os.c vslang.c
- do
- cp -f ${S}/advance/linux/${x} ${S}/advance/linux/${x}.orig
- sed -e 's:slang/slang.h:slang.h:' \
- ${S}/advance/linux/${x}.orig > ${S}/advance/linux/${x}
- rm -f ${S}/advance/linux/${x}.orig
- done
-
- # Fix manpage/doc install location
- cp -f ${S}/advance/advance.mak ${S}/advance/advance.mak.orig
- sed -e 's:$(PREFIX)/doc/advance:$(PREFIX)/share/doc/$(PF):g' \
- -e 's:$(PREFIX)/man/man1:$(PREFIX)/share/man/man1:g' \
- ${S}/advance/advance.mak.orig > ${S}/advance/advance.mak
- rm -f ${S}/advance/advance.mak.orig
-}
-
-src_compile() {
- local myconf=""
-
- use fbcon || myconf="${myconf} --disable-fb"
-
- use oss || myconf="${myconf} --disable-oss"
-
- use slang || myconf="${myconf} --disable-slang"
-
- use svga || myconf="${myconf} --disable-svgalib"
-
- # Configure with explicit SDL support
- # NOTE: do not use econf, as we should not
- # pass --host ...
- ./configure \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-system=sdl \
- --enable-pthread \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- # The install script do not create this one
- dodir /usr/bin
- make PREFIX=${D}/usr install || die
-
- dodir /usr/share/advance/{artwork,diff,image,rom,sample,snap}
-
- dodoc COPYING HISTORY README RELEASE whatsnew.txt
- dodoc docs/{ctrlr.txt,listinfo.txt,mame.txt}
- # Zip the docs that was installed by 'make install'
- gzip ${D}/usr/share/doc/${PF}/*.txt
-
- # Move the html pages the the correct location
- dodir /usr/share/doc/${PF}/html
- mv -f ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/html
-}
-
diff --git a/games-emulation/advancemame/advancemame-0.63.0.ebuild b/games-emulation/advancemame/advancemame-0.63.0.ebuild
deleted file mode 100644
index bec1d7605c24..000000000000
--- a/games-emulation/advancemame/advancemame-0.63.0.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.63.0.ebuild,v 1.1 2003/09/09 16:26:49 vapier Exp $
-
-inherit eutils
-
-# This build we configure to explicitly use SDL, as it is very
-# difficult to get it working with fb or svgalib support. Anyway,
-# it do not look as good ;-)
-
-ADVMNU_VER="2.2.3"
-
-MY_PV="$(echo ${PV} | cut -d. -f1,2)"
-S="${WORKDIR}/advmame"
-DESCRIPTION="GNU/Linux port of the MAME emulator, with GUI menu."
-SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz
- mirror://sourceforge/advancemame/advancemenu-${ADVMNU_VER}.tar.gz
- http://mbnet.fi/~gridle/mame${MY_PV/\.}s.zip
- http://www.mame.net/zips/mame${MY_PV/\.}s.zip
- http://roms.mame.dk/emu/mame${MY_PV/\.}s.zip"
-HOMEPAGE="http://advancemame.sourceforge.net/"
-
-LICENSE="GPL-2 xmame"
-SLOT="0"
-KEYWORDS="~x86 -ppc"
-
-RDEPEND="virtual/glibc
- app-arch/unzip
- >=dev-lang/nasm-0.98
- >=media-libs/libsdl-1.2.3
- slang? ( sys-libs/slang )
- svga? ( >=media-libs/svgalib-1.9 )"
-DEPEND="${RDEPEND}
- sys-kernel/linux-headers"
-
-src_unpack() {
- unpack ${A}
-
- mkdir -p ${S}
-
- cd ${S}
- # Unpack mame and advacemame
- unzip -qaa ${WORKDIR}/MAME${MY_PV/\.}.ZIP || die
- cp -adf ${WORKDIR}/${P}/* .
- cp -adf ${WORKDIR}/advancemenu-${ADVMNU_VER}/* .
-
- # This one is from MAME.ZIP, and breaks things if present
- rm -f makefile
-
- cd ${S}/src
- # Apply the advancemame patch to the mame sources
- epatch ../advance/advmame.dif
-
- for x in os.c vslang.c
- do
- cp -f ${S}/advance/linux/${x} ${S}/advance/linux/${x}.orig
- sed -e 's:slang/slang.h:slang.h:' \
- ${S}/advance/linux/${x}.orig > ${S}/advance/linux/${x}
- rm -f ${S}/advance/linux/${x}.orig
- done
-
- # Fix manpage/doc install location
- cp -f ${S}/advance/advance.mak ${S}/advance/advance.mak.orig
- sed -e 's:$(PREFIX)/doc/advance:$(PREFIX)/share/doc/$(PF):g' \
- -e 's:$(PREFIX)/man/man1:$(PREFIX)/share/man/man1:g' \
- ${S}/advance/advance.mak.orig > ${S}/advance/advance.mak
- rm -f ${S}/advance/advance.mak.orig
-}
-
-src_compile() {
- local myconf=""
-
- use fbcon || myconf="${myconf} --disable-fb"
-
- use oss || myconf="${myconf} --disable-oss"
-
- use slang || myconf="${myconf} --disable-slang"
-
- use svga || myconf="${myconf} --disable-svgalib"
-
- # Configure with explicit SDL support
- # NOTE: do not use econf, as we should not
- # pass --host ...
- ./configure \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-system=sdl \
- --enable-pthread \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- # The install script do not create this one
- dodir /usr/bin
- make PREFIX=${D}/usr install || die
-
- dodir /usr/share/advance/{artwork,diff,image,rom,sample,snap}
-
- dodoc COPYING HISTORY README RELEASE whatsnew.txt
- dodoc docs/{ctrlr.txt,listinfo.txt,mame.txt}
- # Zip the docs that was installed by 'make install'
- gzip ${D}/usr/share/doc/${PF}/*.txt
-
- # Move the html pages the the correct location
- dodir /usr/share/doc/${PF}/html
- mv -f ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/html
-}
-
diff --git a/games-emulation/advancemame/files/advancemame-0.62.0-sdl-configure.patch b/games-emulation/advancemame/files/advancemame-0.62.0-sdl-configure.patch
deleted file mode 100644
index e25e247b65df..000000000000
--- a/games-emulation/advancemame/files/advancemame-0.62.0-sdl-configure.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- advmame/configure.orig 2002-11-20 11:31:46.000000000 +0200
-+++ advmame/configure 2002-11-20 11:32:23.000000000 +0200
-@@ -4513,9 +4513,7 @@
-
- test -n "$SDLCONFIG" && break
- done
--test -n "$SDLCONFIG" || SDLCONFIG="no
-- "
--
-+test -n "$SDLCONFIG" || SDLCONFIG="no"
- else
- for ac_prog in ${host_alias}-sdl-config
- do
-@@ -4556,9 +4554,7 @@
-
- test -n "$SDLCONFIG" && break
- done
--test -n "$SDLCONFIG" || SDLCONFIG="no
-- "
--
-+test -n "$SDLCONFIG" || SDLCONFIG="no"
- fi
- if test ! $SDLCONFIG = no; then
- SDLCFLAGS=`$SDLCONFIG --cflags`
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.62.0 b/games-emulation/advancemame/files/digest-advancemame-0.62.0
deleted file mode 100644
index a286b8000628..000000000000
--- a/games-emulation/advancemame/files/digest-advancemame-0.62.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a6a33e6f9a6b6380f607fd4029116925 advancemame-0.62.0.tar.gz 1028396
-MD5 354b6f7db4cfdb376f169e4933b310c3 advancemenu-2.2.0.tar.gz 1022057
-MD5 e1a175bb0265c2a03da3b881ee2a3a49 mame062s.zip 6375517
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.62.2 b/games-emulation/advancemame/files/digest-advancemame-0.62.2
deleted file mode 100644
index 9d6f7aa8a0e1..000000000000
--- a/games-emulation/advancemame/files/digest-advancemame-0.62.2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 b854f14be9db0984a9d87e57dc822993 advancemame-0.62.2.tar.gz 1041744
-MD5 7876e5eceac991e7cc559eb76e5349ff advancemenu-2.2.2.tar.gz 1033888
-MD5 e1a175bb0265c2a03da3b881ee2a3a49 mame062s.zip 6375517
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.63.0 b/games-emulation/advancemame/files/digest-advancemame-0.63.0
deleted file mode 100644
index 72b288e16ff2..000000000000
--- a/games-emulation/advancemame/files/digest-advancemame-0.63.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 99e6645903b28ad438361b86a4f0d669 advancemame-0.63.0.tar.gz 1046668
-MD5 9f979e321b8fe47825c4c870844c9d26 advancemenu-2.2.3.tar.gz 1040606
-MD5 f51db33f439dc48ec396bf83385af113 mame063s.zip 6576345