summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-09 15:49:33 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-09 15:49:33 +0000
commit8d22186c1105ac468e9b03eca60fff8f52f55a7e (patch)
treea92c793844d64f101217500d3f1e3bd4d1c62b91 /games-emulation
parentStable on amd64 wrt bug 169995 (diff)
downloadgentoo-2-8d22186c1105ac468e9b03eca60fff8f52f55a7e.tar.gz
gentoo-2-8d22186c1105ac468e9b03eca60fff8f52f55a7e.tar.bz2
gentoo-2-8d22186c1105ac468e9b03eca60fff8f52f55a7e.zip
use games_get_libdir
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild b/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild
index 4dbb64e5bce3..ed79f2822823 100644
--- a/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild
+++ b/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild,v 1.6 2006/05/29 21:10:32 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild,v 1.7 2007/04/09 15:49:33 nyhm Exp $
inherit eutils games
@@ -22,22 +22,26 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/GSsoft${PV}
src_unpack() {
- unrar x -idq "${DISTDIR}"/${A} || die
+ unpack ${A}
cd "${S}"
- sed -i 's:-O2 -fomit-frame-pointer -ffast-math:$(OPTFLAGS):' Src/Linux/Makefile || die
- epatch "${FILESDIR}"/${P}-gentoo.patch \
+ sed -i \
+ 's:-O2 -fomit-frame-pointer -ffast-math:$(OPTFLAGS):' \
+ Src/Linux/Makefile \
+ || die "sed failed"
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-PIC.patch \
"${FILESDIR}/${P}"-gcc41.patch
}
src_compile() {
cd Src/Linux
- emake OPTFLAGS="${CFLAGS}" || die "make failed"
+ emake OPTFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
dodoc ReadMe.txt
- exeinto "${GAMES_LIBDIR}"/ps2emu/plugins
- newexe Src/Linux/libGSsoft.so libGSsoft-${PV}.so || die
+ exeinto "$(games_get_libdir)"/ps2emu/plugins
+ newexe Src/Linux/libGSsoft.so libGSsoft-${PV}.so || die "newexe failed"
prepgamesdirs
}