summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-11-12 21:01:35 +0000
committerHanno Böck <hanno@gentoo.org>2011-11-12 21:01:35 +0000
commit9e1c3e307c544c1a9e8a6cbe972159ea779a547b (patch)
treefc8d92bf557d348affe951c43c65400fd7bbff82 /games-emulation
parentRemoving the SELinux 2.20101213 policies (diff)
downloadgentoo-2-9e1c3e307c544c1a9e8a6cbe972159ea779a547b.tar.gz
gentoo-2-9e1c3e307c544c1a9e8a6cbe972159ea779a547b.tar.bz2
gentoo-2-9e1c3e307c544c1a9e8a6cbe972159ea779a547b.zip
desmume version bump
(Portage version: 2.1.10.34/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/desmume/ChangeLog11
-rw-r--r--games-emulation/desmume/desmume-0.9.7.ebuild43
-rw-r--r--games-emulation/desmume/files/desmume-add-missing-potfiles.diff6
-rw-r--r--games-emulation/desmume/files/desmume-fix-gcc-warning.diff22
4 files changed, 80 insertions, 2 deletions
diff --git a/games-emulation/desmume/ChangeLog b/games-emulation/desmume/ChangeLog
index 0d4c9bceffff..1095794a1724 100644
--- a/games-emulation/desmume/ChangeLog
+++ b/games-emulation/desmume/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-emulation/desmume
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/ChangeLog,v 1.17 2010/01/16 18:07:07 hanno Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/ChangeLog,v 1.18 2011/11/12 21:01:35 hanno Exp $
+
+*desmume-0.9.7 (12 Nov 2011)
+
+ 12 Nov 2011; Hanno Boeck <hanno@gentoo.org> +desmume-0.9.7.ebuild,
+ +files/desmume-add-missing-potfiles.diff,
+ +files/desmume-fix-gcc-warning.diff:
+ Version bump, fix for make check and gcc warnings.
16 Jan 2010; Hanno Boeck <hanno@gentoo.org> desmume-0.9.5.ebuild,
+files/desmume-0.9.5-sse2-fix.diff:
diff --git a/games-emulation/desmume/desmume-0.9.7.ebuild b/games-emulation/desmume/desmume-0.9.7.ebuild
new file mode 100644
index 000000000000..4c65d14541a4
--- /dev/null
+++ b/games-emulation/desmume/desmume-0.9.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/desmume-0.9.7.ebuild,v 1.1 2011/11/12 21:01:35 hanno Exp $
+
+EAPI="2"
+
+inherit eutils games
+
+DESCRIPTION="Nintendo DS emulator"
+HOMEPAGE="http://desmume.org/"
+SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.8.0:2
+ gnome-base/libglade
+ x11-libs/gtkglext
+ virtual/opengl
+ sys-libs/zlib
+ dev-libs/zziplib
+ media-libs/libsdl[joystick]
+ x11-libs/agg"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # https://sourceforge.net/tracker/?func=detail&aid=3436660&group_id=164579&atid=832291
+ epatch "${FILESDIR}/desmume-add-missing-potfiles.diff"
+ # https://sourceforge.net/tracker/?func=detail&aid=3436995&group_id=164579&atid=832291
+ epatch "${FILESDIR}/desmume-fix-gcc-warning.diff"
+}
+
+src_configure() {
+ egamesconf --datadir=/usr/share || die "egamesconf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc AUTHORS ChangeLog README README.LIN
+ prepgamesdirs
+}
diff --git a/games-emulation/desmume/files/desmume-add-missing-potfiles.diff b/games-emulation/desmume/files/desmume-add-missing-potfiles.diff
new file mode 100644
index 000000000000..7ce2f8758086
--- /dev/null
+++ b/games-emulation/desmume/files/desmume-add-missing-potfiles.diff
@@ -0,0 +1,6 @@
+--- desmume-0.9.7/po/POTFILES.skip 2011-01-27 11:27:00.000000000 +0100
++++ desmume-0.9.7-1/po/POTFILES.skip 2011-11-11 21:10:30.550725740 +0100
+@@ -1,2 +1,3 @@
+ src/wx/PadSimple/GUI/ConfigDlg.cpp
+ src/wxdlg/wxdlg3dViewer.cpp
++src/wxdlg/wxcontrolsconfigdialog.cpp
diff --git a/games-emulation/desmume/files/desmume-fix-gcc-warning.diff b/games-emulation/desmume/files/desmume-fix-gcc-warning.diff
new file mode 100644
index 000000000000..409640264c7a
--- /dev/null
+++ b/games-emulation/desmume/files/desmume-fix-gcc-warning.diff
@@ -0,0 +1,22 @@
+--- desmume-0.9.7/src/GPU.cpp 2011-01-27 11:27:00.000000000 +0100
++++ desmume-0.9.7-fix-warning/src/GPU.cpp 2011-11-11 21:17:10.826721602 +0100
+@@ -1184,16 +1184,16 @@
+ case BGType_AffineExt_256x1:
+ // 256 colors
+ pal = MMU.ARM9_VMEM + gpu->core * 0x400;
+- apply_rot_fun<rot_256_map<MOSAIC> >(gpu,X,Y,PA,PB,PC,PD,LG, gpu->BG_bmp_ram[num], NULL, pal);
++ apply_rot_fun<rot_256_map<MOSAIC> >(gpu,X,Y,PA,PB,PC,PD,LG, gpu->BG_bmp_ram[num], 0, pal);
+ return;
+ case BGType_AffineExt_Direct:
+ // direct colors / BMP
+- apply_rot_fun<rot_BMP_map<MOSAIC> >(gpu,X,Y,PA,PB,PC,PD,LG, gpu->BG_bmp_ram[num], NULL, NULL);
++ apply_rot_fun<rot_BMP_map<MOSAIC> >(gpu,X,Y,PA,PB,PC,PD,LG, gpu->BG_bmp_ram[num], 0, NULL);
+ return;
+ case BGType_Large8bpp:
+ // large screen 256 colors
+ pal = MMU.ARM9_VMEM + gpu->core * 0x400;
+- apply_rot_fun<rot_256_map<MOSAIC> >(gpu,X,Y,PA,PB,PC,PD,LG, gpu->BG_bmp_large_ram[num], NULL, pal);
++ apply_rot_fun<rot_256_map<MOSAIC> >(gpu,X,Y,PA,PB,PC,PD,LG, gpu->BG_bmp_large_ram[num], 0, pal);
+ return;
+ default: break;
+ }