summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-30 01:36:53 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-30 01:36:53 +0000
commitcb5d40525b9979e6000fa6d2c541eb50cee6f3fb (patch)
treec69304babcab29883299bf5b307819313c5c676d /games-emulation
parentmark stable (Manifest recommit) (diff)
downloadgentoo-2-cb5d40525b9979e6000fa6d2c541eb50cee6f3fb.tar.gz
gentoo-2-cb5d40525b9979e6000fa6d2c541eb50cee6f3fb.tar.bz2
gentoo-2-cb5d40525b9979e6000fa6d2c541eb50cee6f3fb.zip
fix install
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/advancemame-0.81.0.ebuild75
-rw-r--r--games-emulation/advancemame/advancemame-0.82.0.ebuild75
-rw-r--r--games-emulation/advancemame/advancemame-0.83.0.ebuild75
-rw-r--r--games-emulation/advancemame/advancemame-0.83.1.ebuild75
-rw-r--r--games-emulation/advancemame/advancemame-0.85.0.ebuild14
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.81.01
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.82.01
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.83.01
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.83.11
9 files changed, 9 insertions, 309 deletions
diff --git a/games-emulation/advancemame/advancemame-0.81.0.ebuild b/games-emulation/advancemame/advancemame-0.81.0.ebuild
deleted file mode 100644
index 39442187cd94..000000000000
--- a/games-emulation/advancemame/advancemame-0.81.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.81.0.ebuild,v 1.4 2004/07/01 11:12:56 eradicator Exp $
-
-inherit eutils games
-
-DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
-HOMEPAGE="http://advancemame.sourceforge.net/"
-SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
-
-LICENSE="GPL-2 xmame"
-SLOT="0"
-KEYWORDS="x86 ppc"
-IUSE="debug static svga truetype fbcon alsa oss slang sdl"
-
-RDEPEND="virtual/libc
- app-arch/unzip
- app-arch/zip
- x86? ( >=dev-lang/nasm-0.98 )
- sdl? ( media-libs/libsdl )
- slang? ( sys-libs/slang )
- alsa? ( media-libs/alsa-lib )
- truetype? ( media-libs/freetype )
- svga? ( >=media-libs/svgalib-1.9 )"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-src_unpack() {
- unpack ${A}
-
- use x86 && \
- ln -s $(which nasm) "${T}/${CHOST}-nasm"
- use sdl && \
- ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
- use truetype && \
- ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
-}
-
-src_compile() {
- PATH="${PATH}:${T}"
- egamesconf \
- $(use_enable debug) \
- $(use_enable truetype freetype) \
- $(use_enable static) \
- $(use_enable x86 asm) \
- $(use_enable svga svgalib) \
- $(use_enable fbcon fb) \
- $(use_enable alsa) \
- $(use_enable oss) \
- $(use_enable slang) \
- $(use_enable sdl) \
- --with-emu=${PN/advance} \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- local m
-
- dogamesbin adv* || die "dogamesbin failed"
-
- keepdir "${GAMES_DATADIR}"/advance/{artwork,diff,image,rom,sample,snap}
- insinto "${GAMES_DATADIR}/advance"
- doins support/event.dat
-
- dodoc HISTORY README RELEASE
- cd obj/doc
- dodoc *.txt
- dohtml *.html
- for m in *.1 ; do
- newman ${m} ${m/1/6}
- done
-
- prepgamesdirs
-}
diff --git a/games-emulation/advancemame/advancemame-0.82.0.ebuild b/games-emulation/advancemame/advancemame-0.82.0.ebuild
deleted file mode 100644
index 7d1ed69c0913..000000000000
--- a/games-emulation/advancemame/advancemame-0.82.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.82.0.ebuild,v 1.3 2004/07/01 11:12:56 eradicator Exp $
-
-inherit eutils games
-
-DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
-HOMEPAGE="http://advancemame.sourceforge.net/"
-SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
-
-LICENSE="GPL-2 xmame"
-SLOT="0"
-KEYWORDS="x86 ppc"
-IUSE="debug static svga truetype fbcon alsa oss slang sdl"
-
-RDEPEND="virtual/libc
- app-arch/unzip
- app-arch/zip
- x86? ( >=dev-lang/nasm-0.98 )
- sdl? ( media-libs/libsdl )
- slang? ( sys-libs/slang )
- alsa? ( media-libs/alsa-lib )
- truetype? ( media-libs/freetype )
- svga? ( >=media-libs/svgalib-1.9 )"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-src_unpack() {
- unpack ${A}
-
- use x86 && \
- ln -s $(which nasm) "${T}/${CHOST}-nasm"
- use sdl && \
- ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
- use truetype && \
- ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
-}
-
-src_compile() {
- PATH="${PATH}:${T}"
- egamesconf \
- $(use_enable debug) \
- $(use_enable truetype freetype) \
- $(use_enable static) \
- $(use_enable x86 asm) \
- $(use_enable svga svgalib) \
- $(use_enable fbcon fb) \
- $(use_enable alsa) \
- $(use_enable oss) \
- $(use_enable slang) \
- $(use_enable sdl) \
- --with-emu=${PN/advance} \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- local m
-
- dogamesbin adv* || die "dogamesbin failed"
-
- keepdir "${GAMES_DATADIR}"/advance/{artwork,diff,image,rom,sample,snap}
- insinto "${GAMES_DATADIR}/advance"
- doins support/event.dat
-
- dodoc HISTORY README RELEASE
- cd obj/doc
- dodoc *.txt
- dohtml *.html
- for m in *.1 ; do
- newman ${m} ${m/1/6}
- done
-
- prepgamesdirs
-}
diff --git a/games-emulation/advancemame/advancemame-0.83.0.ebuild b/games-emulation/advancemame/advancemame-0.83.0.ebuild
deleted file mode 100644
index b0da95207158..000000000000
--- a/games-emulation/advancemame/advancemame-0.83.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.83.0.ebuild,v 1.3 2004/07/01 11:12:56 eradicator Exp $
-
-inherit eutils games
-
-DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
-HOMEPAGE="http://advancemame.sourceforge.net/"
-SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
-
-LICENSE="GPL-2 xmame"
-SLOT="0"
-KEYWORDS="x86 ppc"
-IUSE="debug static svga truetype fbcon alsa oss slang sdl"
-
-RDEPEND="virtual/libc
- app-arch/unzip
- app-arch/zip
- x86? ( >=dev-lang/nasm-0.98 )
- sdl? ( media-libs/libsdl )
- slang? ( sys-libs/slang )
- alsa? ( media-libs/alsa-lib )
- truetype? ( media-libs/freetype )
- svga? ( >=media-libs/svgalib-1.9 )"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-src_unpack() {
- unpack ${A}
-
- use x86 && \
- ln -s $(which nasm) "${T}/${CHOST}-nasm"
- use sdl && \
- ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
- use truetype && \
- ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
-}
-
-src_compile() {
- PATH="${PATH}:${T}"
- egamesconf \
- $(use_enable debug) \
- $(use_enable truetype freetype) \
- $(use_enable static) \
- $(use_enable x86 asm) \
- $(use_enable svga svgalib) \
- $(use_enable fbcon fb) \
- $(use_enable alsa) \
- $(use_enable oss) \
- $(use_enable slang) \
- $(use_enable sdl) \
- --with-emu=${PN/advance} \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- local m
-
- dogamesbin adv* || die "dogamesbin failed"
-
- keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
- insinto "${GAMES_DATADIR}/advance"
- doins support/event.dat
-
- dodoc HISTORY README RELEASE
- cd obj/doc
- dodoc *.txt
- dohtml *.html
- for m in *.1 ; do
- newman ${m} ${m/1/6}
- done
-
- prepgamesdirs
-}
diff --git a/games-emulation/advancemame/advancemame-0.83.1.ebuild b/games-emulation/advancemame/advancemame-0.83.1.ebuild
deleted file mode 100644
index 47ff8e8b1a5e..000000000000
--- a/games-emulation/advancemame/advancemame-0.83.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.83.1.ebuild,v 1.2 2004/07/06 21:24:03 malc Exp $
-
-inherit eutils games
-
-DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
-HOMEPAGE="http://advancemame.sourceforge.net/"
-SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
-
-LICENSE="GPL-2 xmame"
-SLOT="0"
-KEYWORDS="x86 ppc ~amd64"
-IUSE="debug static svga truetype fbcon alsa oss slang sdl"
-
-RDEPEND="virtual/libc
- app-arch/unzip
- app-arch/zip
- x86? ( >=dev-lang/nasm-0.98 )
- sdl? ( media-libs/libsdl )
- slang? ( sys-libs/slang )
- alsa? ( media-libs/alsa-lib )
- truetype? ( media-libs/freetype )
- svga? ( >=media-libs/svgalib-1.9 )"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-src_unpack() {
- unpack ${A}
-
- use x86 && \
- ln -s $(which nasm) "${T}/${CHOST}-nasm"
- use sdl && \
- ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
- use truetype && \
- ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
-}
-
-src_compile() {
- PATH="${PATH}:${T}"
- egamesconf \
- $(use_enable debug) \
- $(use_enable truetype freetype) \
- $(use_enable static) \
- $(use_enable x86 asm) \
- $(use_enable svga svgalib) \
- $(use_enable fbcon fb) \
- $(use_enable alsa) \
- $(use_enable oss) \
- $(use_enable slang) \
- $(use_enable sdl) \
- --with-emu=${PN/advance} \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- local m
-
- dogamesbin adv* || die "dogamesbin failed"
-
- keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
- insinto "${GAMES_DATADIR}/advance"
- doins support/event.dat
-
- dodoc HISTORY README RELEASE
- cd obj/doc
- dodoc *.txt
- dohtml *.html
- for m in *.1 ; do
- newman ${m} ${m/1/6}
- done
-
- prepgamesdirs
-}
diff --git a/games-emulation/advancemame/advancemame-0.85.0.ebuild b/games-emulation/advancemame/advancemame-0.85.0.ebuild
index 9a8ecc17f197..3e9bbf93ce3d 100644
--- a/games-emulation/advancemame/advancemame-0.85.0.ebuild
+++ b/games-emulation/advancemame/advancemame-0.85.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.85.0.ebuild,v 1.1 2004/08/25 05:38:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.85.0.ebuild,v 1.2 2004/08/30 01:36:53 vapier Exp $
inherit eutils games
@@ -54,9 +54,13 @@ src_compile() {
}
src_install() {
- local m
+ local f
- dogamesbin adv* || die "dogamesbin failed"
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
insinto "${GAMES_DATADIR}/advance"
doins support/event.dat
@@ -66,8 +70,8 @@ src_install() {
cd obj/doc
dodoc *.txt
dohtml *.html
- for m in *.1 ; do
- newman ${m} ${m/1/6}
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
done
prepgamesdirs
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.81.0 b/games-emulation/advancemame/files/digest-advancemame-0.81.0
deleted file mode 100644
index b7c43b5063f4..000000000000
--- a/games-emulation/advancemame/files/digest-advancemame-0.81.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5615328533e4504b1e52c7bc21845c72 advancemame-0.81.0.tar.gz 11427892
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.82.0 b/games-emulation/advancemame/files/digest-advancemame-0.82.0
deleted file mode 100644
index bfab3dbf61d1..000000000000
--- a/games-emulation/advancemame/files/digest-advancemame-0.82.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a80eccc57d29ce1645e491746be3e87a advancemame-0.82.0.tar.gz 11600749
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.83.0 b/games-emulation/advancemame/files/digest-advancemame-0.83.0
deleted file mode 100644
index 9c45121f23d0..000000000000
--- a/games-emulation/advancemame/files/digest-advancemame-0.83.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c71eeff7ff1d913720645ff28b4aef21 advancemame-0.83.0.tar.gz 12685533
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.83.1 b/games-emulation/advancemame/files/digest-advancemame-0.83.1
deleted file mode 100644
index d98cf51f7258..000000000000
--- a/games-emulation/advancemame/files/digest-advancemame-0.83.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 432bed97c66569e29a10181b31f7b0ef advancemame-0.83.1.tar.gz 12526578