summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDevan Franchini <twitch153@gentoo.org>2015-05-02 16:50:01 +0000
committerDevan Franchini <twitch153@gentoo.org>2015-05-02 16:50:01 +0000
commitf815dc8ef4c28aa2f74e4588385f67fbf2d8dafa (patch)
tree1b0b87731e4067c26e83eedf7f751abef0a831f5 /games-emulation
parentVersion bump (diff)
downloadgentoo-2-f815dc8ef4c28aa2f74e4588385f67fbf2d8dafa.tar.gz
gentoo-2-f815dc8ef4c28aa2f74e4588385f67fbf2d8dafa.tar.bz2
gentoo-2-f815dc8ef4c28aa2f74e4588385f67fbf2d8dafa.zip
Adds patching to CMake build system for FindX11 if >=cmake-3.2, bug #548384
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A8C8FBCF)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/ChangeLog9
-rw-r--r--games-emulation/dolphin/dolphin-4.0-r2.ebuild (renamed from games-emulation/dolphin/dolphin-4.0-r1.ebuild)12
-rw-r--r--games-emulation/dolphin/dolphin-4.0.2-r7.ebuild (renamed from games-emulation/dolphin/dolphin-4.0.2-r6.ebuild)12
3 files changed, 30 insertions, 3 deletions
diff --git a/games-emulation/dolphin/ChangeLog b/games-emulation/dolphin/ChangeLog
index f1a4780c4718..c3b9f3448ac4 100644
--- a/games-emulation/dolphin/ChangeLog
+++ b/games-emulation/dolphin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-emulation/dolphin
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/ChangeLog,v 1.36 2015/05/02 16:43:42 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/ChangeLog,v 1.37 2015/05/02 16:50:01 twitch153 Exp $
+
+*dolphin-4.0-r2 (02 May 2015)
+*dolphin-4.0.2-r7 (02 May 2015)
+
+ 02 May 2015; Devan Franchini <twitch153@gentoo.org> +dolphin-4.0-r2.ebuild,
+ +dolphin-4.0.2-r7.ebuild, -dolphin-4.0-r1.ebuild, -dolphin-4.0.2-r6.ebuild:
+ Adds patching to CMake build system for FindX11 if >=cmake-3.2, bug #548384
02 May 2015; Devan Franchini <twitch153@gentoo.org> -dolphin-3.5-r1.ebuild:
Removes dolphin-3.5-r1 from tree
diff --git a/games-emulation/dolphin/dolphin-4.0-r1.ebuild b/games-emulation/dolphin/dolphin-4.0-r2.ebuild
index 92df7c72d37c..9b1f9bf35a4f 100644
--- a/games-emulation/dolphin/dolphin-4.0-r1.ebuild
+++ b/games-emulation/dolphin/dolphin-4.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-4.0-r1.ebuild,v 1.2 2015/04/18 12:47:01 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-4.0-r2.ebuild,v 1.1 2015/05/02 16:50:01 twitch153 Exp $
EAPI=5
@@ -96,6 +96,16 @@ src_prepare() {
mv CLRun Externals || die
mv Bochs_disasm Externals || die
mv SOIL Externals || die
+
+ # Add call for FindX11 as FindOpenGL does not include it implicitly
+ # anymore for >=cmake-3.2. For more info, see:
+ # https://public.kitware.com/Bug/print_bug_page.php?bug_id=15268
+ if has_version ">=dev-util/cmake-3.2"; then
+ sed -i -e '/if(NOT ANDROID)/a include(FindX11)' CMakeLists.txt || die
+
+ # Fix syntax warnings in FindMiniupnpc.cmake
+ sed -i -e 's/\"\"/\\\"\\\"/g' CMakeTests/FindMiniupnpc.cmake || die
+ fi
}
src_configure() {
diff --git a/games-emulation/dolphin/dolphin-4.0.2-r6.ebuild b/games-emulation/dolphin/dolphin-4.0.2-r7.ebuild
index 9ee333b36522..0def1068dfec 100644
--- a/games-emulation/dolphin/dolphin-4.0.2-r6.ebuild
+++ b/games-emulation/dolphin/dolphin-4.0.2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-4.0.2-r6.ebuild,v 1.1 2015/04/30 22:42:32 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-4.0.2-r7.ebuild,v 1.1 2015/05/02 16:50:01 twitch153 Exp $
EAPI=5
@@ -97,6 +97,16 @@ src_prepare() {
mv CLRun Externals || die
mv Bochs_disasm Externals || die
mv SOIL Externals || die
+
+ # Add call for FindX11 as FindOpenGL does not include it implicitly
+ # anymore for >=cmake-3.2. For more info, see:
+ # https://public.kitware.com/Bug/print_bug_page.php?bug_id=15268
+ if has_version ">=dev-util/cmake-3.2"; then
+ sed -i -e '/if(NOT ANDROID)/a include(FindX11)' CMakeLists.txt || die
+
+ # Fix syntax warnings in FindMiniupnpc.cmake
+ sed -i -e 's/\"\"/\\\"\\\"/g' CMakeTests/FindMiniupnpc.cmake || die
+ fi
}
src_configure() {