summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-05 06:21:55 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-05 06:21:55 +0000
commit16f79376f251ca8a1c53180f418138976de2a83b (patch)
tree3c9043e171521977ad1f0cc4dceab64e818a626f /games-engines
parentPreview version of cups-1.2, masked for now (diff)
downloadgentoo-2-16f79376f251ca8a1c53180f418138976de2a83b.tar.gz
gentoo-2-16f79376f251ca8a1c53180f418138976de2a83b.tar.bz2
gentoo-2-16f79376f251ca8a1c53180f418138976de2a83b.zip
Fix for gcc-4.1
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/exult/ChangeLog8
-rw-r--r--games-engines/exult/exult-1.2.ebuild7
-rw-r--r--games-engines/exult/files/digest-exult-1.28
-rw-r--r--games-engines/exult/files/exult-1.2-gcc41.patch42
4 files changed, 59 insertions, 6 deletions
diff --git a/games-engines/exult/ChangeLog b/games-engines/exult/ChangeLog
index 56186f46061a..2496254b996d 100644
--- a/games-engines/exult/ChangeLog
+++ b/games-engines/exult/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-engines/exult
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/ChangeLog,v 1.13 2005/10/07 03:49:18 mr_bones_ Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/ChangeLog,v 1.14 2006/05/05 06:21:55 tupone Exp $
+
+ 05 May 2006; <Tupone@gentoo.org> +files/exult-1.2-gcc41.patch,
+ exult-1.2.ebuild:
+ Fix for gcc-4.1
06 Oct 2005; Michael Sterrett <mr_bones_@gentoo.org> exult-1.2.ebuild:
expand filename before passing to unpack (bug #107532); tidy
diff --git a/games-engines/exult/exult-1.2.ebuild b/games-engines/exult/exult-1.2.ebuild
index 7c3a83cb651a..4b8b25741970 100644
--- a/games-engines/exult/exult-1.2.ebuild
+++ b/games-engines/exult/exult-1.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/exult-1.2.ebuild,v 1.5 2005/10/07 03:49:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/exult-1.2.ebuild,v 1.6 2006/05/05 06:21:55 tupone Exp $
-inherit games
+inherit eutils games
DESCRIPTION="an Ultima 7 game engine that runs on modern operating systems"
HOMEPAGE="http://exult.sourceforge.net/"
@@ -35,6 +35,7 @@ src_unpack() {
cd music/
unpack U7MusicOGG_{1,2}of2.zip
cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc41.patch
sed -i \
-e "s/u7siinstrics.data/u7siintrinsics.data/" \
usecode/ucxt/data/Makefile.in \
diff --git a/games-engines/exult/files/digest-exult-1.2 b/games-engines/exult/files/digest-exult-1.2
index 2a7b44e22def..d1994a018e4c 100644
--- a/games-engines/exult/files/digest-exult-1.2
+++ b/games-engines/exult/files/digest-exult-1.2
@@ -1,3 +1,9 @@
-MD5 0fc88dee74a91724d25373ba0a8670ba exult-1.2.tar.gz 1722259
MD5 7746d1a9164fd67509107797496553bf U7MusicOGG_1of2.zip 12614413
+RMD160 2818c026664f6c8ef79201ea34a507091340fbb8 U7MusicOGG_1of2.zip 12614413
+SHA256 ccf748b346345986b08355ae3bf21c72e3bfffe30ecf9f70fe10fdc8c573a503 U7MusicOGG_1of2.zip 12614413
MD5 cdae5956d7c52f35e90317913a660123 U7MusicOGG_2of2.zip 11382878
+RMD160 830a718674e1a2acf79ef131d30929c55fb91b44 U7MusicOGG_2of2.zip 11382878
+SHA256 58627a090f3f75cc4f5731053d5a2b02c6ba0edff1db0551bcd565d04089baaa U7MusicOGG_2of2.zip 11382878
+MD5 0fc88dee74a91724d25373ba0a8670ba exult-1.2.tar.gz 1722259
+RMD160 339231edf84507f05115ab3189875cb15be9c04f exult-1.2.tar.gz 1722259
+SHA256 a6dd9d4e399281ed2db691ede21dbb79818ee11b08ef717e3eac255e290cf21a exult-1.2.tar.gz 1722259
diff --git a/games-engines/exult/files/exult-1.2-gcc41.patch b/games-engines/exult/files/exult-1.2-gcc41.patch
new file mode 100644
index 000000000000..045fd83405d5
--- /dev/null
+++ b/games-engines/exult/files/exult-1.2-gcc41.patch
@@ -0,0 +1,42 @@
+--- hash_utils.h.old 2006-05-04 20:47:24.000000000 +0200
++++ hash_utils.h 2006-05-04 20:58:58.000000000 +0200
+@@ -26,7 +26,7 @@
+ #else
+ #if HAVE_EXT_HASH_MAP
+ # include <ext/hash_map>
+-# if (defined(__GNUC__) && (__GNUC__ == 3) && ( __GNUC_MINOR__ > 0))
++# if defined(__GNUC__) && (((__GNUC__ == 3) && ( __GNUC_MINOR__ > 0)) || __GNUC__ >= 4)
+ using __gnu_cxx::hash_map;
+ # else
+ using std::hash_map;
+@@ -44,7 +44,7 @@
+ #else
+ #if HAVE_EXT_HASH_SET
+ # include <ext/hash_set>
+-# if (defined(__GNUC__) && (__GNUC__ == 3) && ( __GNUC_MINOR__ > 0))
++# if defined(__GNUC__) && (((__GNUC__ == 3) && ( __GNUC_MINOR__ > 0)) || __GNUC__ >= 4)
+ using __gnu_cxx::hash_set;
+ # else
+ using std::hash_set;
+--- mouse.h.old 2006-05-04 21:02:49.000000000 +0200
++++ mouse.h 2006-05-04 21:03:37.000000000 +0200
+@@ -27,6 +27,8 @@
+ #include "vgafile.h"
+ #include "glshape.h"
+
++class Game_window;
++
+ /*
+ * Handle custom mouse pointers.
+ */
+--- audio/midi_drivers/fmopldrv.h.old 2006-05-04 21:05:16.000000000 +0200
++++ audio/midi_drivers/fmopldrv.h 2006-05-04 21:05:29.000000000 +0200
+@@ -76,7 +76,7 @@
+ /* output a packed midi command to the midi stream
+ * valid only if mode is MO_SIMPLE
+ */
+- void OplDriver::send(uint32 b);
++ void send(uint32 b);
+
+ /* retrieve a string representation of an error code */
+ static const char *get_error_name(int error_code);