summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-09-01 19:01:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-09-01 19:01:12 +0000
commit40fb88b20f46e188cf3873a5394b29b93d5215d4 (patch)
tree7a2fa58156c4aa334be3d3160c22b5ee389be2c8 /games-engines
parentAdd new useflags and some style improvements to live ebuild, thanks to Daniel... (diff)
downloadgentoo-2-40fb88b20f46e188cf3873a5394b29b93d5215d4.tar.gz
gentoo-2-40fb88b20f46e188cf3873a5394b29b93d5215d4.tar.bz2
gentoo-2-40fb88b20f46e188cf3873a5394b29b93d5215d4.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm-tools/ChangeLog8
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-0.12.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/games-engines/scummvm-tools/ChangeLog b/games-engines/scummvm-tools/ChangeLog
index 918bfde23539..7f9a0edbd99f 100644
--- a/games-engines/scummvm-tools/ChangeLog
+++ b/games-engines/scummvm-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm-tools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.16 2008/06/14 18:46:16 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.17 2008/09/01 19:01:12 mr_bones_ Exp $
+
+*scummvm-tools-0.12.0 (01 Sep 2008)
+
+ 01 Sep 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +scummvm-tools-0.12.0.ebuild:
+ version bump
14 Jun 2008; Santiago M. Mola <coldwind@gentoo.org>
scummvm-tools-0.11.0.ebuild:
diff --git a/games-engines/scummvm-tools/scummvm-tools-0.12.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-0.12.0.ebuild
new file mode 100644
index 000000000000..c49e57051dc0
--- /dev/null
+++ b/games-engines/scummvm-tools/scummvm-tools-0.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/scummvm-tools-0.12.0.ebuild,v 1.1 2008/09/01 19:01:12 mr_bones_ Exp $
+
+inherit toolchain-funcs games
+
+DESCRIPTION="utilities for the SCUMM game engine"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libpng
+ x11-libs/wxGTK"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f *.bat
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS} -DUNIX" \
+ || die "emake failed"
+}
+
+src_install() {
+ local f
+ for f in $(find . -type f -perm +1 -print); do
+ newgamesbin $f ${PN}-${f##*/} || die "newgamesbin $f failed"
+ done
+ dodoc README
+ prepgamesdirs
+}