summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-09 08:20:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-09 08:20:15 +0000
commit49b3ede3c0f21401faeaee0e5d10bfaad3484189 (patch)
tree90a6e90dc06fcba1c326f3e116c0858a21e7f0e1 /games-engines
parent old version cleanout. Dependancy change as per bug #57193. Permission from f... (diff)
downloadgentoo-2-49b3ede3c0f21401faeaee0e5d10bfaad3484189.tar.gz
gentoo-2-49b3ede3c0f21401faeaee0e5d10bfaad3484189.tar.bz2
gentoo-2-49b3ede3c0f21401faeaee0e5d10bfaad3484189.zip
bug-fixed version bump
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog7
-rw-r--r--games-engines/scummvm/Manifest2
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.6.1b1
-rw-r--r--games-engines/scummvm/scummvm-0.6.1b.ebuild56
4 files changed, 65 insertions, 1 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 767a22adf044..ba195e92e170 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/scummvm
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.11 2004/07/29 08:20:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.12 2004/08/09 08:20:15 mr_bones_ Exp $
+
+*scummvm-0.6.1b (09 Aug 2004)
+
+ 09 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> +scummvm-0.6.1b.ebuild:
+ bug-fixed version bump
*scummvm-0.6.1 (29 Jul 2004)
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index ca76927ffdf8..f1c81b3b4421 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -3,8 +3,10 @@ MD5 5234b28a69ecec6de215054a3ad810f6 scummvm-0.5.1.ebuild 1432
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 ef4e301449a6e1ddc55e6ccd6d693d0d scummvm-0.6.1.ebuild 1422
MD5 9be8bc622b0d1df5f4deb49c936e463b scummvm-0.6.0.ebuild 1492
+MD5 98b2a64bd3b61ed94a9d55a7d401ced8 scummvm-0.6.1b.ebuild 1418
MD5 ece3781510db9d2d60fcabd88eb576a8 files/0.5.1-alsa.patch 777
MD5 a05cefcb4e86dbf7d1c4592029bf7195 files/digest-scummvm-0.5.1 67
MD5 11d226ec4661788cb3461a72f253cd63 files/digest-scummvm-0.6.0 67
MD5 376253699b8cb172b6b0ebd5b1761754 files/0.6.0-gcc34.patch 1435
MD5 ba65f67b7aa6caf2de3218ad27234007 files/digest-scummvm-0.6.1 71
+MD5 5d563fb08477f6c67b3254b545554b7c files/digest-scummvm-0.6.1b 68
diff --git a/games-engines/scummvm/files/digest-scummvm-0.6.1b b/games-engines/scummvm/files/digest-scummvm-0.6.1b
new file mode 100644
index 000000000000..bf91203d2931
--- /dev/null
+++ b/games-engines/scummvm/files/digest-scummvm-0.6.1b
@@ -0,0 +1 @@
+MD5 143dd7cfe0995922c49e1f8a6cdf2055 scummvm-0.6.1b.tar.bz2 1626950
diff --git a/games-engines/scummvm/scummvm-0.6.1b.ebuild b/games-engines/scummvm/scummvm-0.6.1b.ebuild
new file mode 100644
index 000000000000..58dde5ff391f
--- /dev/null
+++ b/games-engines/scummvm/scummvm-0.6.1b.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.6.1b.ebuild,v 1.1 2004/08/09 08:20:15 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc amd64 ~sparc"
+IUSE="alsa debug mad oggvorbis sdl zlib"
+
+DEPEND="virtual/libc
+ virtual/x11
+ >media-libs/libmpeg2-0.3.1
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ oggvorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ mad? ( media-libs/libmad )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf=
+
+ use sdl \
+ && myconf="${myconf} --backend=sdl" \
+ || myconf="${myconf} --backend=x11"
+ use debug \
+ || myconf="${myconf} --disable-debug"
+
+ # not an autoconf script so dont call econf
+ ./configure \
+ $(use_enable alsa) \
+ $(use_enable mad) \
+ $(use_enable oggvorbis vorbis) \
+ $(use_enable zlib) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin scummvm || die "dobin failed"
+ doman scummvm.6
+ dodoc NEWS README TODO
+ insinto /usr/share/pixmaps
+ doins scummvm.xpm || die "doins failed"
+ make_desktop_entry scummvm ScummVM
+ prepgamesdirs
+}