summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-06 06:42:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-06 06:42:22 +0000
commit404b9799bb61e3f1051208f7416b1875d27e80e0 (patch)
tree91628e74813d76ad0ca8927035b28e9f25c65b94 /games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
parentSDL + cflags + path fixes #26147 (diff)
downloadgentoo-2-404b9799bb61e3f1051208f7416b1875d27e80e0.tar.gz
gentoo-2-404b9799bb61e3f1051208f7416b1875d27e80e0.tar.bz2
gentoo-2-404b9799bb61e3f1051208f7416b1875d27e80e0.zip
SDL + cflags + path fixes #26147
Diffstat (limited to 'games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild')
-rw-r--r--games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild b/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
new file mode 100644
index 000000000000..fb4cbb80daf0
--- /dev/null
+++ b/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild,v 1.1 2003/10/06 06:41:57 vapier Exp $
+
+inherit games gcc eutils
+
+DESCRIPTION="play Quake in 3D with red - blue glasses"
+HOMEPAGE="http://home.iprimus.com.au/crbean/"
+SRC_URI="http://home.iprimus.com.au/crbean/zip/3dGLQuake_SRC_${PV}.zip
+ mirror://gentoo/${P}-SDL.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11
+ virtual/opengl"
+
+S=${WORKDIR}/WinQuake
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ mv GLQUAKE.H glquake.h
+ mv GL_DRAW.C gl_draw.c
+ mv GL_RMAIN.C gl_rmain.c
+ epatch ${FILESDIR}/stupid-dosformat.patch
+ mv Makefile{.linuxi386,}
+ epatch ${FILESDIR}/makefile-path-fixes.patch
+ epatch ${FILESDIR}/fix-sys_printf.patch
+ epatch ${FILESDIR}/makefile-cflags.patch
+ epatch ${FILESDIR}/gentoo-paths.patch
+ epatch ${WORKDIR}/${P}-SDL.patch
+}
+
+src_compile() {
+ make \
+ OPTFLAGS="${CFLAGS}" \
+ GENTOO_DATADIR=${GAMES_DATADIR}/quake-data \
+ build_release \
+ || die "failed to build WinQuake"
+}
+
+src_install() {
+ newgamesbin release*/bin/glquake.sdl anaglyph-stereo-quake
+ dodoc ${WORKDIR}/readme.id.txt
+ dohtml ${WORKDIR}/3dquake.html
+ prepgamesdirs
+}