summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-12-21 16:04:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-12-21 16:04:56 +0000
commit18e1d86000f5443690494d78beec92edccb1f384 (patch)
tree8279b23178d8e9682e2ab6e2478634978c89fd86 /games-fps/prboom
parentFixed description of servletapi 2.3 per bug #158722 (diff)
downloadgentoo-2-18e1d86000f5443690494d78beec92edccb1f384.tar.gz
gentoo-2-18e1d86000f5443690494d78beec92edccb1f384.tar.bz2
gentoo-2-18e1d86000f5443690494d78beec92edccb1f384.zip
version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-fps/prboom')
-rw-r--r--games-fps/prboom/ChangeLog9
-rw-r--r--games-fps/prboom/files/2.4.7-nvidia-test.c3
-rw-r--r--games-fps/prboom/files/2.4.7-nvidia.patch48
-rw-r--r--games-fps/prboom/files/digest-prboom-2.4.73
-rw-r--r--games-fps/prboom/prboom-2.4.7.ebuild66
5 files changed, 128 insertions, 1 deletions
diff --git a/games-fps/prboom/ChangeLog b/games-fps/prboom/ChangeLog
index 8f0c121cbe10..a15b61f62fb8 100644
--- a/games-fps/prboom/ChangeLog
+++ b/games-fps/prboom/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-fps/prboom
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/prboom/ChangeLog,v 1.23 2006/10/19 03:13:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/prboom/ChangeLog,v 1.24 2006/12/21 16:04:56 mr_bones_ Exp $
+
+*prboom-2.4.7 (21 Dec 2006)
+
+ 21 Dec 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/2.4.7-nvidia.patch, +files/2.4.7-nvidia-test.c,
+ +prboom-2.4.7.ebuild:
+ version bump
*prboom-2.4.6 (19 Oct 2006)
diff --git a/games-fps/prboom/files/2.4.7-nvidia-test.c b/games-fps/prboom/files/2.4.7-nvidia-test.c
new file mode 100644
index 000000000000..f9e4bd700f8a
--- /dev/null
+++ b/games-fps/prboom/files/2.4.7-nvidia-test.c
@@ -0,0 +1,3 @@
+#include <SDL/SDL_opengl.h>
+PFNGLCOLORTABLEEXTPROC glColorTableEXT;
+int main(){return 0;}
diff --git a/games-fps/prboom/files/2.4.7-nvidia.patch b/games-fps/prboom/files/2.4.7-nvidia.patch
new file mode 100644
index 000000000000..2b7aa9b32d46
--- /dev/null
+++ b/games-fps/prboom/files/2.4.7-nvidia.patch
@@ -0,0 +1,48 @@
+--- src/gl_intern.h.orig 2003-09-21 16:39:30.247451624 -0400
++++ src/gl_intern.h 2003-09-21 16:39:41.610724144 -0400
+@@ -84,6 +84,6 @@
+ #define min(a,b) ((a)<(b)?(a):(b))
+ #endif
+
+-PFNGLCOLORTABLEEXTPROC gld_ColorTableEXT;
++//PFNGLCOLORTABLEEXTPROC gld_ColorTableEXT;
+
+ #endif // _GL_INTERN_H
+--- src/gl_main.c.orig 2003-09-21 16:39:55.436622288 -0400
++++ src/gl_main.c 2003-09-21 16:43:00.943420968 -0400
+@@ -285,6 +285,7 @@
+
+ if (strcasecmp(extension, "GL_EXT_texture_filter_anisotropic") == 0)
+ gl_texture_filter_anisotropic = true;
++/*
+ else if (strcasecmp(extension, "GL_EXT_paletted_texture") == 0) {
+ if (gl_use_paletted_texture) {
+ gl_paletted_texture = true;
+@@ -304,6 +305,7 @@
+ else
+ lprintf(LO_INFO,"using GL_EXT_shared_texture_palette\n",glGetString(GL_VENDOR));
+ }
++*/
+
+ extension = p;
+ } while (*extension != '\0');
+@@ -761,7 +763,7 @@
+ pal[transparent_pal_index*4+1]=0;
+ pal[transparent_pal_index*4+2]=0;
+ pal[transparent_pal_index*4+3]=0;
+- gld_ColorTableEXT(GL_SHARED_TEXTURE_PALETTE_EXT, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
++// gld_ColorTableEXT(GL_SHARED_TEXTURE_PALETTE_EXT, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
+ W_UnlockLumpName("PLAYPAL");
+ } else {
+ if (palette>0)
+--- src/gl_texture.c.orig 2003-09-21 16:43:18.450759448 -0400
++++ src/gl_texture.c 2003-09-21 16:43:39.549551944 -0400
+@@ -178,7 +178,7 @@
+ pal[transparent_pal_index*4+1]=0;
+ pal[transparent_pal_index*4+2]=0;
+ pal[transparent_pal_index*4+3]=0;
+- gld_ColorTableEXT(target, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
++// gld_ColorTableEXT(target, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
+ W_UnlockLumpName("PLAYPAL");
+ }
+
diff --git a/games-fps/prboom/files/digest-prboom-2.4.7 b/games-fps/prboom/files/digest-prboom-2.4.7
new file mode 100644
index 000000000000..87c3aa83a94f
--- /dev/null
+++ b/games-fps/prboom/files/digest-prboom-2.4.7
@@ -0,0 +1,3 @@
+MD5 9942f521764d7f89df2218a456da4f02 prboom-2.4.7.tar.gz 999524
+RMD160 78c8548954dd95469f8099bc8fa697f62a69c17e prboom-2.4.7.tar.gz 999524
+SHA256 de22dbaacd25a0f0b16c507aa2326a90b7f5dcfcf862c3dc7076996c6187cd2f prboom-2.4.7.tar.gz 999524
diff --git a/games-fps/prboom/prboom-2.4.7.ebuild b/games-fps/prboom/prboom-2.4.7.ebuild
new file mode 100644
index 000000000000..bdcd34dfdb0e
--- /dev/null
+++ b/games-fps/prboom/prboom-2.4.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/prboom/prboom-2.4.7.ebuild,v 1.1 2006/12/21 16:04:56 mr_bones_ Exp $
+
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="Port of ID's doom to SDL and OpenGL"
+HOMEPAGE="http://prboom.sourceforge.net/"
+SRC_URI="mirror://sourceforge/prboom/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE="opengl"
+
+DEPEND=">=media-libs/libsdl-1.1.3
+ media-libs/sdl-mixer
+ media-libs/sdl-net
+ opengl? ( virtual/opengl virtual/glu )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ebegin "Detecting NVidia GL/prboom bug"
+ $(tc-getCC) "${FILESDIR}"/${PV}-nvidia-test.c 2> /dev/null
+ local ret=$?
+ eend ${ret} "NVidia GL/prboom bug found ;("
+ [ ${ret} -eq 0 ] || epatch "${FILESDIR}"/${PV}-nvidia.patch
+ sed -i \
+ -e '/^gamesdir/ s/\/games/\/bin/' \
+ src/Makefile.in \
+ || die "sed failed"
+ sed -i \
+ -e 's/: install-docDATA/:/' \
+ -e '/^SUBDIRS/ s/doc//' \
+ Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ local myconf
+ # configure.in should be fixed as
+ # --enable-gl and
+ # --disable-gl are treated the same
+ use opengl && myconf="--enable-gl"
+ # leave --disable-cpu-opt in otherwise the configure script
+ # will append -march=i686 and crap ... let the user's CFLAGS
+ # handle this ...
+ egamesconf \
+ --disable-dependency-tracking \
+ ${myconf} \
+ $(use_enable x86 i386-asm) \
+ --disable-cpu-opt \
+ --with-waddir="${GAMES_DATADIR}/doom-data" \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doman doc/*.{5,6}
+ dodoc AUTHORS NEWS README TODO doc/README.* doc/*.txt
+ doicon "${FILESDIR}/${PN}.png"
+ make_desktop_entry ${PN} "PrBoom"
+ prepgamesdirs
+}