summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-07-11 14:04:00 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-07-11 14:04:00 +0000
commitec8f9ebd0c41bf1fd9aa1001f440f75a8fbc36d2 (patch)
tree1f16be33efc15264c7dfdf14eb890a32d073edaf /games-fps/soldieroffortune
parentfixed cross-compile build system error, bug 516894 (diff)
downloadgentoo-2-ec8f9ebd0c41bf1fd9aa1001f440f75a8fbc36d2.tar.gz
gentoo-2-ec8f9ebd0c41bf1fd9aa1001f440f75a8fbc36d2.tar.bz2
gentoo-2-ec8f9ebd0c41bf1fd9aa1001f440f75a8fbc36d2.zip
Bumped EAPI to 5, adjusted deps for gx86-multilib; synchronized changes here with those made on soldieroffortune-demo as the original ebuilds matched -- however, this ebuild needs the CD for eveyrthing so there is no way for me to confirm accuracy of changes
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'games-fps/soldieroffortune')
-rw-r--r--games-fps/soldieroffortune/ChangeLog13
-rw-r--r--games-fps/soldieroffortune/soldieroffortune-1.06a-r1.ebuild90
2 files changed, 101 insertions, 2 deletions
diff --git a/games-fps/soldieroffortune/ChangeLog b/games-fps/soldieroffortune/ChangeLog
index 56dd0f98c01c..def895247bb5 100644
--- a/games-fps/soldieroffortune/ChangeLog
+++ b/games-fps/soldieroffortune/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for games-fps/soldieroffortune
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/soldieroffortune/ChangeLog,v 1.29 2012/09/19 15:16:06 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/soldieroffortune/ChangeLog,v 1.30 2014/07/11 14:04:00 axs Exp $
+
+*soldieroffortune-1.06a-r1 (11 Jul 2014)
+
+ 11 Jul 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +soldieroffortune-1.06a-r1.ebuild:
+ Bumped EAPI to 5, adjusted deps for gx86-multilib; synchronized changes here
+ with those made on soldieroffortune-demo as the original ebuilds matched --
+ however, this ebuild needs the CD for eveyrthing so there is no way for me to
+ confirm accuracy of changes
19 Sep 2012; Michael Sterrett <mr_bones_@gentoo.org>
soldieroffortune-1.06a.ebuild:
diff --git a/games-fps/soldieroffortune/soldieroffortune-1.06a-r1.ebuild b/games-fps/soldieroffortune/soldieroffortune-1.06a-r1.ebuild
new file mode 100644
index 000000000000..9efe47aabc94
--- /dev/null
+++ b/games-fps/soldieroffortune/soldieroffortune-1.06a-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/soldieroffortune/soldieroffortune-1.06a-r1.ebuild,v 1.1 2014/07/11 14:04:00 axs Exp $
+
+EAPI=5
+inherit eutils unpacker cdrom games
+
+DESCRIPTION="First-person shooter based on the mercenary trade"
+HOMEPAGE="http://www.lokigames.com/products/sof/"
+SRC_URI="mirror://lokigames/sof/sof-${PV}-cdrom-x86.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+IUSE=""
+
+DEPEND="games-util/loki_patch"
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ || (
+ (
+ virtual/opengl[abi_x86_32(-)]
+ media-libs/libsdl[X,opengl,sound,abi_x86_32(-)]
+ x11-libs/libXrender[abi_x86_32(-)]
+ x11-libs/libXrandr[abi_x86_32(-)]
+ media-libs/smpeg[abi_x86_32(-)]
+ )
+ (
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ )
+ )"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${ED}/${dir}
+
+pkg_pretend() {
+ ewarn "The installed game takes about 725MB of space!"
+}
+
+src_unpack() {
+ cdrom_get_cds sof.xpm
+ unpack_makeself
+ tar xzf "${CDROM_ROOT}"/paks.tar.gz -C "${T}" \
+ || die "uncompressing data"
+ tar xzf "${CDROM_ROOT}"/binaries.tar.gz -C "${T}" \
+ || die "uncompressing binaries"
+}
+
+src_install() {
+ einfo "Copying files... this may take a while..."
+ exeinto "${dir}"
+ doexe "${CDROM_ROOT}"/bin/x86/glibc-2.1/sof
+ insinto "${dir}"
+ doins -r "${T}"/*
+ doins "${CDROM_ROOT}"/{README,kver.pub,sof.xpm}
+
+ cd "${S}"
+ export _POSIX2_VERSION=199209
+ loki_patch --verify patch.dat
+ loki_patch patch.dat "${Ddir}" >& /dev/null || die "patching"
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find "${Ddir}" -exec touch '{}' \;
+
+ games_make_wrapper sof ./sof "${dir}" "${dir}"
+
+ # fix buffer overflow
+ sed -i -e 's/^exec/i \
+export MESA_EXTENSION_MAX_YEAR=2003 \
+export __GL_ExtensionStringVersion=17700' \
+ "${ED}/${GAMES_BINDIR}/sof" || die
+
+ doicon "${CDROM_ROOT}"/sof.xpm
+ make_desktop_entry sof "Soldier of Fortune" sof
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To play the game run:"
+ elog " sof"
+}