summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-11-18 01:04:09 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-11-18 01:04:09 +0000
commit94a26b3c2e72e5c47ad15ca8b525799205c33137 (patch)
tree0ba4393f9d860c554095cd3ff422495d9ec72f53 /games-fps
parentBump binary to 0.5.1.1 (diff)
downloadgentoo-2-94a26b3c2e72e5c47ad15ca8b525799205c33137.tar.gz
gentoo-2-94a26b3c2e72e5c47ad15ca8b525799205c33137.tar.bz2
gentoo-2-94a26b3c2e72e5c47ad15ca8b525799205c33137.zip
version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/urbanterror/ChangeLog8
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.2.007-build.patch70
-rw-r--r--games-fps/urbanterror/urbanterror-4.2.007.ebuild131
3 files changed, 208 insertions, 1 deletions
diff --git a/games-fps/urbanterror/ChangeLog b/games-fps/urbanterror/ChangeLog
index aaa4cffce78e..a102df69b204 100644
--- a/games-fps/urbanterror/ChangeLog
+++ b/games-fps/urbanterror/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/urbanterror
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/ChangeLog,v 1.13 2012/11/10 12:05:30 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/ChangeLog,v 1.14 2012/11/18 01:04:08 hasufell Exp $
+
+*urbanterror-4.2.007 (18 Nov 2012)
+
+ 18 Nov 2012; Julian Ospald <hasufell@gentoo.org> +urbanterror-4.2.007.ebuild,
+ +files/urbanterror-4.2.007-build.patch:
+ version bump
*urbanterror-4.2.006 (10 Nov 2012)
diff --git a/games-fps/urbanterror/files/urbanterror-4.2.007-build.patch b/games-fps/urbanterror/files/urbanterror-4.2.007-build.patch
new file mode 100644
index 000000000000..9221b671cbed
--- /dev/null
+++ b/games-fps/urbanterror/files/urbanterror-4.2.007-build.patch
@@ -0,0 +1,70 @@
+--- Makefile
++++ Makefile
+@@ -213,7 +213,7 @@
+ endif
+ endif
+
+- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes -pipe
++ BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes
+
+ ifeq ($(USE_OPENAL),1)
+ BASE_CFLAGS += -DUSE_OPENAL=1
+@@ -239,19 +239,15 @@
+ BASE_CFLAGS += -I/usr/X11R6/include
+ endif
+
+- OPTIMIZE = -O3 -ffast-math -funroll-loops -fomit-frame-pointer
++ OPTIMIZE = -ffast-math -funroll-loops
+
+ ifeq ($(ARCH),x86_64)
+- OPTIMIZE = -O3 -fomit-frame-pointer -ffast-math -funroll-loops \
+- -falign-loops=2 -falign-jumps=2 -falign-functions=2 \
+- -fstrength-reduce
++ OPTIMIZE = -ffast-math -funroll-loops
+ # experimental x86_64 jit compiler! you need GNU as
+ HAVE_VM_COMPILED = true
+ else
+ ifeq ($(ARCH),i386)
+- OPTIMIZE = -O3 -march=i586 -fomit-frame-pointer -ffast-math \
+- -funroll-loops -falign-loops=2 -falign-jumps=2 \
+- -falign-functions=2 -fstrength-reduce
++ OPTIMIZE = -ffast-math -funroll-loops
+ HAVE_VM_COMPILED=true
+ else
+ ifeq ($(ARCH),ppc)
+@@ -265,7 +261,7 @@
+ BASE_CFLAGS += -DNO_VM_COMPILED
+ endif
+
+- DEBUG_CFLAGS = $(BASE_CFLAGS) -g -O0
++ DEBUG_CFLAGS = $(BASE_CFLAGS) $(OPTIMIZE)
+
+ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG $(OPTIMIZE)
+
+@@ -274,7 +270,7 @@
+ SHLIBLDFLAGS=-shared $(LDFLAGS)
+
+ THREAD_LDFLAGS=-lpthread
+- LDFLAGS=-ldl -lm
++ LDFLAGS+=-ldl -lm
+
+ ifeq ($(USE_SDL),1)
+ CLIENT_LDFLAGS=$(shell sdl-config --libs)
+@@ -1153,13 +1149,13 @@
+
+ $(B)/Quake3-UrT.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ) $(LIBSDLMAIN)
+ $(echo_cmd) "LD $@"
+- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) $(CLIENT_LDFLAGS) \
+- $(LDFLAGS) $(LIBSDLMAIN)
++ $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) \
++ $(LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
+
+ $(B)/Quake3-UrT-smp.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
+ $(echo_cmd) "LD $@"
+- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
+- $(THREAD_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
++ $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) \
++ $(LDFLAGS) $(THREAD_LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
+
+ ifneq ($(strip $(LIBSDLMAIN)),)
+ ifneq ($(strip $(LIBSDLMAINSRC)),)
diff --git a/games-fps/urbanterror/urbanterror-4.2.007.ebuild b/games-fps/urbanterror/urbanterror-4.2.007.ebuild
new file mode 100644
index 000000000000..296077f3a885
--- /dev/null
+++ b/games-fps/urbanterror/urbanterror-4.2.007.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/urbanterror-4.2.007.ebuild,v 1.1 2012/11/18 01:04:09 hasufell Exp $
+
+EAPI=4
+
+inherit check-reqs eutils gnome2-utils games
+
+DESCRIPTION="Hollywood tactical shooter based on the ioquake3 engine"
+HOMEPAGE="http://www.urbanterror.info/home/"
+SRC_URI="http://www.ftwgl.com/files/mirror/UrbanTerror42_full_${PV:4:3}.zip
+ https://github.com/Barbatos/ioq3-for-UrbanTerror-4/archive/release-4.2.006.tar.gz
+ http://upload.wikimedia.org/wikipedia/en/5/56/Urbanterror.svg -> ${PN}.svg"
+
+LICENSE="GPL-2 Q3AEULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+curl debug dedicated openal +sdl server smp vorbis"
+RESTRICT="mirror"
+
+RDEPEND="
+ !dedicated? (
+ virtual/opengl
+ curl? ( net-misc/curl )
+ openal? ( media-libs/openal )
+ sdl? ( media-libs/libsdl[X,audio,joystick,opengl,video] )
+ !sdl? ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm )
+ vorbis? ( media-libs/libogg
+ media-libs/libvorbis )
+ )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dedicated? ( curl? ( net-misc/curl ) )"
+
+S=${WORKDIR}/ioq3-for-UrbanTerror-4-release-4.2.006
+S_DATA=${WORKDIR}/UrbanTerror42
+
+CHECKREQS_DISK_BUILD="2700M"
+CHECKREQS_DISK_USR="1300M"
+
+pkg_pretend() {
+ check-reqs_pkg_pretend
+
+ if ! use dedicated ; then
+ if ! use sdl && ! use openal ; then
+ ewarn
+ ewarn "Sound support disabled. Enable 'sdl' or 'openal' useflag."
+ ewarn
+ fi
+ fi
+}
+
+src_unpack() {
+ # messed up zipball, let's hope they get it right next time
+ unpack release-4.2.006.tar.gz
+ mkdir "${S_DATA}" || die
+ cd "${S_DATA}" || die
+ unpack UrbanTerror42_full_${PV:4:3}.zip
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ buildit() { use $1 && echo 1 || echo 0 ; }
+ nobuildit() { use $1 && echo 0 || echo 1 ; }
+
+ emake \
+ ARCH=$(usex amd64 "x86_64" "i386") \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}/${PN}" \
+ BUILD_CLIENT=$(nobuildit dedicated) \
+ BUILD_CLIENT_SMP=$(usex smp "$(nobuildit dedicated)" "0") \
+ BUILD_SERVER=$(usex dedicated "1" "$(buildit server)") \
+ USE_SDL=$(buildit sdl) \
+ USE_OPENAL=$(buildit openal) \
+ USE_OPENAL_DLOPEN=0 \
+ USE_CURL=$(buildit curl) \
+ USE_CURL_DLOPEN=0 \
+ USE_CODEC_VORBIS=$(buildit vorbis) \
+ USE_LOCAL_HEADERS=0 \
+ Q="" \
+ $(usex debug "debug" "release")
+}
+
+src_install() {
+ local my_arch=$(usex amd64 "x86_64" "i386")
+
+ doicon -s scalable "${DISTDIR}"/${PN}.svg
+ dodoc ChangeLog README md4-readme.txt "${S_DATA}"/readme42.txt
+ insinto "${GAMES_DATADIR}"/${PN}/q3ut4
+ doins "${S_DATA}"/*.pk3
+
+ if use !dedicated ; then
+ newgamesbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT$(usex smp "-smp" "").${my_arch} ${PN}
+ make_desktop_entry ${PN} "UrbanTerror"
+ fi
+
+ if use dedicated || use server ; then
+ newgamesbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT-Ded.${my_arch} ${PN}-dedicated
+ docinto examples
+ dodoc "${S_DATA}"/{server.cfg,mapcycle.txt}
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+
+ if use openal && ! use dedicated ; then
+ einfo
+ elog "You might need to set:"
+ elog " seta s_useopenal \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg for openal to work."
+ einfo
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}