summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-03-12 08:01:05 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-03-12 08:01:05 +0000
commitab0d46edd8eb194681dac1d59ee6d1849e80f646 (patch)
tree625ee8c7dfc85f92871fbb35e8a8e5a51d348019 /games-fps
parentbackport FQDN patch from upstream (diff)
downloadgentoo-2-ab0d46edd8eb194681dac1d59ee6d1849e80f646.tar.gz
gentoo-2-ab0d46edd8eb194681dac1d59ee6d1849e80f646.tar.bz2
gentoo-2-ab0d46edd8eb194681dac1d59ee6d1849e80f646.zip
Fixing CFLAGS and LDFLAGS issues raised on bug #255453
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/openarena/ChangeLog7
-rw-r--r--games-fps/openarena/files/openarena-0.8.1-makefile.patch286
-rw-r--r--games-fps/openarena/files/openarena-0.8.1-unbundling.patch66
-rw-r--r--games-fps/openarena/openarena-0.8.1-r1.ebuild8
4 files changed, 291 insertions, 76 deletions
diff --git a/games-fps/openarena/ChangeLog b/games-fps/openarena/ChangeLog
index cda6afefd604..2b25e76d9f6c 100644
--- a/games-fps/openarena/ChangeLog
+++ b/games-fps/openarena/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/openarena
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/openarena/ChangeLog,v 1.13 2010/03/11 11:21:33 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/openarena/ChangeLog,v 1.14 2010/03/12 08:01:05 tupone Exp $
+
+ 12 Mar 2010; Tupone Alfredo <tupone@gentoo.org> openarena-0.8.1-r1.ebuild,
+ files/openarena-0.8.1-makefile.patch,
+ files/openarena-0.8.1-unbundling.patch:
+ Fixing CFLAGS and LDFLAGS issues raised on bug #255453 by Zeev Tarantov
11 Mar 2010; Tupone Alfredo <tupone@gentoo.org>
files/openarena-0.8.1-makefile.patch:
diff --git a/games-fps/openarena/files/openarena-0.8.1-makefile.patch b/games-fps/openarena/files/openarena-0.8.1-makefile.patch
index 9c49b9458a7d..12a7d6d26e1b 100644
--- a/games-fps/openarena/files/openarena-0.8.1-makefile.patch
+++ b/games-fps/openarena/files/openarena-0.8.1-makefile.patch
@@ -17,10 +17,47 @@
- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes \
- -pipe -DUSE_ICON $(shell sdl-config --cflags)
-+ BASE_CFLAGS = %CFLAGS% -DUSE_ICON $(shell sdl-config --cflags)
++ BASE_CFLAGS = -fno-strict-aliasing -DUSE_ICON $(shell sdl-config --cflags)
ifeq ($(USE_OPENAL),1)
BASE_CFLAGS += -DUSE_OPENAL
+@@ -283,29 +283,29 @@
+ SHLIBCFLAGS=-fPIC
+ SHLIBLDFLAGS=-shared $(LDFLAGS)
+
+- THREAD_LDFLAGS=-lpthread
+- LDFLAGS=-ldl -lm
++ THREAD_LIBS=-lpthread
++ LDLIBS=-ldl -lm -lz
+
+- CLIENT_LDFLAGS=$(shell sdl-config --libs) -lGL
++ CLIENT_LIBS=$(shell sdl-config --libs) -lGL -ljpeg
+
+ ifeq ($(USE_OPENAL),1)
+ ifneq ($(USE_OPENAL_DLOPEN),1)
+- CLIENT_LDFLAGS += -lopenal
++ CLIENT_LIBS += -lopenal
+ endif
+ endif
+
+ ifeq ($(USE_CURL),1)
+ ifneq ($(USE_CURL_DLOPEN),1)
+- CLIENT_LDFLAGS += -lcurl
++ CLIENT_LIBS += -lcurl
+ endif
+ endif
+
+ ifeq ($(USE_CODEC_VORBIS),1)
+- CLIENT_LDFLAGS += -lvorbisfile -lvorbis -logg
++ CLIENT_LIBS += -lvorbisfile -lvorbis -logg
+ endif
+
+ ifeq ($(USE_MUMBLE),1)
+- CLIENT_LDFLAGS += -lrt
++ CLIENT_LIBS += -lrt
+ endif
+
+ ifeq ($(USE_LOCAL_HEADERS),1)
@@ -323,7 +322,7 @@
endif
@@ -30,12 +67,255 @@
else # ifeq Linux
-@@ -821,7 +821,7 @@
+@@ -336,7 +336,7 @@
+
+ ifeq ($(PLATFORM),darwin)
+ HAVE_VM_COMPILED=true
+- CLIENT_LDFLAGS=
++ CLIENT_LIBS=
+ OPTIMIZE=
+
+ BASE_CFLAGS = -Wall -Wimplicit -Wstrict-prototypes
+@@ -357,7 +357,7 @@
+ ifeq ($(USE_OPENAL),1)
+ BASE_CFLAGS += -DUSE_OPENAL
+ ifneq ($(USE_OPENAL_DLOPEN),1)
+- CLIENT_LDFLAGS += -framework OpenAL
++ CLIENT_LIBS += -framework OpenAL
+ else
+ BASE_CFLAGS += -DUSE_OPENAL_DLOPEN
+ endif
+@@ -366,7 +366,7 @@
+ ifeq ($(USE_CURL),1)
+ BASE_CFLAGS += -DUSE_CURL
+ ifneq ($(USE_CURL_DLOPEN),1)
+- CLIENT_LDFLAGS += -lcurl
++ CLIENT_LIBS += -lcurl
+ else
+ BASE_CFLAGS += -DUSE_CURL_DLOPEN
+ endif
+@@ -374,7 +374,7 @@
+
+ ifeq ($(USE_CODEC_VORBIS),1)
+ BASE_CFLAGS += -DUSE_CODEC_VORBIS
+- CLIENT_LDFLAGS += -lvorbisfile -lvorbis -logg
++ CLIENT_LIBS += -lvorbisfile -lvorbis -logg
+ endif
+
+ BASE_CFLAGS += -D_THREAD_SAFE=1
+@@ -387,7 +387,7 @@
+ # the file has been modified by each build.
+ LIBSDLMAIN=$(B)/libSDLmain.a
+ LIBSDLMAINSRC=$(LIBSDIR)/macosx/libSDLmain.a
+- CLIENT_LDFLAGS += -framework Cocoa -framework IOKit -framework OpenGL \
++ CLIENT_LIBS += -framework Cocoa -framework IOKit -framework OpenGL \
+ $(LIBSDIR)/macosx/libSDL-1.2.0.dylib
+
+ OPTIMIZE += -ffast-math -falign-loops=16
+@@ -441,7 +441,7 @@
+ ifeq ($(USE_OPENAL_DLOPEN),1)
+ BASE_CFLAGS += -DUSE_OPENAL_DLOPEN
+ else
+- CLIENT_LDFLAGS += $(OPENAL_LDFLAGS)
++ CLIENT_LIBS += $(OPENAL_LDFLAGS)
+ endif
+ endif
+
+@@ -461,8 +461,8 @@
+
+ BINEXT=.exe
+
+- LDFLAGS= -lws2_32 -lwinmm
+- CLIENT_LDFLAGS = -mwindows -lgdi32 -lole32 -lopengl32
++ LDLIBS= -lws2_32 -lwinmm
++ CLIENT_LIBS = -mwindows -lgdi32 -lole32 -lopengl32
+
+ ifeq ($(USE_CURL),1)
+ BASE_CFLAGS += -DUSE_CURL
+@@ -470,9 +470,9 @@
+ ifneq ($(USE_CURL_DLOPEN),1)
+ ifeq ($(USE_LOCAL_HEADERS),1)
+ BASE_CFLAGS += -DCURL_STATICLIB
+- CLIENT_LDFLAGS += $(LIBSDIR)/win32/libcurl.a
++ CLIENT_LIBS += $(LIBSDIR)/win32/libcurl.a
+ else
+- CLIENT_LDFLAGS += $(CURL_LIBS)
++ CLIENT_LIBS += $(CURL_LIBS)
+ endif
+ endif
+ endif
+@@ -480,9 +480,9 @@
+ ifeq ($(USE_CODEC_VORBIS),1)
+ #Sago: Here I get vorbis to compile in Windows:
+ ifeq ($(PLATFORM),mingw32)
+- CLIENT_LDFLAGS += $(LIBSDIR)/win32/libvorbisfile.a $(LIBSDIR)/win32/libvorbis.a $(LIBSDIR)/win32/libogg.a
++ CLIENT_LIBS += $(LIBSDIR)/win32/libvorbisfile.a $(LIBSDIR)/win32/libvorbis.a $(LIBSDIR)/win32/libogg.a
+ else
+- CLIENT_LDFLAGS += -lvorbisfile -lvorbis -logg
++ CLIENT_LIBS += -lvorbisfile -lvorbis -logg
+ endif
+ endif
+
+@@ -496,14 +496,14 @@
+ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG $(OPTIMIZE)
+
+ # libmingw32 must be linked before libSDLmain
+- CLIENT_LDFLAGS += -lmingw32
++ CLIENT_LIBS += -lmingw32
+ ifeq ($(USE_LOCAL_HEADERS),1)
+ BASE_CFLAGS += -I$(SDLHDIR)/include
+- CLIENT_LDFLAGS += $(LIBSDIR)/win32/libSDLmain.a \
++ CLIENT_LIBS += $(LIBSDIR)/win32/libSDLmain.a \
+ $(LIBSDIR)/win32/libSDL.dll.a
+ else
+ BASE_CFLAGS += $(SDL_CFLAGS)
+- CLIENT_LDFLAGS += $(SDL_LIBS)
++ CLIENT_LIBS += $(SDL_LIBS)
+ endif
+
+
+@@ -561,22 +561,22 @@
+ SHLIBCFLAGS=-fPIC
+ SHLIBLDFLAGS=-shared $(LDFLAGS)
+
+- THREAD_LDFLAGS=-lpthread
++ THREAD_LIBS=-lpthread
+ # don't need -ldl (FreeBSD)
+- LDFLAGS=-lm
++ LDLIBS=-lm -lz
+
+- CLIENT_LDFLAGS =
++ CLIENT_LIBS =
+
+- CLIENT_LDFLAGS += $(shell sdl-config --libs) -lGL
++ CLIENT_LIBS += $(shell sdl-config --libs) -lGL
+
+ ifeq ($(USE_OPENAL),1)
+ ifneq ($(USE_OPENAL_DLOPEN),1)
+- CLIENT_LDFLAGS += $(THREAD_LDFLAGS) -lopenal
++ CLIENT_LIBS += $(THREAD_LIBS) -lopenal
+ endif
+ endif
+
+ ifeq ($(USE_CODEC_VORBIS),1)
+- CLIENT_LDFLAGS += -lvorbisfile -lvorbis -logg
++ CLIENT_LIBS += -lvorbisfile -lvorbis -logg
+ endif
+
+ else # ifeq freebsd
+@@ -618,21 +618,21 @@
+ SHLIBCFLAGS=-fPIC
+ SHLIBLDFLAGS=-shared $(LDFLAGS)
+
+- THREAD_LDFLAGS=-lpthread
+- LDFLAGS=-lm
++ THREAD_LIBS=-lpthread
++ LDLIBS=-lm -lz
+
+- CLIENT_LDFLAGS =
++ CLIENT_LIBS =
+
+- CLIENT_LDFLAGS += $(shell sdl-config --libs) -lGL
++ CLIENT_LIBS += $(shell sdl-config --libs) -lGL
+
+ ifeq ($(USE_OPENAL),1)
+ ifneq ($(USE_OPENAL_DLOPEN),1)
+- CLIENT_LDFLAGS += $(THREAD_LDFLAGS) -lossaudio -lopenal
++ CLIENT_LIBS += $(THREAD_LIBS) -lossaudio -lopenal
+ endif
+ endif
+
+ ifeq ($(USE_CODEC_VORBIS),1)
+- CLIENT_LDFLAGS += -lvorbisfile -lvorbis -logg
++ CLIENT_LIBS += -lvorbisfile -lvorbis -logg
+ endif
+
+ else # ifeq openbsd
+@@ -647,11 +647,11 @@
+ ARCH=i386
+ endif
+
+- LDFLAGS=-lm
++ LDLIBS=-lm -lz
+ SHLIBEXT=so
+ SHLIBCFLAGS=-fPIC
+ SHLIBLDFLAGS=-shared $(LDFLAGS)
+- THREAD_LDFLAGS=-lpthread
++ THREAD_LIBS=-lpthread
+
+ BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes
+
+@@ -686,9 +686,9 @@
+ SHLIBCFLAGS=
+ SHLIBLDFLAGS=-shared
+
+- LDFLAGS=-ldl -lm -lgen
++ LDLIBS=-ldl -lm -lgen -lz
+ # FIXME: The X libraries probably aren't necessary?
+- CLIENT_LDFLAGS=-L/usr/X11/$(LIB) $(shell sdl-config --libs) -lGL \
++ CLIENT_LIBS=-L/usr/X11/$(LIB) $(shell sdl-config --libs) -lGL \
+- -lX11 -lXext -lm
++ -lX11 -lXext -lm -ljpeg
+
+ else # ifeq IRIX
+@@ -736,7 +736,7 @@
+ BASE_CFLAGS += -m32
+ LDFLAGS += -m32
+ BASE_CFLAGS += -I/usr/X11/include/NVIDIA
+- CLIENT_LDFLAGS += -L/usr/X11/lib/NVIDIA -R/usr/X11/lib/NVIDIA
++ CLIENT_LIBS += -L/usr/X11/lib/NVIDIA -R/usr/X11/lib/NVIDIA
+ endif
+ endif
+
+@@ -752,12 +752,12 @@
+ SHLIBCFLAGS=-fPIC
+ SHLIBLDFLAGS=-shared $(LDFLAGS)
+
+- THREAD_LDFLAGS=-lpthread
+- LDFLAGS=-lsocket -lnsl -ldl -lm
++ THREAD_LIBS=-lpthread
++ LDLIBS=-lsocket -lnsl -ldl -lm -lz
+
+ BOTCFLAGS=-O0
+
+- CLIENT_LDFLAGS +=$(shell sdl-config --libs) -lGL
++ CLIENT_LIBS +=$(shell sdl-config --libs) -lGL -ljpeg
+
+ else # ifeq sunos
+
+@@ -825,7 +825,7 @@
ifeq ($(USE_INTERNAL_SPEEX),1)
BASE_CFLAGS += -DFLOATING_POINT -DUSE_ALLOCA -I$(SPEEXDIR)/include
else
- CLIENT_LDFLAGS += -lspeex
-+ CLIENT_LDFLAGS += -lspeex -lspeexdsp
++ CLIENT_LIBS += -lspeex -lspeexdsp
endif
endif
+@@ -1421,13 +1421,13 @@
+
+ $(B)/openarena.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ) $(LIBSDLMAIN)
+ $(echo_cmd) "LD $@"
+- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) $(CLIENT_LDFLAGS) \
+- $(LDFLAGS) $(LIBSDLMAIN)
++ $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) \
++ $(LDFLAGS) $(LIBSDLMAIN) $(CLIENT_LIBS) $(LDLIBS)
+
+ $(B)/openarena-smp.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
+ $(echo_cmd) "LD $@"
+- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
+- $(THREAD_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
++ $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) \
++ $(LDFLAGS) $(THREAD_LIBS) $(LIBSDLMAIN) $(CLIENT_LIBS) $(LDLIBS)
+
+ ifneq ($(strip $(LIBSDLMAIN)),)
+ ifneq ($(strip $(LIBSDLMAINSRC)),)
+@@ -1553,7 +1553,7 @@
+
+ $(B)/oa_ded.$(ARCH)$(BINEXT): $(Q3DOBJ)
+ $(echo_cmd) "LD $@"
+- $(Q)$(CC) -o $@ $(Q3DOBJ) $(LDFLAGS)
++ $(Q)$(CC) -o $@ $(Q3DOBJ) $(LDFLAGS) $(LDLIBS)
+
+
+
diff --git a/games-fps/openarena/files/openarena-0.8.1-unbundling.patch b/games-fps/openarena/files/openarena-0.8.1-unbundling.patch
index 34eaac20c4e0..687668e602b8 100644
--- a/games-fps/openarena/files/openarena-0.8.1-unbundling.patch
+++ b/games-fps/openarena/files/openarena-0.8.1-unbundling.patch
@@ -1,71 +1,5 @@
--- openarena-engine-0.8.1/Makefile.old 2010-03-06 21:51:19.000000000 +0100
+++ openarena-engine-0.8.1/Makefile 2010-03-06 21:58:01.000000000 +0100
-@@ -283,9 +283,9 @@
- SHLIBLDFLAGS=-shared $(LDFLAGS)
-
- THREAD_LDFLAGS=-lpthread
-- LDFLAGS=-ldl -lm
-+ LDFLAGS=-ldl -lm -lz
-
-- CLIENT_LDFLAGS=$(shell sdl-config --libs) -lGL
-+ CLIENT_LDFLAGS=$(shell sdl-config --libs) -lGL -ljpeg
-
- ifeq ($(USE_OPENAL),1)
- ifneq ($(USE_OPENAL_DLOPEN),1)
-@@ -560,7 +560,7 @@
-
- THREAD_LDFLAGS=-lpthread
- # don't need -ldl (FreeBSD)
-- LDFLAGS=-lm
-+ LDFLAGS=-lm -lz
-
- CLIENT_LDFLAGS =
-
-@@ -616,7 +616,7 @@
- SHLIBLDFLAGS=-shared $(LDFLAGS)
-
- THREAD_LDFLAGS=-lpthread
-- LDFLAGS=-lm
-+ LDFLAGS=-lm -lz
-
- CLIENT_LDFLAGS =
-
-@@ -644,7 +644,7 @@
- ARCH=i386
- endif
-
-- LDFLAGS=-lm
-+ LDFLAGS=-lm -lz
- SHLIBEXT=so
- SHLIBCFLAGS=-fPIC
- SHLIBLDFLAGS=-shared $(LDFLAGS)
-@@ -683,10 +683,10 @@
- SHLIBCFLAGS=
- SHLIBLDFLAGS=-shared
-
-- LDFLAGS=-ldl -lm -lgen
-+ LDFLAGS=-ldl -lm -lgen -lz
- # FIXME: The X libraries probably aren't necessary?
- CLIENT_LDFLAGS=-L/usr/X11/$(LIB) $(shell sdl-config --libs) -lGL \
-- -lX11 -lXext -lm
-+ -lX11 -lXext -lm -ljpeg
-
- else # ifeq IRIX
-
-@@ -750,11 +750,11 @@
- SHLIBLDFLAGS=-shared $(LDFLAGS)
-
- THREAD_LDFLAGS=-lpthread
-- LDFLAGS=-lsocket -lnsl -ldl -lm
-+ LDFLAGS=-lsocket -lnsl -ldl -lm -lz
-
- BOTCFLAGS=-O0
-
-- CLIENT_LDFLAGS +=$(shell sdl-config --libs) -lGL
-+ CLIENT_LDFLAGS +=$(shell sdl-config --libs) -lGL -ljpeg
-
- else # ifeq sunos
-
@@ -1278,41 +1278,7 @@
$(B)/client/l_script.o \
$(B)/client/l_struct.o \
diff --git a/games-fps/openarena/openarena-0.8.1-r1.ebuild b/games-fps/openarena/openarena-0.8.1-r1.ebuild
index abe6b26aa457..5ab788f0cbe9 100644
--- a/games-fps/openarena/openarena-0.8.1-r1.ebuild
+++ b/games-fps/openarena/openarena-0.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/openarena/openarena-0.8.1-r1.ebuild,v 1.2 2010/03/10 09:54:08 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/openarena/openarena-0.8.1-r1.ebuild,v 1.3 2010/03/12 08:01:05 tupone Exp $
EAPI=2
inherit eutils flag-o-matic versionator games
@@ -39,11 +39,6 @@ src_prepare() {
cd "${WORKDIR}"
epatch "${FILESDIR}"/${P}-makefile.patch \
"${FILESDIR}"/${P}-unbundling.patch
- append-cflags -fno-strict-aliasing # bug #268851
- sed -i \
- -e "s:%CFLAGS%:${CFLAGS}:g" \
- "${MY_S}"/Makefile \
- || die "sed failed"
sed -i \
-e '/ALDRIVER_DEFAULT/s/libopenal.so.0/libopenal.so/' \
"${MY_S}"/code/client/snd_openal.c \
@@ -63,6 +58,7 @@ src_compile() {
cd "${MY_S}"
emake \
+ V=1 \
DEFAULT_BASEDIR="${DIR}" \
BR="${BUILD_DIR}" \
${myopts} \