summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-03-17 07:31:13 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-03-17 07:31:13 +0000
commitdef33116a86eaab0de40f8cd814a62cbef270c63 (patch)
treea4b504b30ceb6bd2528f0667a10710bee7dcdce0 /games-fps
parentBump (diff)
downloadgentoo-2-def33116a86eaab0de40f8cd814a62cbef270c63.tar.gz
gentoo-2-def33116a86eaab0de40f8cd814a62cbef270c63.tar.bz2
gentoo-2-def33116a86eaab0de40f8cd814a62cbef270c63.zip
Version bump to 0.4.2 requested via bug #212706
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/warsow/ChangeLog8
-rw-r--r--games-fps/warsow/files/warsow-0.4.2-build.patch43
-rw-r--r--games-fps/warsow/warsow-0.4.2.ebuild110
3 files changed, 160 insertions, 1 deletions
diff --git a/games-fps/warsow/ChangeLog b/games-fps/warsow/ChangeLog
index 5fbfbb09a56d..24545b4ad427 100644
--- a/games-fps/warsow/ChangeLog
+++ b/games-fps/warsow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/warsow
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.15 2008/02/11 16:23:52 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.16 2008/03/17 07:31:12 tupone Exp $
+
+*warsow-0.4.2 (17 Mar 2008)
+
+ 17 Mar 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/warsow-0.4.2-build.patch, +warsow-0.4.2.ebuild:
+ Version bump to 0.4.2 requested via bug #212706 from Norman Jonas
*warsow-0.4.1 (11 Feb 2008)
diff --git a/games-fps/warsow/files/warsow-0.4.2-build.patch b/games-fps/warsow/files/warsow-0.4.2-build.patch
new file mode 100644
index 000000000000..4ccbd31c68d3
--- /dev/null
+++ b/games-fps/warsow/files/warsow-0.4.2-build.patch
@@ -0,0 +1,43 @@
+--- Makefile
++++ Makefile
+@@ -108,9 +108,9 @@
+ LOCALBASE?=/usr/local
+ X11BASE?=/usr/X11R6
+
+-CFLAGS_COMMON=$(CFLAGS) -I. -I$(LOCALBASE)/include -I$(X11BASE)/include -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -Wall
+-CFLAGS_RELEASE=-O2 -fno-strict-aliasing -ffast-math -funroll-loops -DNDEBUG
+-CFLAGS_DEBUG=-O0 -ggdb -D_DEBUG
++CFLAGS_COMMON=$(CFLAGS) -I. -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -Wall -fno-strict-aliasing
++CFLAGS_RELEASE=-DNDEBUG
++CFLAGS_DEBUG=-D_DEBUG
+ ifeq ($(DEBUG_BUILD),YES)
+ CFLAGS_COMMON+=$(CFLAGS_DEBUG)
+ else
+@@ -125,7 +125,7 @@
+ ifeq ($(OS),FreeBSD)
+ LDFLAGS_COMMON=-L/usr/local/lib -lm
+ else
+-LDFLAGS_COMMON=-L/usr/local/lib -ldl -lm
++LDFLAGS_COMMON=$(LDFLAGS) -ldl -lm
+ endif
+
+ ifeq ($(ARCH),x86_64)
+@@ -353,15 +353,15 @@
+
+ all: client openal qf ded cgame game ui irc tv_server
+
+-client: $(BUILDDIRS) message-client compile-client link-client start-script-client
++client: $(BUILDDIRS) message-client compile-client link-client
+ openal: $(BUILDDIRS) message-openal compile-openal link-openal
+ qf: $(BUILDDIRS) message-qf compile-qf link-qf
+-ded: $(BUILDDIRS) message-ded compile-ded link-ded start-script-ded
++ded: $(BUILDDIRS) message-ded compile-ded link-ded
+ cgame: $(BUILDDIRS) message-cgame compile-cgame link-cgame
+ game: $(BUILDDIRS) message-game compile-game link-game
+ ui: $(BUILDDIRS) message-ui compile-ui link-ui
+ irc: $(BUILDDIRS) message-irc compile-irc link-irc
+-tv_server: $(BUILDDIRS) message-tv_server compile-tv_server link-tv_server start-script-tv_server
++tv_server: $(BUILDDIRS) message-tv_server compile-tv_server link-tv_server
+
+ clean: clean-msg clean-depend clean-client clean-openal clean-qf clean-ded clean-cgame clean-game clean-ui clean-irc clean-tv_server
+
diff --git a/games-fps/warsow/warsow-0.4.2.ebuild b/games-fps/warsow/warsow-0.4.2.ebuild
new file mode 100644
index 000000000000..17f7ba0f7931
--- /dev/null
+++ b/games-fps/warsow/warsow-0.4.2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/warsow-0.4.2.ebuild,v 1.1 2008/03/17 07:31:12 tupone Exp $
+
+inherit eutils toolchain-funcs versionator games
+
+MY_P=${PN}_$(delete_version_separator 2)
+DESCRIPTION="Multiplayer FPS based on the QFusion engine (evolved from Quake 2)"
+HOMEPAGE="http://www.warsow.net/"
+SRC_URI="http://tastyspleen.net/quake/downloads/mods/warsow/${MY_P}_unified.zip
+ http://tastyspleen.net/quake/downloads/mods/warsow/${MY_P}_sdk.zip
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug dedicated irc openal opengl"
+
+UIRDEPEND="media-libs/jpeg
+ media-libs/libvorbis
+ media-libs/libsdl
+ net-misc/curl
+ virtual/opengl
+ x11-libs/libXinerama
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ openal? ( media-libs/openal )"
+RDEPEND="opengl? ( ${UIRDEPEND} )
+ !opengl? ( !dedicated? ( ${UIRDEPEND} ) )"
+UIDEPEND="x11-proto/xineramaproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ x11-misc/makedepend
+ opengl? ( ${UIDEPEND} )
+ !opengl? ( !dedicated? ( ${UIDEPEND} ) )"
+
+S=${WORKDIR}/${MY_P}_src/source
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "/fs_basepath =/ s:\.:${GAMES_DATADIR}/${PN}:" \
+ qcommon/files.c \
+ || die "sed files.c failed"
+
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ yesno() { use ${1} && echo YES || echo NO ; }
+
+ local client="NO" irc="NO" openal="NO"
+ if use opengl || ! use dedicated ; then
+ client="YES"
+ use irc && irc="YES"
+ use openal && openal="YES"
+ fi
+
+ emake \
+ BUILD_CLIENT=${client} \
+ BUILD_SERVER=$(yesno dedicated) \
+ BUILD_TV_SERVER=$(yesno dedicated) \
+ BUILD_IRC=${irc} \
+ BUILD_SND_OPENAL=${openal} \
+ BUILD_SND_QF=${client} \
+ DEBUG_BUILD=$(yesno debug) \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ || die "emake failed"
+}
+
+src_install() {
+ cd release
+
+ if use opengl || ! use dedicated ; then
+ newgamesbin ${PN}.* ${PN} || die "newgamesbin ${PN} failed"
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Warsow
+ fi
+
+ if use dedicated ; then
+ newgamesbin wsw_server.* ${PN}-ded || die "newgamesbin ${PN}-ded failed"
+ newgamesbin wswtv_server.* ${PN}-tv || die "newgamesbin ${PN}-tv failed"
+ fi
+
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe */*.so || die "doexe failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${WORKDIR}"/${MY_P}_unified/basewsw || die "doins failed"
+
+ local so
+ for so in basewsw/*.so ; do
+ dosym "$(games_get_libdir)"/${PN}/${so##*/} \
+ "${GAMES_DATADIR}"/${PN}/${so} || die "dosym ${so} failed"
+ done
+
+ dodir "${GAMES_DATADIR}"/${PN}/libs
+ for so in libs/*.so ; do
+ dosym "$(games_get_libdir)"/${PN}/${so##*/} \
+ "${GAMES_DATADIR}"/${PN}/${so} || die "dosym ${so} failed"
+ done
+
+ dodoc "${WORKDIR}"/docs/*
+ prepgamesdirs
+}