summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-21 06:01:20 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-21 06:01:20 +0000
commitd83553cd11ca67b68038a6b712a439293be9f9c8 (patch)
tree39cd10642d7f416c857d29c1c156caca588034a4 /games-kids
parent(#131361) Filter -Bdirect LDFLAGS setting. (diff)
downloadgentoo-2-d83553cd11ca67b68038a6b712a439293be9f9c8.tar.gz
gentoo-2-d83553cd11ca67b68038a6b712a439293be9f9c8.tar.bz2
gentoo-2-d83553cd11ca67b68038a6b712a439293be9f9c8.zip
Version bump #115691 by maquiz.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/cubetest/ChangeLog10
-rw-r--r--games-kids/cubetest/cubetest-0.9.4.ebuild29
-rw-r--r--games-kids/cubetest/files/cubetest-0.9.4-build.patch52
-rw-r--r--games-kids/cubetest/files/digest-cubetest-0.9.43
4 files changed, 92 insertions, 2 deletions
diff --git a/games-kids/cubetest/ChangeLog b/games-kids/cubetest/ChangeLog
index 3b32f1c82669..90a1ef13d2bf 100644
--- a/games-kids/cubetest/ChangeLog
+++ b/games-kids/cubetest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-kids/cubetest
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/cubetest/ChangeLog,v 1.5 2005/06/10 14:09:19 dholm Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/cubetest/ChangeLog,v 1.6 2006/06/21 06:01:20 vapier Exp $
+
+*cubetest-0.9.4 (21 Jun 2006)
+
+ 21 Jun 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/cubetest-0.9.4-build.patch, +cubetest-0.9.4.ebuild:
+ Version bump #115691 by maquiz.
10 Jun 2005; David Holm <dholm@gentoo.org> cubetest-0.9.3.ebuild:
Added to ~ppc.
diff --git a/games-kids/cubetest/cubetest-0.9.4.ebuild b/games-kids/cubetest/cubetest-0.9.4.ebuild
new file mode 100644
index 000000000000..96b83d5a9ed9
--- /dev/null
+++ b/games-kids/cubetest/cubetest-0.9.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/cubetest/cubetest-0.9.4.ebuild,v 1.1 2006/06/21 06:01:20 vapier Exp $
+
+inherit qt4 eutils games
+
+DESCRIPTION="A program to train your spatial insight"
+HOMEPAGE="http://www.vandenoever.info/software/cubetest/"
+SRC_URI="http://www.vandenoever.info/software/cubetest/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="$(qt_min_version 4)"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ for i in $(find src/ -iname *_moc.cpp) ; do
+ moc ${i/_moc.cpp/.h} -o $i || die
+ done
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+}
diff --git a/games-kids/cubetest/files/cubetest-0.9.4-build.patch b/games-kids/cubetest/files/cubetest-0.9.4-build.patch
new file mode 100644
index 000000000000..052d319b3600
--- /dev/null
+++ b/games-kids/cubetest/files/cubetest-0.9.4-build.patch
@@ -0,0 +1,52 @@
+--- configure
++++ configure
+@@ -19741,13 +19741,16 @@
+ if test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"QtGui >= \$QT_REQUIRED_VERSION
++ QtCore >= \$QT_REQUIRED_VERSION
+ Qt3Support >= \$QT_REQUIRED_VERSION\"") >&5
+ ($PKG_CONFIG --exists --print-errors "QtGui >= $QT_REQUIRED_VERSION
++ QtCore >= $QT_REQUIRED_VERSION
+ Qt3Support >= $QT_REQUIRED_VERSION") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+ pkg_cv_QT_CFLAGS=`$PKG_CONFIG --cflags "QtGui >= $QT_REQUIRED_VERSION
++ QtCore >= $QT_REQUIRED_VERSION
+ Qt3Support >= $QT_REQUIRED_VERSION" 2>/dev/null`
+ else
+ pkg_failed=yes
+@@ -19758,13 +19761,16 @@
+ if test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"QtGui >= \$QT_REQUIRED_VERSION
++ QtCore >= \$QT_REQUIRED_VERSION
+ Qt3Support >= \$QT_REQUIRED_VERSION\"") >&5
+ ($PKG_CONFIG --exists --print-errors "QtGui >= $QT_REQUIRED_VERSION
++ QtCore >= $QT_REQUIRED_VERSION
+ Qt3Support >= $QT_REQUIRED_VERSION") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+ pkg_cv_QT_LIBS=`$PKG_CONFIG --libs "QtGui >= $QT_REQUIRED_VERSION
++ QtCore >= $QT_REQUIRED_VERSION
+ Qt3Support >= $QT_REQUIRED_VERSION" 2>/dev/null`
+ else
+ pkg_failed=yes
+@@ -19775,6 +19781,7 @@
+
+ if test $pkg_failed = yes; then
+ QT_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "QtGui >= $QT_REQUIRED_VERSION
++ QtCore >= $QT_REQUIRED_VERSION
+ Qt3Support >= $QT_REQUIRED_VERSION"`
+ # Put the nasty error message in config.log where it belongs
+ echo "$QT_PKG_ERRORS" 1>&5
+@@ -19849,6 +19842,7 @@
+
+ fi
+
++ QT_CXXFLAGS="$QT_CFLAGS $QT_CXXFLAGS"
+ { echo "$as_me:$LINENO: Set QT_CXXFLAGS... $QT_CXXFLAGS" >&5
+ echo "$as_me: Set QT_CXXFLAGS... $QT_CXXFLAGS" >&6;}
+ { echo "$as_me:$LINENO: Set QT_LIBS... $QT_LIBS" >&5
diff --git a/games-kids/cubetest/files/digest-cubetest-0.9.4 b/games-kids/cubetest/files/digest-cubetest-0.9.4
new file mode 100644
index 000000000000..d7a61977b50e
--- /dev/null
+++ b/games-kids/cubetest/files/digest-cubetest-0.9.4
@@ -0,0 +1,3 @@
+MD5 56dd2b35f972726f369c67bd1b907820 cubetest-0.9.4.tar.bz2 764429
+RMD160 bdf95895965e258915b978e8fa73f95a0ee634bb cubetest-0.9.4.tar.bz2 764429
+SHA256 fa7341a081a4803f26dd95c5ceb998867ed120b2e0ce0a61b758ced37d782521 cubetest-0.9.4.tar.bz2 764429