summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-08-05 02:53:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-08-05 02:53:29 +0000
commit70c9bf7cc21ac8145782ac040e9bb53bf031eaa6 (patch)
treeb56d8149e546fb028b47571819614face6c751a1 /games-misc
parentStable for HPPA (bug #278150). (diff)
downloadgentoo-2-70c9bf7cc21ac8145782ac040e9bb53bf031eaa6.tar.gz
gentoo-2-70c9bf7cc21ac8145782ac040e9bb53bf031eaa6.tar.bz2
gentoo-2-70c9bf7cc21ac8145782ac040e9bb53bf031eaa6.zip
fix building with gcc44 with patch from Fredric Johansson (bug #274001)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/yadex/ChangeLog8
-rw-r--r--games-misc/yadex/files/yadex-1.7.0-elif.patch11
-rw-r--r--games-misc/yadex/yadex-1.7.0.ebuild6
3 files changed, 21 insertions, 4 deletions
diff --git a/games-misc/yadex/ChangeLog b/games-misc/yadex/ChangeLog
index 22641dddbe5f..a94996921f3c 100644
--- a/games-misc/yadex/ChangeLog
+++ b/games-misc/yadex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/yadex
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/yadex/ChangeLog,v 1.8 2009/01/29 08:40:12 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/yadex/ChangeLog,v 1.9 2009/08/05 02:53:29 mr_bones_ Exp $
+
+ 05 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org> yadex-1.7.0.ebuild,
+ +files/yadex-1.7.0-elif.patch:
+ fix building with gcc44 with patch from Fredric Johansson (bug #274001)
29 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> yadex-1.7.0.ebuild:
EAPI=2; respect CC
diff --git a/games-misc/yadex/files/yadex-1.7.0-elif.patch b/games-misc/yadex/files/yadex-1.7.0-elif.patch
new file mode 100644
index 000000000000..a170cbe0ad77
--- /dev/null
+++ b/games-misc/yadex/files/yadex-1.7.0-elif.patch
@@ -0,0 +1,11 @@
+--- src/gfx.cc.old 2009-08-01 18:47:46.000000000 +0200
++++ src/gfx.cc 2009-08-01 18:46:03.000000000 +0200
+@@ -310,7 +310,7 @@
+ win_vis_id = vis_info->visualid;
+ #if defined _cplusplus || defined __cplusplus
+ win_vis_class = vis_info->c_class;
+-#elif
++#else
+ win_vis_class = vis_info->class;
+ #endif
+ win_ncolours = vis_info->colormap_size;
diff --git a/games-misc/yadex/yadex-1.7.0.ebuild b/games-misc/yadex/yadex-1.7.0.ebuild
index 7349ac3fdc14..70dc87b3917b 100644
--- a/games-misc/yadex/yadex-1.7.0.ebuild
+++ b/games-misc/yadex/yadex-1.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/yadex/yadex-1.7.0.ebuild,v 1.10 2009/01/29 08:40:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/yadex/yadex-1.7.0.ebuild,v 1.11 2009/08/05 02:53:29 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -22,9 +22,11 @@ src_prepare() {
-e '/iwad/s/local\///' \
"${S}"/yadex.cfg \
|| die "sed yadex.cfg failed"
- epatch "${FILESDIR}/${P}"-NULL-is-not-zero.patch
+ epatch "${FILESDIR}/${P}"-NULL-is-not-zero.patch \
+ "${FILESDIR}/${P}"-elif.patch
# Force the patched file to be old, otherwise the compile fails
touch -t 196910101010 "${S}"/src/wadlist.cc
+ touch -t 196910101010 "${S}"/src/gfx.cc
}
src_configure() {