summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 23:49:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 23:49:32 +0000
commitc0681a0e446e8f48d2d94db1d3909ccbce8db091 (patch)
treec24a4b9accdbc6f19e99e61ee3c7a35ffbed8cda /games-mud/tf
parentversion bump (diff)
downloadgentoo-2-c0681a0e446e8f48d2d94db1d3909ccbce8db091.tar.gz
gentoo-2-c0681a0e446e8f48d2d94db1d3909ccbce8db091.tar.bz2
gentoo-2-c0681a0e446e8f48d2d94db1d3909ccbce8db091.zip
fix compile with gcc4 (bug #149079) with patch from Alexander Graf; avoid prestripped binaries; tidy
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'games-mud/tf')
-rw-r--r--games-mud/tf/ChangeLog7
-rw-r--r--games-mud/tf/files/digest-tf-40-r26
-rw-r--r--games-mud/tf/files/tf-40-gcc4.patch44
-rw-r--r--games-mud/tf/files/tf-40-gentoo.diff14
-rw-r--r--games-mud/tf/tf-40-r2.ebuild16
5 files changed, 76 insertions, 11 deletions
diff --git a/games-mud/tf/ChangeLog b/games-mud/tf/ChangeLog
index 63a57ae73e51..d67c43790b27 100644
--- a/games-mud/tf/ChangeLog
+++ b/games-mud/tf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-mud/tf
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/ChangeLog,v 1.16 2006/09/02 08:52:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/ChangeLog,v 1.17 2006/10/01 23:49:32 mr_bones_ Exp $
+
+ 01 Oct 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/tf-40-gcc4.patch, files/tf-40-gentoo.diff, tf-40-r2.ebuild:
+ fix compile with gcc4 (bug #149079) with patch from Alexander Graf; avoid
+ prestripped binaries; tidy
02 Sep 2006; Michael Sterrett <mr_bones_@gentoo.org> tf-50_beta7.ebuild:
avoid prestripped binaries; touchups (patch from Tristan Heaven bug #137835)
diff --git a/games-mud/tf/files/digest-tf-40-r2 b/games-mud/tf/files/digest-tf-40-r2
index 6addb20e5c07..28a8c36cab35 100644
--- a/games-mud/tf/files/digest-tf-40-r2
+++ b/games-mud/tf/files/digest-tf-40-r2
@@ -1,2 +1,6 @@
-MD5 db6fa9a1aac0b7f199567d81c4b5c81d tf-40s1.tar.gz 349239
MD5 59b5a3dee0aacabc5472cc041e71961d tf-40s1-help.tar.gz 121936
+RMD160 847833d010f82869e411a87294fa3dd53f2c59ba tf-40s1-help.tar.gz 121936
+SHA256 057668bdbe63e7cd1b5121343ebbfc182956e75feb9e273dd42fe22ce0d45a48 tf-40s1-help.tar.gz 121936
+MD5 db6fa9a1aac0b7f199567d81c4b5c81d tf-40s1.tar.gz 349239
+RMD160 2852daa3363bb134f29cc25d3177e9599ecacc1f tf-40s1.tar.gz 349239
+SHA256 488715d3c75ff05c08a518b0e1cd4518245842fbc1e4178c6da515e415101beb tf-40s1.tar.gz 349239
diff --git a/games-mud/tf/files/tf-40-gcc4.patch b/games-mud/tf/files/tf-40-gcc4.patch
new file mode 100644
index 000000000000..2b96ac03bdd0
--- /dev/null
+++ b/games-mud/tf/files/tf-40-gcc4.patch
@@ -0,0 +1,44 @@
+diff -urpN tf-40s1.orig/src/history.c tf-40s1/src/history.c
+--- tf-40s1.orig/src/history.c 1999-03-06 23:43:24.000000000 +0100
++++ tf-40s1/src/history.c 2006-09-30 18:16:43.000000000 +0200
+@@ -38,18 +38,6 @@
+ #define LOCALSIZE 100 /* local history size */
+ #define INPUTSIZE 100 /* command history buffer size */
+
+-typedef struct History { /* circular list of Alines, and logfile */
+- struct Aline **alines;
+- int size; /* actual number of lines currently saved */
+- int maxsize; /* maximum number of lines that can be saved */
+- int first; /* position of first line in circular array */
+- int last; /* position of last line in circular array */
+- int index; /* current recall position */
+- int total; /* total number of lines ever saved */
+- TFILE *logfile;
+- CONST char *logname;
+-} History;
+-
+ #define empty(hist) (!(hist)->alines || !(hist)->size)
+
+ static void FDECL(alloc_history,(History *hist, int maxsize));
+diff -urpN tf-40s1.orig/src/history.h tf-40s1/src/history.h
+--- tf-40s1.orig/src/history.h 1999-03-06 23:43:24.000000000 +0100
++++ tf-40s1/src/history.h 2006-09-30 18:16:39.000000000 +0200
+@@ -31,6 +31,18 @@ extern void NDECL(free_histories);
+ #define record_global(aline) recordline(globalhist, (aline))
+ #define record_local(aline) recordline(localhist, (aline))
+
++typedef struct History { /* circular list of Alines, and logfile */
++ struct Aline **alines;
++ int size; /* actual number of lines currently saved */
++ int maxsize; /* maximum number of lines that can be saved */
++ int first; /* position of first line in circular array */
++ int last; /* position of last line in circular array */
++ int index; /* current recall position */
++ int total; /* total number of lines ever saved */
++ TFILE *logfile;
++ CONST char *logname;
++} History;
++
+ extern struct History globalhist[], localhist[];
+ extern int log_count, norecord, nolog;
+
diff --git a/games-mud/tf/files/tf-40-gentoo.diff b/games-mud/tf/files/tf-40-gentoo.diff
index 6fc7739c3339..e980f9d1c202 100644
--- a/games-mud/tf/files/tf-40-gentoo.diff
+++ b/games-mud/tf/files/tf-40-gentoo.diff
@@ -1,6 +1,5 @@
-diff -Nur tf-40s1/unix/Config tf-40s1-new/unix/Config
---- tf-40s1/unix/Config Sat Mar 6 16:43:28 1999
-+++ tf-40s1-new/unix/Config Tue Jul 3 15:04:45 2001
+--- unix/Config.orig 2006-10-01 00:13:05.000000000 -0400
++++ unix/Config 2006-10-01 00:14:11.000000000 -0400
@@ -33,9 +33,9 @@
# even if an old version is currently in use. You can remove
# the old version manually later when it is no longer in use.
@@ -34,3 +33,12 @@ diff -Nur tf-40s1/unix/Config tf-40s1-new/unix/Config
# CCFLAGS="-g"
+@@ -117,7 +117,7 @@
+ # tfconfig will use "strip" on the tf binary unless you tell it otherwise.
+ # Set STRIP='' to disable stripping.
+
+-# STRIP=''
++STRIP=''
+
+
+ ### Other Compiler Libraries.
diff --git a/games-mud/tf/tf-40-r2.ebuild b/games-mud/tf/tf-40-r2.ebuild
index 70e938d3cad8..8ccacb88919a 100644
--- a/games-mud/tf/tf-40-r2.ebuild
+++ b/games-mud/tf/tf-40-r2.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/tf-40-r2.ebuild,v 1.8 2004/06/24 23:01:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/tf-40-r2.ebuild,v 1.9 2006/10/01 23:49:32 mr_bones_ Exp $
inherit eutils
MY_P=${P}s1
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="A small full-featured MUD client"
HOMEPAGE="http://tf.tcp.com/~hawkeye/tf/"
SRC_URI="mirror://tinyfugue/${MY_P}.tar.gz
@@ -13,16 +12,21 @@ SRC_URI="mirror://tinyfugue/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~amd64 ~sparc"
+KEYWORDS=" ~amd64 ~sparc x86"
IUSE="doc"
DEPEND=">=sys-libs/ncurses-5.2"
+S=${WORKDIR}/${MY_P}
+
src_unpack() {
unpack ${A}
- cd ${S}
- epatch "${FILESDIR}/${P}-gentoo.diff"
+ cd "${S}"
+ epatch \
+ "${FILESDIR}/${P}-gentoo.diff" \
+ "${FILESDIR}/${P}-gcc4.patch"
}
+
src_compile() {
echo 'y' | ./unixmake config || die
./unixmake all || die