summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
commit36f033373c281af1793a0bdc033d004e9d129f59 (patch)
tree29e637012cd09fb89fbc62b23f6474d0c4ba2bec /games-puzzle/cuyo
parentnative widget stuff now also for gtk (diff)
downloadgentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.tar.gz
gentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.tar.bz2
gentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.zip
IUSE; error check; tidy
Diffstat (limited to 'games-puzzle/cuyo')
-rw-r--r--games-puzzle/cuyo/cuyo-1.8.1.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/games-puzzle/cuyo/cuyo-1.8.1.ebuild b/games-puzzle/cuyo/cuyo-1.8.1.ebuild
index d116e6417c02..f54459115900 100644
--- a/games-puzzle/cuyo/cuyo-1.8.1.ebuild
+++ b/games-puzzle/cuyo/cuyo-1.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/cuyo-1.8.1.ebuild,v 1.4 2004/02/22 10:01:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/cuyo-1.8.1.ebuild,v 1.5 2004/05/12 09:02:45 mr_bones_ Exp $
inherit games
@@ -11,17 +11,20 @@ SRC_URI="http://savannah.nongnu.org/download/cuyo/${P//_}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
+IUSE=""
DEPEND="virtual/glibc
virtual/x11
x11-libs/qt"
-S=${WORKDIR}/${P/_}
+S="${WORKDIR}/${P/_}"
src_unpack() {
unpack ${A}
cd ${S}
- sed -i 's:-O2:@CXXFLAGS@ -Wno-long-long:' src/Makefile.in
+ sed -i \
+ -e 's:-O2:@CXXFLAGS@ -Wno-long-long:' src/Makefile.in \
+ || die "sed src/Makefile.in failed"
}
src_compile() {
@@ -34,11 +37,11 @@ src_compile() {
src_install() {
sed -i \
- 's: $(pkgdatadir: $(DESTDIR)$(pkgdatadir:' \
- data/Makefile
- make install DESTDIR=${D} || die
- dogamesbin ${D}/${GAMES_PREFIX}/games/cuyo
- rm -rf ${D}/${GAMES_PREFIX}/games
+ -e 's: $(pkgdatadir: $(DESTDIR)$(pkgdatadir:' data/Makefile \
+ || die "sed data/Makefile failed"
+ make install DESTDIR=${D} || die "make install failed"
+ dogamesbin "${D}/${GAMES_PREFIX}/games/cuyo"
+ rm -rf "${D}/${GAMES_PREFIX}/games"
dodoc AUTHORS INSTALL NEWS README TODO ChangeLog
prepgamesdirs
}