summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2014-05-18 19:36:54 +0000
committerAlfredo Tupone <tupone@gentoo.org>2014-05-18 19:36:54 +0000
commita6f4bb53b350238c335efb66b454f76b5f313e76 (patch)
treebfd24b1fdcb6e537ddb7b7168eb7fe0cadec8f41 /games-puzzle/gottet
parentVersion bump. (diff)
downloadgentoo-2-a6f4bb53b350238c335efb66b454f76b5f313e76.tar.gz
gentoo-2-a6f4bb53b350238c335efb66b454f76b5f313e76.tar.bz2
gentoo-2-a6f4bb53b350238c335efb66b454f76b5f313e76.zip
Version bump to 1.0.6
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-puzzle/gottet')
-rw-r--r--games-puzzle/gottet/ChangeLog10
-rw-r--r--games-puzzle/gottet/files/gottet-1.0.6-gentoo.patch11
-rw-r--r--games-puzzle/gottet/gottet-1.0.6.ebuild50
3 files changed, 69 insertions, 2 deletions
diff --git a/games-puzzle/gottet/ChangeLog b/games-puzzle/gottet/ChangeLog
index 83b6abe28a32..c32f1f10b3b3 100644
--- a/games-puzzle/gottet/ChangeLog
+++ b/games-puzzle/gottet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/gottet
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gottet/ChangeLog,v 1.9 2013/03/02 21:19:05 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gottet/ChangeLog,v 1.10 2014/05/18 19:36:54 tupone Exp $
+
+*gottet-1.0.6 (18 May 2014)
+
+ 18 May 2014; Tupone Alfredo <tupone@gentoo.org> +gottet-1.0.6.ebuild,
+ +files/gottet-1.0.6-gentoo.patch:
+ Version bump to 1.0.6
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> gottet-1.0.4.ebuild:
Move Qt dependencies to the new category
diff --git a/games-puzzle/gottet/files/gottet-1.0.6-gentoo.patch b/games-puzzle/gottet/files/gottet-1.0.6-gentoo.patch
new file mode 100644
index 000000000000..3b34dae0e261
--- /dev/null
+++ b/games-puzzle/gottet/files/gottet-1.0.6-gentoo.patch
@@ -0,0 +1,11 @@
+--- src/locale_dialog.cpp.old 2014-05-18 18:11:33.546814928 +0200
++++ src/locale_dialog.cpp 2014-05-18 18:40:56.033720946 +0200
+@@ -85,7 +85,7 @@
+ if (paths.isEmpty()) {
+ QString appdir = QCoreApplication::applicationDirPath();
+ paths.append(appdir);
+- paths.append(appdir + "/../share/" + QCoreApplication::applicationName().toLower());
++ paths.append("@GENTOO_DATADIR@/" + QCoreApplication::applicationName().toLower());
+ paths.append(appdir + "/../Resources");
+ }
+ foreach (const QString& path, paths) {
diff --git a/games-puzzle/gottet/gottet-1.0.6.ebuild b/games-puzzle/gottet/gottet-1.0.6.ebuild
new file mode 100644
index 000000000000..3cb452a27eb5
--- /dev/null
+++ b/games-puzzle/gottet/gottet-1.0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gottet/gottet-1.0.6.ebuild,v 1.1 2014/05/18 19:36:54 tupone Exp $
+
+EAPI=5
+
+LANGS="ca de en es fr he ko ms pl ro ru tr vi"
+inherit eutils qt4-r2 games
+
+DESCRIPTION="A tetris clone based on Qt4"
+HOMEPAGE="http://gottcode.org/gottet/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}:" \
+ src/locale_dialog.cpp \
+ || die "sed failed"
+}
+
+src_configure() {
+ qt4-r2_src_configure
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}/translations/
+ for lang in ${LINGUAS};do
+ for x in ${LANGS};do
+ if [[ ${lang} == ${x} ]];then
+ doins translations/${PN}_${x}.qm
+ fi
+ done
+ done
+ insinto /usr/share/icons
+ doins -r icons/hicolor
+ dodoc CREDITS ChangeLog NEWS README
+ doicon icons/${PN}.xpm
+ domenu icons/${PN}.desktop
+ prepgamesdirs
+}