summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-21 06:31:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-21 06:31:49 +0000
commit8ad584cc6bb960b81293b9f0433336926ac11136 (patch)
tree6f700620454bdfb85d8ac804baeb858e9605fcd7 /games-puzzle/ltris
parentctemplate is also a runtime dependency, fixes #338139. (diff)
downloadgentoo-2-8ad584cc6bb960b81293b9f0433336926ac11136.tar.gz
gentoo-2-8ad584cc6bb960b81293b9f0433336926ac11136.tar.bz2
gentoo-2-8ad584cc6bb960b81293b9f0433336926ac11136.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/ltris')
-rw-r--r--games-puzzle/ltris/ChangeLog8
-rw-r--r--games-puzzle/ltris/files/ltris-1.0.15-gentoo.patch51
-rw-r--r--games-puzzle/ltris/ltris-1.0.15.ebuild40
3 files changed, 98 insertions, 1 deletions
diff --git a/games-puzzle/ltris/ChangeLog b/games-puzzle/ltris/ChangeLog
index 83036727c526..f4446969fa93 100644
--- a/games-puzzle/ltris/ChangeLog
+++ b/games-puzzle/ltris/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/ltris
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ChangeLog,v 1.34 2010/05/22 14:50:49 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ChangeLog,v 1.35 2010/09/21 06:31:49 mr_bones_ Exp $
+
+*ltris-1.0.15 (21 Sep 2010)
+
+ 21 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org> +ltris-1.0.15.ebuild,
+ +files/ltris-1.0.15-gentoo.patch:
+ version bump
22 May 2010; Pacho Ramos <pacho@gentoo.org> ltris-1.0.14.ebuild:
stable amd64, bug 302848
diff --git a/games-puzzle/ltris/files/ltris-1.0.15-gentoo.patch b/games-puzzle/ltris/files/ltris-1.0.15-gentoo.patch
new file mode 100644
index 000000000000..82acee7d33bc
--- /dev/null
+++ b/games-puzzle/ltris/files/ltris-1.0.15-gentoo.patch
@@ -0,0 +1,51 @@
+diff -ru ltris-1.0.15.orig/Makefile.am ltris-1.0.15/Makefile.am
+--- ltris-1.0.15.orig/Makefile.am 2010-09-20 13:26:05.000000000 -0400
++++ ltris-1.0.15/Makefile.am 2010-09-21 02:01:52.680858712 -0400
+@@ -1,21 +1,9 @@
+-SUBDIRS = intl m4 po src icons
++SUBDIRS = intl m4 po src
+
+ EXTRA_DIST = config.rpath AUTHORS COPYING ChangeLog INSTALL \
+ README TODO touchall ABOUT-NLS po/tr.po_full po/pt.po_full \
+-po/nonascii.pl ltris32.gif ltris48.gif ltris.desktop.in
+-
+-desktopdir = $(datadir)/applications
+-desktop_DATA = ltris.desktop
+-icondir = $(datadir)/icons
+-icon_DATA = ltris48.gif
++po/nonascii.pl
+
+ AUTOMAKE_OPTIONS = foreign
+
+-# We can't use static desktop file because of icon location. Is this
+-# the right way to handle it? At least it works... as long as $datadir
+-# does not contain plus signs. :-)
+-ltris.desktop:
+- @sed -e "s+Icon=+Icon=$(datadir)/icons/ltris48.gif+" \
+- < ltris.desktop.in > ltris.desktop
+-
+ ACLOCAL_AMFLAGS = -I m4
+diff -ru ltris-1.0.15.orig/configure.in ltris-1.0.15/configure.in
+--- ltris-1.0.15.orig/configure.in 2010-09-20 13:23:17.000000000 -0400
++++ ltris-1.0.15/configure.in 2010-09-21 02:02:22.418843746 -0400
+@@ -55,7 +55,7 @@
+ AC_SUBST(buf_flag)
+
+ dnl set localedir
+-localedir=$datadir/locale
++localedir=/usr/share/locale
+ locdir_flag="-DLOCALEDIR=\\\"$localedir\\\""
+
+ dnl installation path
+diff -ru ltris-1.0.15.orig/po/Makefile.in.in ltris-1.0.15/po/Makefile.in.in
+--- ltris-1.0.15.orig/po/Makefile.in.in 2005-10-04 14:41:03.000000000 -0400
++++ ltris-1.0.15/po/Makefile.in.in 2010-09-21 02:02:40.464207966 -0400
+@@ -23,7 +23,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = /usr/share/locale
+ gettextsrcdir = $(datadir)/gettext/po
+
+ INSTALL = @INSTALL@
diff --git a/games-puzzle/ltris/ltris-1.0.15.ebuild b/games-puzzle/ltris/ltris-1.0.15.ebuild
new file mode 100644
index 000000000000..ffb51ca22a01
--- /dev/null
+++ b/games-puzzle/ltris/ltris-1.0.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ltris-1.0.15.ebuild,v 1.1 2010/09/21 06:31:49 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="very polished Tetris clone"
+HOMEPAGE="http://lgames.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-mixer
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ newicon icons/ltris48.xpm ${PN}.xpm
+ make_desktop_entry ltris LTris
+ prepgamesdirs
+}