summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-12-30 18:25:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-12-30 18:25:42 +0000
commit48154da686ad69c2c858d0350517c6a014e0d893 (patch)
treea4d352a46d0d70e8600b3f7cdad73c7ee4f82e2a /games-puzzle
parentVersion bump. (diff)
downloadgentoo-2-48154da686ad69c2c858d0350517c6a014e0d893.tar.gz
gentoo-2-48154da686ad69c2c858d0350517c6a014e0d893.tar.bz2
gentoo-2-48154da686ad69c2c858d0350517c6a014e0d893.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ltris/ChangeLog8
-rw-r--r--games-puzzle/ltris/files/ltris-1.0.14-gentoo.patch51
-rw-r--r--games-puzzle/ltris/ltris-1.0.14.ebuild40
3 files changed, 98 insertions, 1 deletions
diff --git a/games-puzzle/ltris/ChangeLog b/games-puzzle/ltris/ChangeLog
index 4ff66e12d18d..61361627f7f9 100644
--- a/games-puzzle/ltris/ChangeLog
+++ b/games-puzzle/ltris/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/ltris
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ChangeLog,v 1.28 2009/12/30 13:14:55 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ChangeLog,v 1.29 2009/12/30 18:25:42 mr_bones_ Exp $
+
+*ltris-1.0.14 (30 Dec 2009)
+
+ 30 Dec 2009; Michael Sterrett <mr_bones_@gentoo.org> +ltris-1.0.14.ebuild,
+ +files/ltris-1.0.14-gentoo.patch:
+ version bump
30 Dec 2009; Raúl Porcel <armin76@gentoo.org> ltris-1.0.13.ebuild:
sparc stable wrt #296121
diff --git a/games-puzzle/ltris/files/ltris-1.0.14-gentoo.patch b/games-puzzle/ltris/files/ltris-1.0.14-gentoo.patch
new file mode 100644
index 000000000000..95deb50b032a
--- /dev/null
+++ b/games-puzzle/ltris/files/ltris-1.0.14-gentoo.patch
@@ -0,0 +1,51 @@
+diff -ru ltris-1.0.14.orig/Makefile.am ltris-1.0.14/Makefile.am
+--- ltris-1.0.14.orig/Makefile.am 2009-12-24 09:52:45.000000000 -0500
++++ ltris-1.0.14/Makefile.am 2009-12-30 12:58:42.929781504 -0500
+@@ -1,21 +1,9 @@
+-SUBDIRS = intl m4 po src icons
++SUBDIRS = intl m4 po src
+
+ EXTRA_DIST = config.rpath AUTHORS COPYING ChangeLog INSTALL \
+ README TODO touchall ABOUT-NLS po/tr_full.po po/pt_full.po \
+-po/nonascii.pl ltris32.gif ltris48.gif ltris.desktop.in
+-
+-desktopdir = $(datadir)/applications
+-desktop_DATA = ltris.desktop
+-icondir = $(datadir)/icons
+-icon_DATA = ltris48.gif
++po/nonascii.pl
+
+ AUTOMAKE_OPTIONS = foreign
+
+-# We can't use static desktop file because of icon location. Is this
+-# the right way to handle it? At least it works... as long as $datadir
+-# does not contain plus signs. :-)
+-ltris.desktop:
+- @sed -e "s+Icon=+Icon=$(datadir)/icons/ltris48.gif+" \
+- < ltris.desktop.in > ltris.desktop
+-
+ ACLOCAL_AMFLAGS = -I m4
+diff -ru ltris-1.0.14.orig/configure.in ltris-1.0.14/configure.in
+--- ltris-1.0.14.orig/configure.in 2009-12-24 13:28:12.000000000 -0500
++++ ltris-1.0.14/configure.in 2009-12-30 12:57:18.461780277 -0500
+@@ -53,7 +53,7 @@
+ AC_SUBST(buf_flag)
+
+ dnl set localedir
+-localedir=$datadir/locale
++localedir=/usr/share/locale
+ locdir_flag="-DLOCALEDIR=\\\"$localedir\\\""
+
+ dnl installation path
+diff -ru ltris-1.0.14.orig/po/Makefile.in.in ltris-1.0.14/po/Makefile.in.in
+--- ltris-1.0.14.orig/po/Makefile.in.in 2005-10-04 14:41:03.000000000 -0400
++++ ltris-1.0.14/po/Makefile.in.in 2009-12-30 12:57:00.192041633 -0500
+@@ -23,7 +23,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = /usr/share/locale
+ gettextsrcdir = $(datadir)/gettext/po
+
+ INSTALL = @INSTALL@
diff --git a/games-puzzle/ltris/ltris-1.0.14.ebuild b/games-puzzle/ltris/ltris-1.0.14.ebuild
new file mode 100644
index 000000000000..6140b41adf2f
--- /dev/null
+++ b/games-puzzle/ltris/ltris-1.0.14.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ltris-1.0.14.ebuild,v 1.1 2009/12/30 18:25:42 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="very polished Tetris clone"
+HOMEPAGE="http://lgames.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-mixer
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ newicon icons/ltris48.xpm ${PN}.xpm
+ make_desktop_entry ltris LTris
+ prepgamesdirs
+}