summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-13 12:58:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-13 12:58:54 +0000
commit6c883eedd55769c778c7838cbe4ca292e15ac873 (patch)
treec265583e60e0d238e132c705e44e408cc9ba9e9a /games-puzzle
parentClean up unneeded tora mask (diff)
downloadgentoo-2-6c883eedd55769c778c7838cbe4ca292e15ac873.tar.gz
gentoo-2-6c883eedd55769c778c7838cbe4ca292e15ac873.tar.bz2
gentoo-2-6c883eedd55769c778c7838cbe4ca292e15ac873.zip
Install missing words file wrt #300792, thanks to Johannes Rauh for reporting.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/connectagram/ChangeLog9
-rw-r--r--games-puzzle/connectagram/connectagram-1.0.1-r1.ebuild49
-rw-r--r--games-puzzle/connectagram/connectagram-1.0.1.ebuild29
3 files changed, 57 insertions, 30 deletions
diff --git a/games-puzzle/connectagram/ChangeLog b/games-puzzle/connectagram/ChangeLog
index 9b9198c49f81..e02ca5952dd7 100644
--- a/games-puzzle/connectagram/ChangeLog
+++ b/games-puzzle/connectagram/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-puzzle/connectagram
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/connectagram/ChangeLog,v 1.1 2010/01/06 00:44:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/connectagram/ChangeLog,v 1.2 2010/01/13 12:58:54 ssuominen Exp $
+
+*connectagram-1.0.1-r1 (13 Jan 2010)
+
+ 13 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
+ connectagram-1.0.1.ebuild, +connectagram-1.0.1-r1.ebuild:
+ Install missing words file wrt #300792, thanks to Johannes Rauh for
+ reporting.
*connectagram-1.0.1 (06 Jan 2010)
diff --git a/games-puzzle/connectagram/connectagram-1.0.1-r1.ebuild b/games-puzzle/connectagram/connectagram-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..abba3c5db478
--- /dev/null
+++ b/games-puzzle/connectagram/connectagram-1.0.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/connectagram/connectagram-1.0.1-r1.ebuild,v 1.1 2010/01/13 12:58:54 ssuominen Exp $
+
+EAPI=2
+inherit gnome2-utils qt4 games
+
+DESCRIPTION="A word unscrambling game"
+HOMEPAGE="http://gottcode.org/connectagram/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4"
+
+src_prepare() {
+ sed -i \
+ -e "/PREFIX/s:/usr/local:/usr:" \
+ -e "/target.path/s:\$\$PREFIX/bin:${GAMES_BINDIR}:" \
+ -e "/definitions.path/s:\$\$PREFIX/share:${GAMES_DATADIR}:" \
+ ${PN}.pro || die
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die
+ dodoc ChangeLog
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ games_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ games_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-puzzle/connectagram/connectagram-1.0.1.ebuild b/games-puzzle/connectagram/connectagram-1.0.1.ebuild
deleted file mode 100644
index 1189a846095f..000000000000
--- a/games-puzzle/connectagram/connectagram-1.0.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/connectagram/connectagram-1.0.1.ebuild,v 1.1 2010/01/06 00:44:22 ssuominen Exp $
-
-EAPI=2
-inherit eutils qt4 games
-
-DESCRIPTION="A word unscrambling game"
-HOMEPAGE="http://gottcode.org/connectagram/"
-SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="x11-libs/qt-gui:4"
-
-src_configure() {
- eqmake4
-}
-
-src_install() {
- dogamesbin bin/${PN} || die
- dodoc ChangeLog
- doicon icons/${PN}.png
- domenu icons/${PN}.desktop
- prepgamesdirs
-}