summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-06-29 16:22:25 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-06-29 16:22:25 +0000
commitfdcd35f0006128762171f7e4d615cbc39293559b (patch)
tree6a117abf5fcf6b3dda902e7580551dfe6924981d /games-puzzle
parentFixed binaries being pre-stripped. Thanks to Tristan Heaven <tristanheaven@g... (diff)
downloadgentoo-2-fdcd35f0006128762171f7e4d615cbc39293559b.tar.gz
gentoo-2-fdcd35f0006128762171f7e4d615cbc39293559b.tar.bz2
gentoo-2-fdcd35f0006128762171f7e4d615cbc39293559b.zip
Fixed binaries being pre-stripped. Thanks to Tristan Heaven <tristanheaven@gmail.com> for the patch. Closing bug #137741.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/xwelltris/ChangeLog7
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1.ebuild10
2 files changed, 14 insertions, 3 deletions
diff --git a/games-puzzle/xwelltris/ChangeLog b/games-puzzle/xwelltris/ChangeLog
index 9257b1ad62b0..e219e97f1e86 100644
--- a/games-puzzle/xwelltris/ChangeLog
+++ b/games-puzzle/xwelltris/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/xwelltris
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/ChangeLog,v 1.8 2006/01/20 20:43:19 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/ChangeLog,v 1.9 2006/06/29 16:22:25 wolf31o2 Exp $
+
+ 29 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ xwelltris-1.0.1.ebuild:
+ Fixed binaries being pre-stripped. Thanks to Tristan Heaven
+ <tristanheaven@gmail.com> for the patch. Closing bug #137741.
20 Jan 2006; Chris Gianelloni <wolf31o2@gentoo.org>
xwelltris-1.0.1.ebuild:
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
index 2b4519452063..6fed45e55a2a 100644
--- a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.11 2006/01/20 20:43:19 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.12 2006/06/29 16:22:25 wolf31o2 Exp $
inherit games
@@ -30,9 +30,15 @@ DEPEND="${RDEPEND}
x11-libs/libX11
virtual/x11 )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i '/INSTALL_PROGRAM/s/-s //' src/Make.common.in || die "sed failed"
+}
+
src_compile() {
# configure/build process is pretty messed up
- egamesconf $(use_with sdl) || die
+ egamesconf $(use_with sdl) || die "egamesconf failed"
sed -i \
-e "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
src/include/globals.h \