summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-09-17 22:03:12 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-09-17 22:03:12 +0000
commita4f07ceb775cc1d02153b0a6bf18d5a1d2262d26 (patch)
tree64d3a9d19d9f875e8f6ce6533033d420045313e7 /games-roguelike
parentnew package for controlling LIRC remotes (diff)
downloadgentoo-2-a4f07ceb775cc1d02153b0a6bf18d5a1d2262d26.tar.gz
gentoo-2-a4f07ceb775cc1d02153b0a6bf18d5a1d2262d26.tar.bz2
gentoo-2-a4f07ceb775cc1d02153b0a6bf18d5a1d2262d26.zip
Version bump to 2.3.5. Bug #222891
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/tome/ChangeLog8
-rw-r--r--games-roguelike/tome/files/2.3.5-gentoo-paths.patch31
-rw-r--r--games-roguelike/tome/tome-2.3.5.ebuild128
3 files changed, 166 insertions, 1 deletions
diff --git a/games-roguelike/tome/ChangeLog b/games-roguelike/tome/ChangeLog
index a0de614615ca..8c6a251134c0 100644
--- a/games-roguelike/tome/ChangeLog
+++ b/games-roguelike/tome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-roguelike/tome
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.29 2008/01/14 20:35:11 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.30 2008/09/17 22:03:11 tupone Exp $
+
+*tome-2.3.5 (17 Sep 2008)
+
+ 17 Sep 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/2.3.5-gentoo-paths.patch, +tome-2.3.5.ebuild:
+ Version bump to 2.3.5. Bug #222891 by Elio Cuevas Gómez
14 Jan 2008; Fabian Groffen <grobian@gentoo.org> tome-2.3.1.ebuild,
tome-2.3.4.ebuild:
diff --git a/games-roguelike/tome/files/2.3.5-gentoo-paths.patch b/games-roguelike/tome/files/2.3.5-gentoo-paths.patch
new file mode 100644
index 000000000000..d171a1cf540f
--- /dev/null
+++ b/games-roguelike/tome/files/2.3.5-gentoo-paths.patch
@@ -0,0 +1,31 @@
+diff -rU 1 tome-225-src.orig/src/files.c tome-225-src/src/files.c
+--- tome-225-src.orig/src/files.c 2004-01-14 11:17:02.423263360 -0500
++++ tome-225-src/src/files.c 2004-01-14 11:17:50.074019344 -0500
+@@ -5670,3 +5670,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -5748,3 +5748,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -5846,3 +5846,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -6296,3 +6296,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+diff -rU 1 tome-225-src.orig/src/init2.c tome-225-src/src/init2.c
+--- tome-225-src.orig/src/init2.c 2004-01-14 11:17:02.473255760 -0500
++++ tome-225-src/src/init2.c 2004-01-14 11:17:58.286770816 -0500
+@@ -6686,3 +6686,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
diff --git a/games-roguelike/tome/tome-2.3.5.ebuild b/games-roguelike/tome/tome-2.3.5.ebuild
new file mode 100644
index 000000000000..91efd3e777d0
--- /dev/null
+++ b/games-roguelike/tome/tome-2.3.5.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/tome-2.3.5.ebuild,v 1.1 2008/09/17 22:03:11 tupone Exp $
+
+inherit eutils games
+
+MY_PV=${PV//./}
+DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
+HOMEPAGE="http://t-o-m-e.net/"
+SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tar.bz2"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X Xaw3d gtk sdl"
+
+RDEPEND=">=sys-libs/ncurses-5
+ X? ( x11-libs/libX11 )
+ Xaw3d? ( x11-libs/libXaw )
+ sdl? (
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/libsdl )
+ gtk? ( >=x11-libs/gtk+-2.12.8 ) "
+DEPEND="${REDEPEND}
+ x11-misc/makedepend"
+
+S=${WORKDIR}/tome-${MY_PV}-src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cd "src"
+ mv makefile.std makefile
+ epatch "${FILESDIR}/${PV}-gentoo-paths.patch"
+ sed -i \
+ -e "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c \
+ || die "sed failed"
+
+ find "${S}" -name .cvsignore -exec rm -f \{\} \;
+ find "${S}/lib/edit" -type f -exec chmod a-x \{\} \;
+}
+
+src_compile() {
+ local GENTOO_INCLUDES="" GENTOO_DEFINES="-DUSE_GCU " GENTOO_LIBS="-lncurses"
+ if use sdl || use X || use gtk || use Xaw3d; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_EGO_GRAPHICS -DUSE_TRANSPARENCY \
+ -DSUPPORT_GAMMA"
+ fi
+ if use sdl || use X || use Xaw3d; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_PRECISE_CMOVIE -DUSE_UNIXSOCK "
+ fi
+ if use sdl; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} $(sdl-config --cflags)"
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_SDL "
+ GENTOO_LIBS="${GENTOO_LIBS} $(sdl-config --libs) -lSDL_image -lSDL_ttf"
+ fi
+ if use X; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_X11 "
+ GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lX11 "
+ fi
+ if use Xaw3d; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_XAW "
+ GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lXaw -lXmu -lXt -lX11 "
+ fi
+ if use gtk; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} $(pkg-config gtk+-2.0 --cflags)"
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_GTK2 "
+ GENTOO_LIBS="${GENTOO_LIBS} $(pkg-config gtk+-2.0 --libs) "
+ GTK_SRC_FILE="main-gtk2.c"
+ GTK_OBJ_FILE="main-gtk2.o"
+ else
+ GTK_SRC_FILE=""
+ GTK_OBJ_FILE=""
+ fi
+ if use amd64; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DLUA_NUM_TYPE=int "
+ fi
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -Ilua -I."
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_LUA"
+ cd src
+ make \
+ INCLUDES="${GENTOO_INCLUDES}" \
+ DEFINES="${GENTOO_DEFINES}" \
+ depend || die "make depend failed"
+ emake ./tolua || die "emake ./tolua failed"
+ emake \
+ COPTS="${CFLAGS}" \
+ INCLUDES="${GENTOO_INCLUDES}" \
+ DEFINES="${GENTOO_DEFINES}" \
+ LIBS="${GENTOO_LIBS}" \
+ BINDIR="${GAMES_BINDIR}" \
+ LIBDIR="${GAMES_DATADIR}/${PN}" \
+ GTK_SRC_FILE="${GTK_SRC_FILE}" \
+ GTK_OBJ_FILE="${GTK_OBJ_FILE}" \
+ || die "emake failed"
+}
+
+src_install() {
+ cd src
+ make \
+ DESTDIR="${D}" \
+ OWNER="${GAMES_USER}" \
+ BINDIR="${GAMES_BINDIR}" \
+ LIBDIR="${GAMES_DATADIR}/${PN}" install \
+ || die "make install failed"
+ cd "${S}"
+ dodoc *.txt
+
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}/${GAMES_STATEDIR}/${PN}-scores.raw"
+ prepgamesdirs
+ fperms g+w "${GAMES_STATEDIR}/${PN}-scores.raw"
+ #FIXME: something has to be done about this.
+ fperms g+w "${GAMES_DATADIR}/${PN}/data"
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "ToME ${PV} is not save-game compatible with 2.3.0 and previous versions."
+ echo
+ ewarn "If you have older save files and you wish to continue those games,"
+ ewarn "you'll need to remerge the version of ToME with which you started"
+ ewarn "those save-games."
+}