summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-01-06 12:39:44 +0000
committerRoy Marples <uberlord@gentoo.org>2007-01-06 12:39:44 +0000
commit3e47ecfe8215db8c55ce95ca63801aa2bd7c64c6 (patch)
treed85aead81a0daefd33363a8d904a784f995f4ede /games-rpg/eternal-lands
parentNew release, #159336 (diff)
downloadgentoo-2-3e47ecfe8215db8c55ce95ca63801aa2bd7c64c6.tar.gz
gentoo-2-3e47ecfe8215db8c55ce95ca63801aa2bd7c64c6.tar.bz2
gentoo-2-3e47ecfe8215db8c55ce95ca63801aa2bd7c64c6.zip
New release, #159336
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'games-rpg/eternal-lands')
-rw-r--r--games-rpg/eternal-lands/ChangeLog10
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.3.3.ebuild128
-rw-r--r--games-rpg/eternal-lands/files/digest-eternal-lands-1.3.36
3 files changed, 142 insertions, 2 deletions
diff --git a/games-rpg/eternal-lands/ChangeLog b/games-rpg/eternal-lands/ChangeLog
index 48b460f39736..115c0c66c259 100644
--- a/games-rpg/eternal-lands/ChangeLog
+++ b/games-rpg/eternal-lands/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/eternal-lands
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.31 2006/12/06 20:20:09 wolf31o2 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.32 2007/01/06 12:39:44 uberlord Exp $
+
+*eternal-lands-1.3.3 (06 Jan 2007)
+
+ 06 Jan 2007; Roy Marples <uberlord@gentoo.org>
+ +eternal-lands-1.3.3.ebuild:
+ New release, #159336.
06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
eternal-lands-1.3.2-r1.ebuild:
diff --git a/games-rpg/eternal-lands/eternal-lands-1.3.3.ebuild b/games-rpg/eternal-lands/eternal-lands-1.3.3.ebuild
new file mode 100644
index 000000000000..9328c1f33577
--- /dev/null
+++ b/games-rpg/eternal-lands/eternal-lands-1.3.3.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.3.3.ebuild,v 1.1 2007/01/06 12:39:44 uberlord Exp $
+
+inherit eutils flag-o-matic games
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+S="${WORKDIR}/elc"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="mirror://gentoo/elc_${MY_PV}.tar.bz2
+ mirror://gentoo/eternal-lands.png"
+
+# NOTE: Sometimes you'll have to roll your own elc tarball from their CVS
+# tree as they don't always release one.
+# If they do then use this in SRC_URI instead
+# ftp://ftp.berlios.de/pub/elc/elc_${MY_PV}.tgz
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="debug doc kernel_linux"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ virtual/opengl
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-net-1.2.5
+ media-libs/openal
+ media-libs/freealut
+ media-libs/libvorbis
+ >=dev-libs/libxml2-2.6.7
+ media-libs/cal3d
+ !=media-libs/cal3d-0.11.0_pre20050823
+ >=media-libs/libpng-1.2.8
+ ~games-rpg/${PN}-data-${PV}"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( >=app-doc/doxygen-1.3.8
+ >=media-gfx/graphviz-1.10 )"
+
+src_unpack() {
+ OPTIONS="-DDATA_DIR="\\\\\"${GAMES_DATADIR}/${PN}/\\\\\"""
+ S_CLIENT="${WORKDIR}/elc"
+ BROWSER="firefox"
+
+ unpack ${A}
+ cd "${S}"
+
+ # Create updated files with correct perms and allow dir creation
+ epatch "${FILESDIR}/${PN}-1.3.0-update-createdir.patch"
+
+ # Build for amd64
+ use amd64 && OPTIONS="${OPTIONS} -DX86_64"
+
+ # This should be default in the next version
+ OPTIONS="${OPTIONS} -DUSE_ACTOR_DEFAULTS"
+
+ # Add debugging options
+ if use debug ; then
+ OPTIONS="${OPTIONS} -DMEMORY_DEBUG"
+ append-flags -ggdb
+ fi
+
+ sed \
+ -e "s@CFLAGS=\$(PLATFORM) \$(CWARN) -O0 -ggdb -pipe@CFLAGS=${CFLAGS} ${OPTIONS} @g"\
+ -e "s@CXXFLAGS=\$(PLATFORM) \$(CXXWARN) -O0 -ggdb -pipe@CXXFLAGS=${CXXFLAGS} ${OPTIONS} @g"\
+ -e 's/lopenal/lopenal -l alut/' \
+ Makefile.linux > Makefile \
+ || die "sed failed"
+ sed -i \
+ -e 's/#browser/browser/g' \
+ -e "s/browser = mozilla/#browser = ${BROWSER}/g" \
+ -e "s@#data_dir = /usr/local/games/el/@#data_dir = ${GAMES_DATADIR}/${PN}/@g" \
+ el.ini || die "sed failed"
+
+ # Support BSD in the Linux makefile - it's easier
+ use kernel_linux || sed -i -e 's/^CFLAGS=.*/& -DBSD/' Makefile || die "sed failed"
+
+ # Gah
+ sed -i -e 's/CXX=g++/CXX=gcc/' Makefile || die "sed failed"
+
+ # Finally, update the server
+ sed -i -e '/#server_address =/ s/.*/#server_address = game.eternal-lands.com/' \
+ el.ini || die "sed failed"
+}
+
+src_compile() {
+ emake || die "make failed"
+ if use doc; then
+ emake docs || die "Failed to create documentation, try with USE=-doc"
+ mv ./docs/html/ ../client || die "Failed to move documentation directory"
+ fi
+}
+
+src_install() {
+ newgamesbin el.x86.linux.bin el || die "newgamesbin failed"
+ doicon "${DISTDIR}/eternal-lands.png"
+ make_desktop_entry el "Eternal Lands"
+
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r *.ini *.txt commands.lst || die "doins failed"
+
+ if use doc ; then
+ dohtml -r client/*
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ einfo "Auto Update is now enabled in Eternal Lands"
+ ewarn "If an update occurs then the client will suddenly exit"
+ einfo "Updates only happen when the game first loads"
+ einfo "Please don't report this behaviour as a bug"
+
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${PN}" -type d -exec chmod g+sx {} \;
+}
diff --git a/games-rpg/eternal-lands/files/digest-eternal-lands-1.3.3 b/games-rpg/eternal-lands/files/digest-eternal-lands-1.3.3
new file mode 100644
index 000000000000..65de4adf771f
--- /dev/null
+++ b/games-rpg/eternal-lands/files/digest-eternal-lands-1.3.3
@@ -0,0 +1,6 @@
+MD5 89d431082f20cb198e82bd44b00fe1a3 elc_133.tar.bz2 859803
+RMD160 0f70bbf218a2e85cd2c81eb2bb238eda3c6f7f5b elc_133.tar.bz2 859803
+SHA256 2abe7161bd329014b5e881573c1777cb42c03b8a5684fecf25abd7a2a23f3659 elc_133.tar.bz2 859803
+MD5 059df8128b11b19a76b54e9907072f00 eternal-lands.png 9955
+RMD160 2f9c8acd96214577cf8b8027f0d20fb1fe7574ff eternal-lands.png 9955
+SHA256 dd7d45cd9948fe7875ebd0bfcd1925d9b34e7606a223faf61d37a6dd2cd433fb eternal-lands.png 9955